Set up AX210 step by step

CPU	Intel(R) Celeron(R) CPU 5205U @ 1.90GHz
kernel version 5.10.135
  1. You should install iwlwifi which is the official driver for ax210.
  2. go to intel official website to download the firmware https://www.intel.com/content/www/us/en/support/articles/000005511/wireless.html
    we can the content " Intel® Wi-Fi 6 AX210 160MHz 5.10+ iwlwifi-ty-59.601f3a66.0.tgz"
  3. unzip the iwlwifi-ty-59.601f3a66.0.tgz and copy the file to the /lib/firmware/
  4. Use lspci command to check the ax210 path.
03:00.0 Network controller: Intel Corporation Wi-Fi 6 AX210/AX211/AX411 160MHz (rev 1a)
  1. go to the /sys/bus/pci/devices, and you will see the device id. You should find the "03:00.0"
  2. enter the dictionary and use pwd command to get the absolute path.
  3. edit the /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option country 'US'
        option cell_density '0'
        option path 'pci0000:00/0000:00:1d.0/0000:03:00.0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:1d.0/0000:03:00.0'
        option band '5g'
        option htmode 'HE80'
        option cell_density '0'
        option country 'US'
  1. reboot ! And you will find the driver works well.
1 Like

What's the problem with opkg install iwlwifi-firmware-ax210?
While that package didn't exist for 21.02.x, it does for 22.03~ (and your 5.10.135 kernel confirms you using openwrt-22.03 and not earlier versions).

Well, my mistake. I forget the opkg which can install firmware ax210 directly. So I download the firmware from the intel official website. :rofl:

How does this work for country NL and a ax200

ax200 <> ax210

try with an openwrt snapshot image ?

so now you can enable 6e AP (6GHz band - ax210) ? what about ax200 - 5GHz band ?

trial and error ?

Neither the 5 GHz band, nor the 6 GHz band (on the ax210) will support AP mode - only the 2.4 GHz band and only in a very limited fashion (one VAP, not officially supported/ tested by Intel - here are dragons). The situation is identical for ax200 and ax210 (with the obvious naming difference for the firmware package and their corresponding technical specs).

1 Like

There is a patch that will make the 5 GHz band work on a ax200

I'm aware of that, but that's not really anywhere on the table for quite some time to come (DFS remains unobtainium and it's not really a supported configuration; ax210 remains very limited in many regards as well (only one AP interface)).

1 Like

Also ntice some requests on intel forums about being limited to 12 clients in AP mode. Can anyone confirm?

My /etc/config/ directory does not contain a wireless subdirectory and my webUI doesn't have Wireless under networking. I have installed pkgs:
kmod-cfg80211
iw
iwinfo
iwlwifi-firmware-ax210
wpad-basic
What am I missing? I'm running OpenWrt 22.03.0 on x86/64
I cannot find a way to add the wifi devices. Any guidance is appreciated.

It's a file, not a dir, info's in the 1st post.

Thanks for clarifying. The only files inside my /etc/config/ directory are:
DHCP
dropbear
firewall
luci
network
rpcd
system
ucitrack
uhttpd

There is no wireless file. Am I missing a pkg or was I supposed to choose "overwrite" when pkgs had items already installed? I never checked the box to overwrite.

Create one, with the content from the 1st post?

Sadly, I'm a beginner who doesn't know much about the command language for OpenWrt. I'm looking now, but not much about create files on only seem to find info about editing. Any guidance to documentation or steps is appreciated.

Command line language is plain Linux.

Or use winscp from a Win host, to connect to the router, and edit/create the file.

1 Like

Thanks so much for the resource. I added the config file above and now I do have a Wireless drop-down now menu with two items called:
Radio0 Generic 802.11bg
Radio1 Generic 802.11bg

Restart, Scan, Add don't do anything but throw out an error.
Under Networking, Interfaces, Devices - I don't see anything new to add.

For these parameters in the config file "option path 'pci0000:00/0000:00:1d.0/0000:03:00.0'"
Am I supposed to enter exactly what is listed here or are some of these variables I am supposed to replace?