Tp-link tl-wr940n v4 problems for install

Good morning, everyone,

I am sorry for my English and also for the question that will follow and that has already had to be asked.
But here I am trying to install openwrt on a tl-wr940n v4 and I can't do it.
Through the update menu it gives me an error message:

Error code: 18005
Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name.

And not tftp nothing happens when I boot with the reset button pressed.

I don't know where to look and there's no tutorial bcp could you help me?

Thank you in advance

Translated with

Use correct firmware for country device (e.g. US, RU, EU, etc.).

thank you for your answer,
I have requested my firmware on this web page:

I don't think I have any distinction between regions.


Please re-read the web page:

Comment installation:

For TFTP, rename -factory image to wr940nv4_tp_recovery.bin

Recovery method(s):

U-Boot TFTP recovery, U-Boot TFTP + serial recovery

Comment recovery:

For TFTP, rename -factory image to wr940nv4_tp_recovery.bin

Wayne if you're here not to help me (yet I see you active elsewhere) and just put things I've already tried or read, you can go your way!

What you show me I have already read it and done 10,000 times without success is why I ask a question here ! if I could have avoided thinking that I would have done without a question on the forum...

So it's a question of

rename the file = don't work
Your link = no answer to my question
Recovery method(s):U-Boot TFTP recovery recovery 1, U-Boot TFTP + serial recovery = no viable link

If you don't help me, thank you for going elsewhere, otherwise thank you for guiding me better than that

Newer versions of the stock TP-Link firmware do a signature or some other as yet unknown check on the firmware submitted to the web page, and are going to give error 18005 on any third-party firmware. It is necessary to use TFTP or serial.

There isn't a lot of developer interest or support for 4/32 devices since the small memory limits what OpenWrt can do. (That isn't to say you should not run OpenWrt, since it still can do a lot more than the stock firmware does.) I don't see any specific instructions for this model. Some generic instructions are here:

When you boot with the reset button pressed the bootloader should go out and look for your TFTP server. So you need to have a TFTP server running on your PC. Using Wireshark or other packet monitoring program will show exactly what it is looking for.


You never said that renaming the file didn't work. Also, you never mentioned in the first post that you renamed the file. In the future, please inform us, instead of getting mad.

LOL, there were answers

You should be able to TFTP and it does not look for a regional code (the error 18005).

2 (a response I wrote regarding the SAME MODEL-different version!!!):

We're not psychic...we don't even know what language you're translating form.

Thank you for all these useful and enefic instructions for me

very funny it's very easy and it shows a little intelligence to make fun of it.....

I'm not making fun. I can't guess that you'll get angry because you have to read posts (in a foreign language) on error 18005.

I was making note - that you posted a link to a translator, but never said what language to translate to.

I am willing to speak in your native language, if its the cause of your anger.

Did you succeed in TFTPing the file, and bypassing the 18005 error?
¿Tuvo éxito en TFTPing el archivo y omitió el error 18005?
Avez-vous réussi à TFTPing le fichier et à contourner l’erreur 18005?

Reading in a foreign language is not what makes me angry... reread posts I have already read before posting either.
It is not the content that bothers me (because I have succeeded thanks to you and your tracks) but the form that is really not pleasant and more than dismissive.
As a result, everything that follows behind in your answers looks more like an attack than a help.

Anyway, I managed to install it.

Now I need help to change the basic ip address from to

I've tried many times but it makes me a rollerback

Thank you for your help

:+1: :peace_symbol:

OK...You have 4 options...I suggest them in this order:

  • Hit "Apply Unchecked" if/when it appears
  • Make the changes on CLI/UCI in /etc/config/network and do an /etc/init.d/network reload
  • Within the 30 seconds, get a new DHCP lease and browse to the new IP
  • Make the changes from an interface that will not experience an IP change.

(This information was also locatable by searching the community.)

Ok but "Apply Unchecked" crash my router and I'm forced to do a reset it's better if I pass part /etc /init.d/network?

Describe what you mean by "crash"?

Unless you misconfigured your LAN, hitting "Apply Unchecked" shouldn't cause such an issue.

That's your choice:

  • Edit the option ipaddr LAN section in /etc/config/network

  • Save

  • Then run /etc/init.d/network reload


thanks for your help I will test this, but nano is not installed it is what is the editor put on openwrt?

Do you have a complete tutorial on the configuration of openwrt but in..... French :slight_smile:
because I have a lot of gaps.

If it is truly "crashing" your router, then capturing the logs, perhaps by ssh-ing into the box and running logread so they remain on your terminal screen for easy copying, would help determine if there is a bug.

When making IP address changes of this sort, on OpenWrt or otherwise, I always make sure I have connectivity to the device that will "survive" changes or errors. This can include, for example:

  • Serial or other console access
  • Creating a management interface in advance of the change

If I didn't have console access, I would:

  • Create a new interface with a static IP address that isn't in either my "old" or "new" LAN subnet
  • Configure the switch to connect that interface to either a specific LAN socket, or over a VLAN
  • Configure my "desktop" to be able to connect to the management interface and confirm it works
  • Change the LAN network configuration using the management interface

For me, a separate management interface (on a VLAN, if possible) is among my first steps on any device, OpenWrt or otherwise.

1 Like

vim - Vi IMproved

You can also install nano if you have enough space:

opkg update
opkg install nano

:+1: Oui!



Thank you but you are completely out of my field of expertise :slight_smile:

Good morning, everyone,

Thank you bcp for your help it works!

But I still have 2 3 questions

  1. why doesn't the dhcp list display all devices connected to the router? I need to do a scan to find the ip.
  2. My internet box is connected on the wam and has an access ip which is My router is configured on an ip range of how can I access my box?
  3. is there a Parental Control on openwrt?

Thank you again for your help and answers

DHCP list will only show devices which used dhcp from the router. Those configured with a static IP will not be in the list. You can see the IP and MAC of everything that has connected to the router using arp.

If you are double-NATting (the WAN IP is a private one 192.168.1.X issued by the modem), you can access the modem by simply going from a LAN PC to Anything outside of 192.168.0.X will be routed to the WAN port automatically.

If your modem is bridged (a public IP on the WAN) you can add a second IP to the WAN port and a route to it to access the modem's administration page.

Control such as having a list of allowed and disallowed websites is possible with OpenWrt, but takes more memory than your device has. Time based all or nothing rules like turning off the wifi or Internet access entirely at night is possible.