[solved] Failed to change subnet

Hello i have some issue changing the subnet of openwrt. i have red this

my issue is somehwat similar, and unlike what it is said there, after config is not confirmed, roolback kick in as expected but does not complete

i have this that stays on forever. ( instead of offering me to force changes )

(And yes i did try various thing after waiting couple of minutes, such as restart / recreating the network link (plug / unplug ) etc.

and it reverted many restart/reboot with reset button (not sure it did anything as it kept old password).

version :


After the rollback, you will see a button that says "APPLY UNCHECKED". You will press that.

that is the issue... there is no apply unchecked in my case.

it is stuck in the previous step with loading wheel.

Three options:

  • Within the 30 seconds, get a new DHCP lease and browse to the new IP
  • Make the changes on CLI/UCI in /etc/config/network and do an /etc/init.d/network restart
  • Make the changes from an interface that will not experience an IP change.

This feature exists to prevent lockout to the web GUI.

1 Like

thanks. i will try 1.

In my experience the "feature" did lock me out... ( and it took me energy and several reboot to have the rooter accessible again ... )

  • But the IP remand the same.
  • You never lost access to the device (as the old IP stayed in place)
  • I think that may be due to the switch restarting in the process, some devices just do that

i did loose access to the device and wan.
this is the reason i went on hard reboot cycle after, and eventually after 3 or 4 tries, it reverted back (but not hard reset) but i am not sure what made it happen.

anyway thanks for your time answering

1 Like

There is no such feature on most routers, I'm glad you didn't brick it.

It wasn't clear if you got your IP on LAN changed.

Hope the best with the options offered.


come on, changing subnet is not something extraordinary and i would call that a major bug if router ends up bricked.

Now thinking of it, the reverting may have partialy failed because of conflit with wan network that has same subnet than the lan one reverted too. ( and obviously the very reason why i wanted to change it on the first place ... )

In any case the "feature" would gain to be enhanced for subnet changes... :wink:

thanks for your time and answers.

1 Like

Correct, that's why I suggested you not do that.

Then that means you had same subnet on LAN and WAN and no routing took place, that's why you lost Internet.

Perhaps, a lot of people are having snags changing LAN subnet in LuCI now, I do recognize that. In the past, people would lock themselves out (at that point) if there was an error, though.

Well I finally managed to try this again.

i removed the wan entry to avoid any interference, and proceeded again changing the lan ip subnet.
after the 30 seconds, the conf is trying to revert (same image as above with loading wheel) but does not complete.
At that point the router does not provide any DHCP anymore and does not respond. Only a reboot will bring it back.
So there is something not working as intended with feature /luCI in my setup for basic lan subnet change.

Now i retried it again with advise above "to renew DHCP lease and reconnect within the 30 seconds time slot". And this worked OK.

If any useful.

Thanks for the help provided.

@L1wrt If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

Thanks thomas, wil do.
( this still look like a bug to me )

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.