[Testing] lede-17.01 security backports for 4/32 devices

Noticed the 432 devices support is near the end so I've decided to give it a try backporting security related patches to LEDE-17.01 abandoned branch https://github.com/maurerr/openwrt
I've generated TEST images for ar71xx and rt305x architectures for now:
https://maurerr.github.io/lede-17.01.ng-ar71xx/
https://maurerr.github.io/lede-17.01.ng-rt3050/
SDKs and imagebuilders here: https://github.com/maurerr/lede-17.01.ng-imgbld-sdk/

Before testing make sure you back up your config as described here or better test it on a spare 432 device.

I need your feedback before adding more security related patches (mostly kernel and CVEs)

5 Likes

Glad to see people aren't forgetting our loved cheap routers! Thanks for the time you put into this.

1 Like

I've tried the version but it doesn't pass any traffic from the WAN to LAN network. I don't know why. I have normal internal LAN traffic. I didn't see any error messages in system log. I can ping the WAN from the router but not from any other LAN client.
I had to revert to 18.06.8 in order to recover the internet connection for LAN clients.

I've only tested the code on a tl-wr842v1 but didn't had any of those problems.
thanks for the feedback though !

Don't like replying to myself but just finished building and uploading ramips/mt7628 4/32 devices to https://maurerr.github.io/lede-17.01.ng-mt7628/ (also available via plain http for easier download on device's /tmp via curl/wget)
tested only on tp-link tl-wr841n-v14 and tl-wr840n-v6
waiting for testers for Asus rt-n10p-v3/rt-n11p-b1/rt-n12-vp-b1

1 Like