No dsl connection with Fritz!Box 7362 SL


I have been trying to make the WAN connection to DSL work without success. And I found similar threads here and here and here and here. All of them end up with missing network interface. To me it looks like even the default setup which is referring to dsl0 is incomplete. I'd assume the firmware is needed even if it is ADSL only.

On the other hand I could configure eht0.7 as WAN device, however, I'm not able to assing VLAN Id 40 (which is required by my provider M-net) to that device. As a result I get this System Log messages:

Sun Apr 17 01:20:53 2022 daemon.warn pppd[2937]: Timeout waiting for PADO packets
Sun Apr 17 01:20:53 2022 daemon.err pppd[2937]: Unable to complete PPPoE Discovery

Does anybody here has a fully working setup (as all-in-one DSL router incl. modem)?


I have the same Problem !!!

Is this a VDSL or VDSL-vectoring line? Do you have a DSL-sync? What OpenWrt version are you using?

It's ADSL 16.000 and I have no sync. It's OpenWrt 21.02.3 r16554-1d4dea6d4f / LuCI openwrt-21.02 branch git-22.083.69138-0a0ce2a

Ok, because the pppd/pppoe errors does not matter when you have no sync.
Have you also tried with default settings? Does that version change something for you?

Not yet (since I wasn't aware of it). I have installed as described here.

Ok, I've just installed rc4, but same result: "Network device is not present".

And you of have reset the configuration while installation or later? Because otherwise it wont have changed anything at the configuration.

In general its always a good idea to use the latest DSL-firmware file. In Germany you have ADSL lines with ANNEX-B. In this case you have to use vr9-B-dsl.bin for example from here Howto: Updating the Lantiq XRX200 devices with latest DSL vectoring firmware - #39 by godraselti or if you dont trust this file, then download the latest 7490 firmware image on your own and extract it from there.

Most people put this firmware file into /lib/firmware of the router because there is also the old redistributable DSL-firmware file. Dont forget to configure set in the DSL-tab to use this DSL-firmware file instead of the default OpenWrt one.

Also dont forget that sometimes it could take up to 10 minutes for a sync in some cases. So be patient as long as it tries to sync.

I was forced to run sysupgrade -n due to format change (can't remember exactly).

Still the same result.

Have you taken the annex-b dsl file i named? Have you changed in luci the tone settings and tried out some different ones?

Well, not really, Deutsche Telkom as biggest operator of access lines uses AnnexJ... not sure whether the linecards still sync with devices set for AnnexB, but I assume they should.

When you run ubus call dsl metrics | grep state\" on the command line what does it return? Or if look at the GUI in the overview tab (Status-> Overview look inside the DSL section) what does 'Line State:' report?

Also what tone set is used?

I took this one: vr9-B-dsl_s6QpaNxxn0BCugT.bin

No, since the network device in not present I think this does not make sense.

What does VersionInformationGet issued on the modem's command line return?

It jumps between Orderly shutdown, Silent, Handshake, Exception, Idle request, Not initialized.

I've tried all of them.

nReturn=0 DSL_DriverVersionApi= DSL_ChipSetFWVersion= DSL_ChipSetHWVersion=Unknown DSL_ChipSetType=Lantiq-VRX200 DSL_DriverVersionMeiBsp= nHybrid=3

1 Like

Please don't, select 'bv' and stick to it.

Mmmh, the SDK says:

%    /** Line State: EXCEPTION.
%        Entered upon an initialization or showtime failure or whenever a regular
%        state transition cannot be followed.
%        Corresponds to the following device specific state
%        - Modem Status: FAIL_STATE */
linestate_strings.DSL_LINESTATE_EXCEPTION = '0x00000001';

Have you tried with the DSL firmware blob extracted from the last 7362sl firmware archive? That should not matter, but who knows...

Link to blob:

Same result.

If you issue:

# default is 4, 1 and 2 are a firehose, 3 spits out something at retrains
echo "LOG 3" > /proc/driver/mei_cpe/config
echo "TRACE 3" > /proc/driver/mei_cpe/config

or maybe even 2 or 1, and then try to connect again does anything useful show up?

several times approx every 15s:

[ 7755.158794] MEI_DRV[00 - 03]: ReadAck[0x5308] - FctOP ERROR 0x31!
[ 7755.158794] 
[ 7755.163733] MEI_DRV[00 - 03]: Send Msg[0x5348] read ACK failed (cnt: 265419, t: 7455130 - 7455130 = 0)
[ 7755.163733] 
[ 7755.171739] MEI_DRV[0x00]: fail to set MAC config!
[ 7755.171739]