Problem connecting Fritzbox 7362 SL to Deutsche Telekom (Germany) ISP

Hello everybody,

I currently try to use OpenWrt (version 19.07.7) for the first time. I want to use my FritzBOX 7362 SL as a direct connection to my ISP (Deutsche Telekom). I don't use any switch or other device, I plug this router directly into the wall and want to create a WiFi network with it.

I sucessfully installed OpenWrt on the device as explained here: https://openwrt.org/toh/avm/avm_7362_sl . I also already enabled WiFi. However, when I configure my WAN (with the browser UI), it tells me Error: Network device is not present. This error comes both when the cable from my wall is plugged in or not.

When I try to configure the WAN (User: Anschlusskennung#Zugangsnummer#Mitbenutzernummer@t-online.de, passwort: Kennwort , explained under https://telekomhilft.telekom.de/t5/Telefonie-Internet/Wie-OpenWRT-Router-am-FTTH-Anschluss-betreiben/m-p/2967765/highlight/true#M868204) and not changing anything else at all, I still get the same error. When I try to use logread | grep err I dont get any information at all.

I also tried copying the information for the BNG platform from here: https://openwrt.org/docs/guide-user/network/wan/isp-configurations#deutsche_telekom_bng in /etc/config/network, but I do not really know which fields I have to change because they use an Archer C7 V2.

I tried everything from https://openwrt.org/inbox/support , but I couldn't find much help in the wiki nor in the forum besides VLAN configuration for Telekom - #5 by firefexx , but I couldn't find 'eth1.7' in my router. I also dont know why the WAN is configured with dsl0 and not eth0, I couldn't find anything about dsl0 in the internet.

It would be nice of you if you please could help me connecting to the ISP and know why I get the Error: Network device is not present error. Please tell me when you need additional information, I'm glad to give them to you.

Thanks!

Do you have ADSL, VDSL, or ethernet connection from your ISP to your Fritzbox?

Please post the contents of your /etc/config/network file. Use </> to format the text.

(For Deutsche Telekom, VDSL services, I believe the 'ifname' will be 'dsl0.7')

fwiw, you may wish to study section 9.1 of the 'OpenWrt installation guide for HH5A' which describes how to configure PPPoE connection for VDSL broadband using LuCI:
https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=266
For Deutsche Telekom VDSL: replace 'dsl0.101' with 'dsl0.7' when following the instructions.

The TEST interface connected to eth0 doesn't really make sense here.

The first question would be (well, after the original one by bill888), ADSL or VDSL or VDSL+vectoring (as the later would need a non-default modem firmware).

The second, is there an external -dedicated- xDSL modem in front of your Fritz!Box or is the Fritz!Box supposed to be its own xDSL modem (as it could be). In the later case, your WAN connection and PPPoE configuration should be on the dsl0.7 interface - in the former, you'd first need to figure out if your dedicated xDSL modem already does the tagging on WAN for you transparently, or if you need to tag the packages towards it (VID 7).

In all cases it can be done (at least if you don't need super-vectoring), if set up correctly.

Provides some hints.

Hello to both of you, and thank you so much for your comments. However, I still have problems:

To the answer of @bill888 : I have a 'Call & Surf Comfort (5)' service (dont judge me :smiley: ), which seems to be ISDN, which again seems to be a ADSL connection (The ISDN/ADSL parts are what I found out when searching on the internet, please correct me if I'm wrong). Thus, I tried section 9.5 'Quick PPPoE setup using DSL port for ADSL Connection' of the tutorial of https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=266 . In the end, my /etc/config/network looked like this:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'PREFIX'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option tone 'av'
	option ds_snr_offset '0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'MAC'

config interface 'wan'
	option proto 'pppoe'
	option username 'USER'
	option password 'PASS'
	option ipv6 '1'
	option mtu '1492'
	option ifname 'dsl0'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr 'MAC'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t'
	option vid '7'

However, I still get in the Lua GUI an Error: Network device is not present for the WAN (as in the picture of the original question). As the PDF-tutorial does not have this error in its images, I guess this is a problem which does not depend on the ISP?

I also tried following the section 9.1 as suggested (without removing the bridge), which lead to the following /etc/config/network


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'PREFIX'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option tone 'av'
	option ds_snr_offset '0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr 'MAC'

config interface 'wan'
	option ifname 'dsl0.7'
	option proto 'pppoe'
	option username 'USER'
	option password 'PASS'
	option ipv6 '1'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr 'MAC'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t'
	option vid '7'

However, I still get the same Error: Network device is not present.

@slh : I removed the TEST interface, this was only for me to try out whether I also get the Error from the WAN here as well. I already tried out your link (see original questions), and I also get the Error: Network device is not present WAN-problem here as well.

So anyone has an idea on what to do next?

@deriv, do you really still have ISDN? If you're sure about that, you need to set the correct annex mode. I think it should be Annex B. You can do that via LuCi.

Do you get a sync state on the status page?

All the vlan config etc. doesn't matter yet at this point. Does the dsl sync?

/etc/init.d/dsl_control dslstat
/etc/init.d/dsl_control status

If the second command says silent or just running, the dsl profile paramters are wrong.

The status has to be up. And only then you can start setting the vlan to probably 7 or 4. And insert your credentials to obtain an IP address.