Support for Easybox 904 LTE


#1

Easybox 904

Hi there. Since we lost some information on the openwrt forum page, this should be the new home for our device. I welcome everyone which contributed with cool topic responses to join here and continue.

Actually we're missing the changed bootanimation - any hints about?

Best regards,
Qualle


#2

There seems to be at least some information at https://forum.openwrt.org/viewtopic.php?id=44676 (coincidentally I got my hands on a EasyBox 904 xDSL today, so I'm currently reading up what I can do with it).


#3

I'm sorry, that's all the information I could restore. Also I'm sorry the topic archive display is just a big long page right now. Pagination that does not break old links is tricky due to missing posts. Edit: Pagination works now, yay!

That was due to a completely different reason: I moved servers and forgot/didn't get around to copying some temporary content yet. That's fixed now, for those two files at least. The preview and download in in the post works again. Additionally, there's also information on my github.

BTW, nice to see you here, QAuge. I hope work on the EB904 can continue, I still would love to see it working in a non-experimental way.


#4

Hello Quallenauge,

thank you for your excellent work!

Unfortunately I dont get my Easybox working with your newest .bin: 2018-06-06 (https://app.box.com/s/hvqg535dnubt4r2ontpmtodpvt6ydf00/folder/50058293183). I get a bootloop

I tried different versions and saw that it works with the build 2017-11-19.

This was build with ubifs. The newer snapshots with squashfs. Everytime i do a sysupgrade via Luci i get a bootloop.

Please give me a hint to solve that problem.

Thank you in advance


#5

Have a look at

Attention for upgrading an older Image

If you want to upgrade an older image ( <2018-03-11 ) with the current one,
please backup the data and perform an recovery via fullimage.img method. If not,
you end up in a bootloop, which then also has to be resolved via the
fullimage.img method.

#6

Hi slh, thank you for your help! It worked for my 904xdsl. Open-WRT is working on that box.

Now i have a very strange problem with my 904 lte box.

I tried to flash that fullimage.img by Quallenauge. I get the following messages:
"firmware downloaded", then "Incorrect image. Please power-off-on..."

If i take an original firmware like UEfullimage_AT904L-03.05.bin, UEfullimage_AT904L-03.07.bin, i don't get the message "firmware downloaded", but "Incorrect image. Please power-off-on..."

Now I tried the images for the xDSL-Routers - fullimage_AT904X-03.17.01.16.bin. There i can flash it with the message "Firmware downloaded. Writing flash" and "Rescue process is complete, please power..." Same with fullimage-3.17-opened.img.

But i get a permanent boot loop.
: (

Can you give me a hint, what i do wrong?


#7

I have only access to the xdsl variant, but I'd assume both use a different hwid and dts.


#8

It is strange, that the LTE Box doesn't take the original LTE images. Just what the Box takes is an original xDSL firmware and the opend xDSL firmware from http://arny.tjps.eu (but with bootloop).

Could it be that i bricked my LTE box somehow?


#9

"bricked" might be a bit harsh, but you might need either serial console access or provide a specially crafted firmware image (lte image with xdsl headers/ hwid).


#10

I found a similar post on forum: "Easybox 904 LTE open source code to be provide soon" - post 301.
https://forum.openwrt.org/viewtopic.php?id=44676&p=13

Unfortunately there is no answer to that problem


#11

Meanwhile i bought a serial adapter and deboxed the 904 LTE. But I am quite stuck right now:

ROM VER: 1.1.4
CFG 06
NAND
NAND Read OK

ROM VER: 1.1.4
CFG 06
NAND
NAND Read OK
nand_read_page - 00000008
DDR autotuning Rev 0.3c
DDR size from 0xa0000000 - 0xa7ffffff
DDR check ok... start booting...



U-Boot 2010.06-Lv2.0.40-A0.3  (Jul 12 2012 - 22:00:12)

CLOCK CPU 500M RAM 250M
DRAM:  128 MiB
NAND:  NAND device: Manufacturer ID: 0xec, Chip ID: 0xdc (Samsung NAND 512MiB 3,3V 8-bit)
512 MiB
Bad block table found at page 262080, version 0x01
Bad block table found at page 262016, version 0x01
nand_read_bbt: Bad block at 0x000001160000
nand_read_bbt: Bad block at 0x00000bd20000
nand_read_bbt: Bad block at 0x000015ae0000
nand_read_bbt: Bad block at 0x000016740000
In:    serial
Out:   serial
Err:   serial
Net:   Internal phy(GE) firmware version: 0x040b
vr9 Switch

Type "run flash_nfs" to mount root filesystem over NFS

Hit any key to stop autoboot:  0 
1. bootid : 2, bootnum : 12
Uncompressing LCD bootup images ............... 
NAND read: device 0 offset 0x0000000004700000, size 0x0000000000300000
 0x300000 bytes read: OK


please input password :

I tried to shortcut R148. It is at a different position on the 904 LTE board. The box restarts, but i don't get it to UART mode.

@ slh
Thank you for your help! Can you help me crafting my own LTE firmware with xdsl headers? Because i think, i don't get the LTE box in UART mode with the xDSL HowTo.

And I think this could help others who also got stuck with an LTE box.


#12

Hmm, the MAGIC seems to be 0x27051956 for both devices (so crossflashing should work as far as the flashing toll is concerned), I don't really see any other distinguishing factor, but I haven't really followed the 904lte specifics. Do you have a pointer to OpenWrt(-like) source for it?


#13

Thank you for your help.

I found an quite old source at:

But when i tried to compile it, i got an error:

make[6]: Entering directory `/home/user/Downloads/test/easybox-904-lte-firmware/build_dir/host/m4-1.4.15'
make[6]: Nothing to be done for `all-am'.
make[6]: Leaving directory `/home/user/Downloads/test/easybox-904-lte-firmware/build_dir/host/m4-1.4.15'
Making all in examples
make[6]: Entering directory `/home/user/Downloads/test/easybox-904-lte-firmware/build_dir/host/m4-1.4.15/examples'
make[6]: Nothing to be done for `all'.                                                                                                                                                                               
make[6]: Leaving directory `/home/user/Downloads/test/easybox-904-lte-firmware/build_dir/host/m4-1.4.15/examples'                                                                                                   
Making all in lib                                                                                                                                                                                                    
make[6]: Entering directory `/home/user/Downloads/test/easybox-904-lte-firmware/build_dir/host/m4-1.4.15/lib'                                                                                                       
make  all-am                                                                                                                                                                                                         
make[7]: Entering directory `/home/user/Downloads/test/easybox-904-lte-firmware/build_dir/host/m4-1.4.15/lib'                                                                                                       
x86_64-linux-gnu-gcc -std=gnu99  -I.   -O2 -I/home/user/Downloads/test/easybox-904-lte-firmware/staging_dir/host/include  -O2 -I/home/user/Downloads/test/easybox-904-lte-firmware/staging_dir/host/include -MT gl_avltree_oset.o -MD -MP -MF .deps/gl_avltree_oset.Tpo -c -o gl_avltree_oset.o gl_avltree_oset.c                                                                                                                       
mv -f .deps/gl_avltree_oset.Tpo .deps/gl_avltree_oset.Po                                                                                                                                                             
x86_64-linux-gnu-gcc -std=gnu99  -I.   -O2 -I/home/user/Downloads/test/easybox-904-lte-firmware/staging_dir/host/include  -O2 -I/home/user/Downloads/test/easybox-904-lte-firmware/staging_dir/host/include -MT c-stack.o -MD -MP -MF .deps/c-stack.Tpo -c -o c-stack.o c-stack.c                                                                                                                                                       
mv -f .deps/c-stack.Tpo .deps/c-stack.Po                                                                                                                                                                             
x86_64-linux-gnu-gcc -std=gnu99  -I.   -O2 -I/home/user/Downloads/test/easybox-904-lte-firmware/staging_dir/host/include  -O2 -I/home/user/Downloads/test/easybox-904-lte-firmware/staging_dir/host/include -MT clean-temp.o -MD -MP -MF .deps/clean-temp.Tpo -c -o clean-temp.o clean-temp.c                                                                                                                                           
In file included from clean-temp.h:22:0,                                                                                                                                                                             
                 from clean-temp.c:23:                                                                                                                                                                               
./stdio.h:456:1: error: 'gets' undeclared here (not in a function)                                                                                                                                                   
 _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");                                                                                                                                              
 ^                                                                                                                                                                                                                   
make[7]: *** [clean-temp.o] Error 1                                                                                                                                                                                  
make[7]: Leaving directory `/home/user/Downloads/test/easybox-904-lte-firmware/build_dir/host/m4-1.4.15/lib'
make[6]: *** [all] Error 2
make[6]: Leaving directory `/home/user/Downloads/test/easybox-904-lte-firmware/build_dir/host/m4-1.4.15/lib'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/user/Downloads/test/easybox-904-lte-firmware/build_dir/host/m4-1.4.15'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/user/Downloads/test/easybox-904-lte-firmware/build_dir/host/m4-1.4.15'
make[3]: *** [/home/user/Downloads/test/easybox-904-lte-firmware/build_dir/host/m4-1.4.15/.built] Error 2
make[3]: Leaving directory `/home/user/Downloads/test/easybox-904-lte-firmware/tools/m4'
make[2]: *** [tools/m4/compile] Error 2
make[2]: Leaving directory `/home/user/Downloads/test/easybox-904-lte-firmware'
make[1]: *** [/home/user/Downloads/test/easybox-904-lte-firmware/staging_dir/target-mips_r2_uClibc-0.9.30.1/stamp/.tools_install_nnynn] Error 2
make[1]: Leaving directory `/home/user/Downloads/test/easybox-904-lte-firmware'
make: *** [world] Fehler 2

#14

Since a few weeks, your snapshots have some problems with WIFI-Ap-mode, the last If have tried, was the one from 6.6.18. The client can authificate to the EB-AP, but no IP-communication is possible (dhcp,ping), probably due to a lack of a userspace-daemon (hostapd), that doesn't seem to be compatible with RT3883-Drivers wext-API. I know older versions (that one wit uLibC) worked, but I didn't check, if hostapd was running that time. Any idea what has changed?


#15

I also found the source code from Astoria for LTE.

http://www.astorianetworks.com/astoria/Easybox%20904%20LTE.html

May this help?


#16

That archive is well known, it quite literally kicked off OpenWrt development for the device in 2013.


#17

Juhuuu!

Carefully reading posts helped me. So I will share my experiences:

904 xDSL Box:

For programming / unbricking / using it with OpenWRT / LEDE i refer to the earlier Post from slh with the Quallenauge repository:

904 LTE Box

I bricked my Box using a xDSL firmware. So be careful.

Unbricking was easy with the right firmware. I found Post 142 by wafuli in the old forum

https://forum.openwrt.org/viewtopic.php?id=44676&p=6

with the working LTE pre-Image 1.07

I flashed that Image in the rescue mode via TFTP. Afterwards it booted. I did an upgrade to 3.18 and then back to 3.07 because of the telnet access.

After booting the box go to the tab which ist called somewhat "Help & Diagnostics" and insert in the field "Diagnostics" the string: &telnetd

Now you can access the box via telnet:
telnet 192.168.2.1
user: root
password: 123456

Programming the Box with a SIM different to Vodafone:

I used these explanations:


I inserted these for o2 / Drillisch and it worked:
ccfg_cli set ivr_mode@bootstrap=2
ccfg_cli set arcor_pinConf@bootstrap=1
ccfg_cli set arcor_customer@bootstrap=1
ccfg_cli set keep_in_act@bootstrap=0
ccfg_cli set FirstUseDate@tr69=2015-05-24T01:07:49
ccfg_cli set Username@tr69=26207rest_of_your_IMSI
ccfg_cli commitcfg
ccfg_cli set umts_lock_ops@lte=26203
ccfg_cli set lte_lock_ops@lte=26203
ccfg_cli set umts_lock_ops@wan200=26203
ccfg_cli set lte_sim_lock_ops@lte=26203,26205,26207,26208,26211,26277
ccfg_cli set apn_data@lte=internet
ccfg_cli set apn_voice@lte=internet
ccfg_cli set apn_umts@lte=internet
ccfg_cli commitcfg

Roaming / Using a SIM of a foreign firm:

I have an italien SIM (Provider: WIND). After my vacation I was able to use my flat in Germany via roaming in my Smartphone.

But I was not able to program my 904 LTE box. I found a forum entry, that the box is not able to roam.

My goal and the main reason why i bought the router is: I want to use it with an Italien SIM in Italy. For my WIND SIM I programmed it to:

ccfg_cli set ivr_mode@bootstrap=2
ccfg_cli set arcor_pinConf@bootstrap=1
ccfg_cli set arcor_customer@bootstrap=1
ccfg_cli set keep_in_act@bootstrap=0
ccfg_cli set FirstUseDate@tr69=2015-05-24T01:07:49
ccfg_cli set Username@tr69=222881*Rest_of_my_Italien_SIM
ccfg_cli commitcfg
ccfg_cli set umts_lock_ops@lte=22288
ccfg_cli set lte_lock_ops@lte=22288
ccfg_cli set umts_lock_ops@wan200=22288
ccfg_cli set lte_sim_lock_ops@lte=22288
ccfg_cli set apn_data@lte=internet.wind
ccfg_cli set apn_voice@lte=internet.wind
ccfg_cli set apn_umts@lte=internet.wind
ccfg_cli commitcfg

My next Italien vacation is in August. So i will inform you, if that worked in Italy with no roaming.

Best regards


#18

I'm happy that you got your box back into working state (I would disagree that it was "bricked" in the first place), and I can share your joy about that. However, I can't see what any of this has to do with OpenWrt. This is the original manufacturer's firmware, no?


#19

Firts, a info:
in the 2018-06-27 build, the diagnostic luci page don't work

and second a Question:
i found a sim card slot on my dsl version. have it a umts/lte modem? if yes,is it already supportet to use it?

Thanks

P.S.: sorry for my bad english


#20

There has been quite a lot of development on luci over the last few weeks, some of those changes also caused short term regressions which have mostly been fixed already - but the 27th was right around the time when multiple things weren't working properly in luci.

While there is a SIM slot, there is no 3g/ 4g modem in the EasyBox 904 xdsl, the OEM firmware might use it for a USB attached modem though.