Support for Easybox 904 LTE


#21

is there any way tu use it with a softmodem? Or how it work?


#23

I noticed that there is an alternative driver for the builtin switch component, and that alternative driver is already in the process of being merged upstream (it's in davem's net-next tree).
[PATCH 1/4 v1] net: phy: realtek: Support RTL8366RB variant
[PATCH 2/4 v1] net: dsa: Add bindings for Realtek SMI DSAs
[PATCH 3/4 v1] net: dsa: realtek-smi: Add Realtek SMI driver
[PATCH 4/4 v1] ARM: dts: Add ethernet and switch to D-Link DIR-685

Unless some serious problems appear, these patches will be in Linux 4.19.


#24

Would this new driver for the switch finally make it possible to have easybox 904 official support in openwrt?

Because noone have mentioned that here:
Here is the Link to the old forum post inside the old forum with the OpenWrt boot animation (instead of vodafone boot animation):
https://forum.archive.openwrt.org/viewtopic.php?id=44676&p=16

Copy of the forum post:

So, an evening with a lot of cursing about animation tools, Photoshop and video formats later, here's a complete replacement for the boot animation. I hope you like it.

https://square.wf/tmp/easybox904xdsl_lcdimage.gif
(It runs a bit faster on the device itself, also it remains on the last frame of the animation and does not loop.)

How to install:

  1. Backup the original lcd image:
# dd if=/dev/mtd8 of=/tmp/easybox904xdsl_lcdimage_backup.bin

and transfer it off your Easybox

  1. Download easybox904xdsl_lcdimage.bin and transfer it to the Easybox, I would suggest to /tmp

( Backup of the download: https://web.archive.org/web/20180523225944/https://square.wf/tmp/easybox904xdsl_lcdimage.bin )

  1. Verify the integrity of the file:
# md5sum easybox904xdsl_lcdimage.bin

It should read:

9effc4dd7c210fcb8a4b28ebfe1489f8  easybox904xdsl_lcdimage.bin

(If it doesn't, please re-download the image file, I might have changed something in between.)

  1. Flash the image file:
# mtd write easybox904xdsl_lcdimage.bin lcdimage
  1. Reboot and rejoice you don't have to see a horrible zoom animation of the Vodafone logo anymore.

The binary also contains the images with instructions for the "Rescue Process", and for good measure I replaced them too with my own versions, so we are completely free to distribute this.

Disclaimer: I don't know if this would work with an Easybox 904 LTE, but I assume so. Try at your own risk. I can't imagine that the box would deny booting if the LCD boot logo is broken, but I have no way of knowing that for sure.

P.S.: May I ask you to not quote but only reply to this post, so I can change it in the future if needed. Thank you.


#25

That's not entirely true, but I guess it went a bit under the radar, like so much about the Easybox 904 does. Thanks for the renewed interest.


#26

When would this device get upstream support?
I think thanks to the by @hailfinger mentioned drivers this should be finally possible. Could someone send the patches for 904xdsl support to upstream openwrt? @QAuge , that would be great.


#27

Hey guys!

There is still a big interest in this project. Can anyone give a conclusion what's working and not? I flashed my device and did the work around from the old thread. It's working in AP mode, but not as wireless bridge, also no working internet dial in for Deutsche Telekom in my case...

But maybe there is already some further development.

I followed this thread

https://forum.archive.openwrt.org/viewtopic.php?id=44676&p=19


#28

The DSL Line should work fine. Also Wifi should work fine in normal AP mode. So using it as a replacement for a Fritzbox should work fine (DSL connection + WLAN + analog phone ATA).
You should sync and connect just fine to the telekom. Many users here are using it at VDSL or even VDSL Vectoring on telekom.
You would probably like to get latest vectoring firmware by using this howto: Howto: Updating the Lantiq XRX200 devices with latest DSL vectoring firmware


#29

The RTL8366 DSA switch driver has been merged in mainline Linux and will be part of Linux 4.19-rc1 and later.
I have no idea if that driver handles the switch variant in the Easybox 904, but it might be worth a try.


#30

Hi, thanks for your answer. Would you maybe please give some instructions about how you got it to work? Your link is just for Vectoring Firmware adjustment, but no instruction for getting the provider dial in and VoIP to work. My latest found Openwrt Firmware is synced at a ADSL2+ Annex ja and on a VDSL 50 port. But unfortunately the dial in doesn't work.

With FritzBox 7490 and FritzBox 7580 it works fine. Also with another connection with Easybox904 at a Vodafone dial in port.

I get no dial in or VoIP working on my Easybox904xdsl.

I would love to get some further details how you did it.


#31

First the dial-in (you probably mean PPPoE on VLAN7 in Germany).
Have you set up VLAN7 and updated to the latest 7490 lantiq firmware?


#32

Let me just add that this solution is going "too far". With an internal modem it is not necessary to change the switch's VLAN setup, that is for externally connected modems.

It is enough to change
ifname 'dsl0'
to
ifname 'dsl0.7'
and reboot.


#33

Yep, what takimata say is also what i am using. But the "too far" solution should also work fine.


#34

Hello everyone! Today I tried to use the Easybox 904xDSL with the OpenWRT version (https://app.box.com/s/hvqg535dnubt4r2ontpmtodpvt6ydf00 Version 2.September 2018) to dial into the ADSL network at Vodafone Germany. Unfortunately without success.
Even with the change from dsl0 to dsl0.7 the connection was not established. Then I called the Vodafone support and went through all LUCI settings (DSL and WAN settings), but without success.
LUCI changed dsl0.7 to dsl0 again.
Can anyone help me?
Unfortunately the WLAN doesn't work either. After switching on it comes to the bootloop. Does anyone already have a solution?

Thank you very much!

Greetings Mike
---Original----
Hallo zusammen! Ich habe heute versucht, mich mit der Easybox 904xDSL mit der OpenWRT-Version (https://app.box.com/s/hvqg535dnubt4r2ontpmtodpvt6ydf00 Version 2.September 2018) ins ADSL-Netz bei Vodafone Deutschland einzuwählen. Leider ohne Erfolg.
Auch mit der Änderung von dsl0 nach dsl0.7 kam die Verbindung nicht zustande. Danach habe ich beim Vodafone-Support angerufen und bin mit diesem alle Einstellungen bei LUCI durchgegangen (DSL- und WAN-Einstellungen), jedoch auch ohne Erfolg.
LUCI hat dsl0.7 wieder zu dsl0 geändert.
Kann mir da jemand helfen?
Leider klappt auch das WLAN nicht. Nach dem einschalten kommt es zum Bootloop. Hat dafür schon jemand eine Lösung?

Vielen Dank!

Gruß Mike


#35

https://openwrt.org/docs/guide-user/network/wan/isp-configurations#on_a_telekom_line_with_annex_j that should at least give you a general idea - for ADSL you need to set annex b or j as needed, vlan tagging might or may not be required (depending on the local infrastructure).

In case of VDSL, you may need to ensure using a vectoring enabled firmware, if required by the local infrastructure.

These questions would be lantiq specific, but shouldn't be specific to the individual device (the Easybox 904 in this case) - as long as the hardware supports annex B.


#36

Yes, for ASDL at Vodafone Germany it has to be set to Annex B.
I looked at the log file, fortunately I had switched on logging before. There is the warning again and again:

Tue Sep 25 20:24:23 2018 daemon.warn pppd[4565]: Timeout waiting for PADO packets

I had tried many settings, the service employee was not sure whether Annex J or B and whether ADSL or VDSL. It was then ADSL and Annex B. However, the connection was not established.
My second Easybox 904xDSL (with original firmware) manages to establish the connection. Even if it takes some time.
Is it possible to extend the waiting time for the program ppp somewhere?
Greetings Mike

Translated with www.DeepL.com/Translator
------Original-------
Ja, für ASDL bei Vodafone Deutschland muß es auf Annex B eingestellt werden.
Ich habe mir die Logdatei angesehen, zum Glück hatte ich vorher das loggen eingeschaltet. Da kommt immer wieder die Warnung:
Tue Sep 25 20:24:23 2018 daemon.warn pppd[4565]: Timeout waiting for PADO packets
Ich hatte viele Einstellungen durchprobiert, der Sevicemitarbeiter war sich nicht sicher, ob Annex J oder B und ob ADSL oder VDSL. Es war dann ADSL und Annex B. Jedoch kam die Verbindung nicht zustande.
Meine zweite Easybox 904xDSL (mit Original-Firmware) schafft es jedoch die Verbindung aufzubauen. Auch wenn es etwas dauert.
Kann man die Wartezeit für das Programm ppp irgendwo verlängern?

Gruß Mike


#37

Hey everybody!

I just recently got my hands on a used '904 xDSL, and everything went flawlessly (installing OpenWRT snapshot via TFTP recover, then flashing the new boot animation) until I tried to use the 904 behind a cable modem to connect to the internet.

The cable modem has a LAN-port, then I tried to connect it to the WAN-port of the 904.
The serial console logged

lentiq,xrx200-net 1e108000.eth eth0: port 4 got link

But the device does not "see" this change in the webinterface (it still displays DSL: Line State: DOWN), I do not know enough about OpenWRT to change the interface type to DHCP client (if that is at all possible).

Then, there is a second question: In the webinterface there is the point "asterisk", for the voip server configuration (correct?).
Is there a tutorial or guide available what to set/change to use an VoIP provider (like sipgate) on the analog plugs (if that is possible)?

Your help would be much appreciated!
Felix


#38

VLANs on the Easybox 904 is a bit tricky, as there are two switches involved, combined with the RaLink iNIC wlan that's hardcoded via VLANs themselves - you'll need to read through the old threads for the details.

Yes, you can configure the analogue FXS ports via chan_lantiq and asterisk.


#39

Okay, the first part i figured out:
the "WAN"-port on the XRX200 switch is connected to VLAN-ID 2.
So I simply created a new interface (via webinterface) with protocol "DHCP client" and under "Physical settings" the "Interface" to "eth0.2", and it worked! Then just added this interface to the firewall-zone "wan", and the device and clients had internet!

Where I am currently struggling with is asterisk: the asterisk package itself is not installed (and not installable), but the luci-asterisk package is installed? This seems rather strange.

Btw: I am using the snapshot version 01.10.2018 (or 2018-10-01); r8233-5edb6314f

Another "small" problem: if I try to install a kernel module via opkg, the install fails as the packages expect the kernel version to be different (4.14.74-something) vs the installed kernel 4.14.72, is there any solution to this? Self building?

And please be kind, my technical understanding of OpenWRT is - at most - basic.

Thanks,
Felix


#40

You might have to build the firmware image from source, to get compatible kernel modules.


#41

Thanks to Quallenauge and the Openwrt developing team to add the modified rtl-8367b switch to openwrt.
And i see that the kernelconfig are the same now.
What speaks against it too add whole device to Openwrt ?

Anyway, i have create a patch for openwrt master (it was working on 14.10.2018) to add this device.
add-eb904x-support-for-master-2018.09.20.patch

I have build an full working (with telephon) openwrt image and the reposatory from 14.10.2018.
It contain the patch and the buildscript for the patch
The reposatory must be on an USB stick see repo_root
base-commit.txt is the commit of used openwrt the used commits of the packages are inside feed.conf
eb904x-build-2018.10.14.tar.gz
sh256=9253929d1f9a9490c57565246953076fa2d9e2318788260acb82d5b38e2afea3
I use use 5 steps to build it:

  • download of all packages and the feed.config with the right commits
  • build openwrt from source
  • build the easybox and own packages via SDK
  • creating an reposatory by overcopy the new one to the old and making an index on SDK via "make index"
  • making an image via imagebuilder
    for this reason is the https://github.com/Plonkbong/eb904x-feedfix.git where i have fixing some problems at SDK build especially for the FBTFT driver.
    for streaming experiments with the screen i have build this: https://github.com/Plonkbong/openwrt-feeds-raspberry.git

note: wireless does not work out of the box, i add an config example in the "config" directory

Booting from USB by changing the commandline like the lines in dts files, does not work.
I thing the reason is the kernelconfig: no f2fs and no usb-storage, know erveryone the exact kernelconfig parameter ?
Exist other reasons ?

My second usb-slot does not work but i fear it is an elektrical problem or have everyone the same problem ?

Hmm i have this strange error on starting asterisk:

root@OpenWrt:/# [  194.438890] [/mnt/mapper/sda3/build/owrt/build_dir/target-mips_24kc_musl/linux-lantiq_xrx200/drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_ar9.c ifx_mps_download_firmware 140]: warning, image does not contain size - assuming 1MB!
[  197.671902] [/mnt/mapper/sda3/build/owrt/build_dir/target-mips_24kc_musl/linux-lantiq_xrx200/drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_ar9.c ifx_mps_release 380]: Timeout waiting for firmware ready.
[  197.763118] MPS: FW checksum OK
[  197.764969] 00000008: 86b75ca1
[  197.768099] 0000000c: 86b75ca1
[  197.771158] 00000010: 86b75ca1
[  197.774363] 00000014: 86b75ca1
[  197.777496] 00000018: 86b75ca1
[  197.780636] 0000001c: 86b75ca1
[  197.783692] 00000020: 86b75ca1
[  201.383919] [/mnt/mapper/sda3/build/owrt/build_dir/target-mips_24kc_musl/linux-lantiq_xrx200/drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_common.c ifx_mps_get_fw_version 3114]: timeout
[  201.398257] IFX_MPS: firmware download error (-14)!

It was working well on 25.09.2018
I fix it with overcopy with the same firmware from kmod-ltq-vmmc package.
I think it is a right mananment error on the FS or somthing else.