OpenWrt support for Xiaomi AX3000T

By link was info about default value of nasid if it was not defined by user (=bssid)
I don't have any other idea how to understand it.

Usteer is only additional package (service), the link was about ‘band steering’ and ft (fast transition, 802.11r).

Hello, I have been receiving putty after this step and then repeatedly read the value of RAM "6.As soon as the "Handshake..." text appears in the windows command prompt console, turn on the power adapter on the router. If router successfully processes the 'mtk_uartboot' loading, additional information will appear in the Windows console. Following that, a new window with PuTTY will automatically appear, attempting to retrieve the 'openwrt-mediatek-filogic-xiaomi_mi-router-ax3000t-ubootmod-initramfs-recovery.itb' file."
He couldn't stop for me to look for "openwrt-mediatek-filogic-xiaomi_mi-router-ax3000t-ubootmod-initramfs-recovery.itb"

I had a similar issue, and I solved it by disabling the Windows firewall.
Also, make sure that you selected the Server Interface 192.168.1.1 in tftpd64 when PuTTY attempting to load "openwrt-mediatek-filogic-xiaomi_mi-router-ax3000t-ubootmod-initramfs-recovery.itb" (or maybe 192.168.1.254 ? :thinking: - manual says "and select your PC's Ethernet port")

tftpd64

image

Also, please make sure that the Ethernet cable is connected between the router (2nd or 3rd port on the router) and your laptop. (I will add this information to the instructions. Thanks!)

anyone using recent snapshots with new 6.6 kernel?
is it stable? any crashes?

1 Like

I upgraded to the 6.6 kernel version a few days ago, but am back to this version:

Firmware Version OpenWrt SNAPSHOT r26114-00b86168bd / LuCI Master 24.120.25050~8f2dfa7
Kernel version 6.1.86

Reason: Internet connection was sometimes disconnected. I could access the router's website, but could not connect to the Internet. I would have to restart the ethernet adapter or wait for a new connection to be established. Oddly enough, this problem does not occur with the version I am using now.

1 Like

I am getting the same timeout. Did you find out out why?

There's no issue of kernel 6.6 for my usage as AP, connect the main router via a lan port.

The known bug for wan port at least with another filogic router has been fixed recently.

1 Like

which known bug is that? can you share a forum post or github issue?

This one: https://forum.openwrt.org/t/kernel-6-6-mediatek-mt7622-wan-issue/

mt7622 is not filogic, and in that topic the filogic owners actually say that they didn't have any issues

I just updated to this version:

Firmware Version OpenWrt SNAPSHOT r26329-cffd3ad8d7 / LuCI Master 24.135.65178~2bb1e06
Kernel version 6.6.30

If there are any problems, I will report them.

1 Like

First of all, thank you for your answer!! The current situation is that he starts an infinite loop after the cmd "handshake" shows the putty window.

I tried turning off my firewall but it didn't work.

Tried other methods on the network, such as "ctrl+c" or "enter" or changed to a different one.

Here's what I'm looping about.
F0: 102B 0000
FA: 1040 0000
FA: 1040 0000 [0200]
F9: 0000 0000
V0: 0000 0000 [0001]
00: 0000 0000
BP: 2400 0041 [0000]
G0: 1190 0000
EC: 0000 0000 [1000]
T0: 0000 024F [010F]
Jump to BL

NOTICE: BL2: v2.6(release):46016510e96-dirty
NOTICE: BL2: Built : 10:13:01, Apr 10 2024
NOTICE: WDT: disabled
NOTICE: EMI: Using DDR3 settings

dump toprgu registers data:
1001c000 | 00000000 0000ffe0 00000000 00000000
1001c010 | 00000fff 00000000 00f00000 00000000
1001c020 | 00000000 00000000 00000000 00000000
1001c030 | 003c0003 003c0003 00000000 00000000
1001c040 | 00000000 00000000 00000000 00000000
1001c050 | 00000000 00000000 00000000 00000000
1001c060 | 00000000 00000000 00000000 00000000
1001c070 | 00000000 00000000 00000000 00000000
1001c080 | 00000000 00000000 00000000 00000000

dump drm registers data:
1001d000 | 00000000 00000000 00000000 00000000
1001d010 | 00000000 00000000 00000000 00000000
1001d020 | 00000000 00000000 00000000 00000000
1001d030 | 00a003f1 000000ff 00100000 00000000
1001d040 | 00027e71 000200a0 00020303 000000ff
1001d050 | 00000000 00000000 00000000 00000000
1001d060 | 00000002 00000000 00000000 00000000
drm: 500 = 0xc
[DDR Reserve] ddr reserve mode not be enabled yet
DDR RESERVE Success 0
[EMI] ComboMCP not ready, using default setting
BYTE_swap:0
BYTE_swap:0
Window Sum 576, worse bit 0, min window 72
Window Sum 572, worse bit 8, min window 68
Window Sum 410, worse bit 0, min window 48
Window Sum 334, worse bit 15, min window 38
Window Sum 420, worse bit 2, min window 50
Window Sum 342, worse bit 15, min window 40
Window Sum 430, worse bit 2, min window 52
Window Sum 352, worse bit 11, min window 40
Window Sum 356, worse bit 9, min window 42
NOTICE: CPU: MT7981 (1300MHz)
NOTICE: SPI_NAND parses attributes from parameter page.
NOTICE: SPI_NAND Detected ID 0xc8
NOTICE: Page size 2048, Block size 131072, size 134217728
NOTICE: Initializing NMBM ...
NOTICE: Signature found at block 1023 [0x07fe0000]
NOTICE: First info table with writecount 0 found in block 960
NOTICE: Second info table with writecount 0 found in block 963
NOTICE: NMBM has been successfully attached in read-only mode
NOTICE: BL2: Booting BL31
NOTICE: BL31: v2.6(release):46016510e96-dirty
NOTICE: BL31: Built : 10:13:01, Apr 10 2024
NOTICE: Hello BL31!!!

just got my router yersterday and flashed this version. I am having some issues getting my Ipad 4 to connect. I have changed to WPA2 only but nothing

I need it badly because my RD23 turned into a brick

Simply power off the router and start from step 5 again. I encountered a similar behaviour, but eventually, it began to load after several attempts. So, instead of waiting, just after several loops with 'NOTICE: Hello BL31,' power off the router and restart from step 5. Try it 6-10 times.

What is the output in the console? Can you provide a bit more information?

Yes, for RD23, it was necessary in my case.
After I performed the last step of the OpenWrt installation with ubiformat for ..ax3000t-initramfs-factory.ubi, I did a basic router configuration and rebooted the router a few times. After one of the reboots, the router didn't load quickly, but instead the orange light blinked for a long time, and after that it loaded with the default OpenWrt configuration. It was unexpected for me.

I investigated fw_printenv and found that I had:

flag_try_sys1_failed=1
flag_try_sys2_failed=6

After several trial and errors I detected that:

  1. reset to default occurs if I changing flag_try_sys2_failed to any value.
  2. reset to default occurs if I changing flag_try_sys1_failed to ≥ 5 (and for 8 too!).

I have the following explanation based on this bootloader code for AX3000T shared by @remittor (please feel free to correct me if I'm wrong):

  • In Xiaomi routers (new versions) if boot occurs from non-official firmware, after each reboot router adds +1 to counter for flag_try_sys1_failed. If router reaches flag_try_sys1_failed=6, it switch loading from firmware=0 to firmware=1, and tries to boot from another partition (firmware=1). But because after OpenWrt installation I have only mtd8 (and no mtd9), router 6 times tried to load from firmware=1 (it can explain the flag_try_sys2_failed=6 and pretty long boot), and again switching back to load from firmware=0 with default OpenWrt settings. That's why it's important to set fw_setenv flag_try_sys1_failed 0 into /etc/rc.local for RD23.

I do not think so. Otherwise it would also be mentioned in the wiki for the AX3000T RD03.

1 Like

Greetings, openwrt guru.
Given:
firmware: snapshot (now the last one is installed, but there were others)
works as Dumb AP with FT configured

Periodically (unpredictably) in X days from 1 to 10
WIFI drops. This is expressed in the fact that the connection of IOT devices via 2.4 is active, but the data stops flowing, and the laptop and phone lose connection and do not connect to the network.
At the same time, lan continues to work as usual, and when I reboot the router or wireless interface, everything returns to normal.
there is only this error in the logs
hostapd: nl80211: kernel reports: key addition failed
there is nothing more suspicious.

Have any ideas?

Try ImmortalWrt)))
It's not a joke though.

1 Like