OpenWrt support for WAX206

I agree with @dhewg, there's a reason it's not the same all over the globe, but I could test it, just to see if there's an impact.

1 Like

Yes sorry, it was a joke/ironic, I thought it can be understood.

Don't get me wrong, it's up to each one of us. I fact you'll find quite some ppl using another country code on purpose. I just think it shouldn't be recommended without a warning. Nobody around here will enforce anything :wink:


Now flashed my US version, with the same build, no issues.

Thanks @giuliomagnifico and @Finn - The OpenWRT factory builds you posted are working perfectly on my new Australian version - WAX206-100AUS. Loaded simply through the Netgear factory GUI, just one error message about the version being older than the Netgear Factory build but easily dismissed and installed.

Can't tell the difference between the two OpenWRT factory builds in this thread as they are both the same r21758, the same git version, kernel version, same 170 packages, but there is about a 400Kb difference in size.

Have not tried the sysupgrade build that @giuliomagnifico posted.

If You're using GM's factory build (NOT a sysupgrade) I think You are running the latest and greates version - my build is prior to that. The latest update did some magic on the power light so it's green + changes to the firmware - if You are using the squashfs_factory build I provided further up - You can get the latest update here and upgrade Your wax206 in LuCi

My current Firmware version with the latest update is OpenWrt SNAPSHOT r21758-6709edf1e9 Kernel version 5.15.86


Thanks, I thought it was something minor like that. :wink:

What is the other r21758 build? I missed it!

My sysupgrade build have made a mess to me, I had to reset the WAX206 and then I used the factory to upgrade and this worked.

Probably because I haven't resetted the configurations when I uploaded the sysupgrade. As soon as I have some time I'll make another new image, but I hope to see the WAX206 supported from the online image builder, since is way easier to upgrade during these snapshot times :slight_smile:

Minor ?? GM jumped of joy so it better matches his nice setup :wink: -

look at
to see the changes to the latest build that the hardworking people who keeps on pushing to get the wax206 in the mainstream has made..
I think we all appreciate their work very much

1 Like

:partying_face: yeah, now I can keep this AP, before (I mean with the orange power LED) I was really skeptical about it :joy:

Anyway if someone need it, I've made another build [kindly provided by Oracle's watts and CPU cycles :smile: ] with the same .config file, here are both the sysupgrade and factory but I haven't tested it at the moment

If someone want to test it, make a backup obviously, then try with the sysupgrade, if after the reboot the WAX206 is messed up (like the radio interfaces greyed/disabled, etcc..) then reset it with the rear button, wait for the stock firmware, then flash the factory, then restore the backup... last time I did these steps and worked.

Or try to reset the settings during the upgrade, that is easier :smile:

since this is my "main device" at the moment, I don't want to make a mess, since I'm already going/went crazy to solve this issue in my network (now I solved it yesterday but some firewall configs are still "meh?" to me... I don't understand why I have to specify the device where a zone belongs to, if this zone is already assigned to this device/interface... anyway... ).

And please report here the result!

Flashed the image from @giuliomagnifico but there is no pppoe package installed. Now, i have no internet connection tot test. Is there a possibility tot get the package installed? An official build is a little bit easier tot setup. However, The wax206 is currently difficult tot get in The Netherlands...
Thats the reason to test this unnofficial one first and flash the official later.

Oh sorry, no there isn't the pppoe package but

...just attach it to your modem as a normal lan device (create a new interface with the static IP, etc...) and not a router, and install-download the packages you need!

(here in italy you can find it on Amazon for 70/80€, try to check on

What is an official build?

Actually Italy is among the highest for Europe on Amazon, then (for the Netherlands) is better, just below € 100. In December they were selling them there new for € 43!

BTW, I have an uptime of 35 days on r21375 now, and it has pushed no less than 600GB external traffic, without any issues whatsoever.

1 Like

Can someone provide a Factory image with ppoe packages. Saves me a lot of time. I have no connection at the moment. Thanks in advance!

Whoa, that’s true! 160€ :hushed: I paid it 100€ new about 7/10 days ago, and I got a the alert just Tuesday that it was at 74€ refurbished.

Anyway I think that about 100€ is the correct price for the performance of it.

So you still have the ugly orange power LED… :laughing: ahah anyway yes it’s stable and reliable.

Did get internet working from the modem! However ppoe packages wont install. Kernel 5.15.86 is installed, 5.15.90 is needed. Need a newer image with a newer kernel...

You can try these, I added ppp and pppoe (kmods are present as well):

I built factory and upgrades; make sure you don't grab the images with 2500x in the name unless you plan to use 2.5GB wan.

I also have r21929 builds up, however the factory.img was rejected by the netgear factory 1.0.4 firmware version:
Same applies here, 2500x named images will only work on a 2.5GB wan port.

These were minimally tested, I flashed them and that's all. I am not yet using this router as a primary as I want to get a stable 2.5GB build.


Post when/if you need 2.5GbE testers, I got 2.5 (and 10GbE) in my LAN.

At the moment, I'm only using the changes @patient0 had added to the dts previously to make the wan run at 2500x. It does link just fine at 2.5G for me but, I have not run much traffic or testing through it. I did some initial testing/playing with iperf3 (appeared single thread) maxed out the cpu on the wax206 before it reach the max 2.5G. I need to test my laptop on wifi6 with 160mhz channel and see what I can really push through it and multiple 1gb client devices with iperf.

The issues with the DTS changes are that the wan cannot link at 1GB, which would prevent a general image from being built. More specifically, it will appear to link at 1gb speed (ethtool, ip link, etc), however you will not be able to get any packets out. Reading through this thread and another thread link earlier for another device with the same cpu/phy, I understood the issue as having to do with the cpu/phy/physical layer link mismatching/not agreeing on the speed. I was trying to play with some of the patches for hisgmii mode (pending patches 721-730) as I thought this might help, but I've been having trouble with quilt and after the latest kernel jump they do not apply cleanly.

Just some images following the posts before :slight_smile: They are both 1G

Thank you for making that possible.

1 Like