OpenWrt Firmware for Archer c6 v3.2

By firmware upgrade using the tp-link stock interface, but instead of the TP-Link FW file I used the OpenWRT. After 2-3 minutes and one restart you have OpenWRT. Be careful, OpenWRT changes the IP address to 192.168.1.1 instead of the default 192.168.0.1.

@RaresC95 I have tried that approach, I hoped that there is another way that would work for me :frowning:

I will continue to find the way.

Have u tried with TFTP? Instead of the TP-Link FW try with the OpenWRT using the correct name. U have to find out what FW the router is asking. Install TFTP server on your PC, and, with it open and the pc connected only to the router, press the reset button on the router, power it on, then keep it press for more 5 seconds, after that, release it and u should get some information on the server logs, u need the file name that the router is asking, once u got that, rename the OpenWRT file exactly the same, repet the procedure and maybe the router will take the FW file from the server and install it. I DO NOT GUARANTEE that is safe for the router.
This is actually a recovery procedure among U-Boot, but, the recovery page comes up only if the router failed to boot normally, so, you can use only TFTP.
For example if u brick the router u can use the TFTP method to fix it, but, you can "call" it even if it is working. The router will search for the FW file for, u will get a message on the server telling you that one client is searching for a certain file named "***", u need the name, then, repeat it and maybe, not surelt, it will install it safely.

U got one tutorial here:https://youtu.be/54PAS0gvW2k
It it used for recovery but also can force installation of certain firmwares.

@RaresC95 I also tried that with holding reset for 6 seconds and even until WPS led started to flash. The router could not connect and leave logs on the tftpd64 running on my computer. I found somewhere that this might be caused by Windows not bringing up the ethernet interface fast enough.

Maybe using Linux will solve the issue? I successfully used windows 10 for this operation on other routers and it worked.
You can intentionally brick the router so you could get to the recovery page and upload the firmware there. The router will show a steady light on all LEDs and it will only be accessible through static IP. Set 192.168.0.2 as IP address and 192.168.0.1 as default gateway. Be sure u have the correct TP-link Fw before u do it in case the OpenWRT don't work so you can reinstall original Fw through web interface.
Acces the router at 192.168.0.1 and try it on multiple browsers, for me the page don't show up on Google Chrome, only Firefox and edge.
The page is a simple one with only "browse" and "upload". U can't go anything wrong.

BUT BE CAREFUL, on some cases even the recovery page isn't available depending on the "bricking level". Try bricking the router by installing a wrong firmware from other router, not by power off during install, the second ones are much bad and can result in a complete brick instead of a smaller one with web acces to recovery page.

Installing openwrt is very easy process.openwrt can be installed directly from tplink web interface.if it is not working then something is wrong.you can create a seperate thread for the issues.
Maybe this will help you solve the problem,check wheather sha256 checksum of your downloaded file matches with the checksum given in the download page of openwrt, if it is not matching redownload the file again and install.

@RaresC95, I am just planning to learn Linux by using OpenWrt :wink: so no chance right now. How I can "You can intentionally brick the router"?

@Magneto, for some reason, it is not as simple as it should be :frowning:
Checksum is correct:

but when I try to upload it via TP-Link software, then I get:

If the router can't boot normally, it will show a recovery page where you are asked to upload a FW image.
In general, the routers are bricked in 2 ways:

  1. Power off during install firmware procedure.
  2. Wrong firmware, another router/wrong version

BUT, sometimes, if the router is bricked because of a power failure during the install procedure there are some chances that the recovery page won't show up, and, then you have 2 options: TFTP or opening the router to connect your PC via UART.
You can intentionally brick the router by install a wrong firmware file, another router version/another region version, after that, u will get the "boot fail" or "U-BOOT" page that will ask for a FW file. The same thing is happening when you have OpenWRT and try to install back the TP-LINK FW, it will fail and the recovery page will show up asking to upload the firmware, there u can upload any firmware, the OpenWRT again or the TP-link. It is the same if u have the TP-Link Fw and brick the router so you get the page where u can install any Fw like OpenWRT.

Which variant of archer a6 v3.2 you have?

1 Like

Last night I had the first issue since 22.03.3 update, the router, after about 4d uptime, rebooted itself during night, I finded out this morning and I saw the time of the reboot in the PPPoE connection logs offered by the ISP. As I said, it rebooted itself and remained in a weird state, only the power led was on, no WiFi, no ethernet link. It came back to "life" after powering off then on. I connected a laptop with a SSH running with "logread -f" command, maybe I can catch the last logs before any crash/reboot.

It looks like you are also affected by

What version were you using before? Do you have HW acceleration enabled?

It started to happen after update to 22.03.3, no problems with 22.03.0 - 22.03.2. I will revert back to 22.03.2 to see if it's happening on that version too, but, on those versions I had +30 days of uptime. I never used the HW/SW Offloading, the only change since the update is using WPA2/WPA3 instead of only WPA3, since I got an older tablet that can't connect with WPA3.

I am back on Openwrt after having taken a break from it since July and I wanted to say thanks to the developers for having fixed the biggest issue that I was having.
I've been on Openwrt 22.03 from RC1 to RC4 and I think RC5 and I was having an issue where my main phone would disconnect and not reconnect to wifi, it was unusable so I flashed back to stock in July, to give Openwrt a bit more time to mature for this router.
Everything is completely stable on stock, I wasn't getting any disconnects.
Then I saw people having problems with 22.03.0 so I didn't flash it.
Today I wanted to flash Openwrt again but I saw that people are having problems here with 22.03.3. So I decided take versions step by step from 22.03.1 and 22.03.1 was a disaster, none of my devices would connect to wifi.
Then I remembered seeing that 22.03.2 was released shortly afterwards because 22.03.1 was buggy.
So I flashed 22.03.2 and it looks better, now my phone still disconnects at times but quickly reconnects so it at least looks like things are on the right track, it is usable for the most part now.
I've now unchecked "Disassociate on low acknowledgement", to see if that helps.

Before, I was getting AP-STA-DISCONNECTED, disassociated and deauthenticated in the log and that was it, no automatic reconnect.
Now after these 3 lines I get within seconds the next lines: authenticated, associated (aid 2) and AP-STA-CONNECTED.

Other than that, when it comes to network spikes, I am having a similar experience to stock. I am using a VR headset that's connected to Wifi and just like on stock, I get a network spike for a split second every few seconds which means a rather unpleasant frame flashes on the screen when that happens but while things aren't better than on stock, they aren't worse either, I don't know if there could be an external factor.

I'll keep testing and hopefully it will be decently stable, maybe then 22.03.4 will be bug free when it lands and I'll be able to flash Openwrt up to date without issues, without my phone disconnecting at all.
Best regards to the developers!

Just like with the release candidates, I continue to be having a problem not connecting to the internet through Openwrt in my Meta Quest 2 headset (which is running Android 10 basically on Snapdragon XR2) with one of the apps. The app is Deo VR, other apps such as Youtube VR still run just fine. This is one of the reasons why I reverted to stock in the summer as I need wifi connectivity to that app. I am on Openwrt 22.03.2 but I'm not sure that anything has been fixed about this in 22.03.3 and I wouldn't want to be having the problems that you are having with the new firmware.
This is something that has to do with the wifi connection of Openwrt because if I plug in another router into an ethernet port of the C6 (with Openwrt), I am able to connect to the internet in that app, on wifi to that second router.

Try using it non-stop for days and you should run into this bug.

Tested on 22.03.0, 22.03.2 and 22.03.3.