Archer C6 on 22.03.2 crashes every ~3 days

I am running 22.03.2 of OpenWRT on an Archer C6. Approximately every 3 days, it will completely crash - my wifi networks (3 of them) all vanish, and I am also unable to hook an Ethernet cable up (my laptop just says nothing is connected). The solution is to power cycle.

It seems a few days prior to the crash, it stops logging anything (but there are also no errors) - I was suspicious that maybe the logs were being wiped out but I set up a syslog server to log all messages and the last message is from December 1 (the last crash was this morning, Dec 4 around 9:30).

The logs in the lead up to the crash can be found here:

Memory usage is constant (I am monitoring it with grafana)

The only 3rd party packages I have running are (however it was happening when I only had avahi installed and none of the others):

  • avahi
  • udp-broacast-relay-redux
  • prometheus-node-exporter-lua
  • prometheus-node-exporter-lua-nat_traffic
  • prometheus-node-exporter-lua-netstat
  • prometheus-node-exporter-lua-openwrt
  • prometheus-node-exporter-lua-wifi
  • prometheus-node-exporter-lua-wifi_stations

I am not too sure where to go from here? Is there any way to turn on enhanced logging?

  1. Are you running a firmware downloaded from Openwrt or have you build it yourself of have anyone else build it?

  2. Try reinstall a completely new download from OpenWrt and verify the sha256 checksum when installing.

  3. Can you connect with serial when it has crashed?

  4. Hardware failure, some thermal issue or power supply issue.

The firmware is from OpenWRT, I will try and reinstall to see if that helps. I haven't yet cracked it open to try the serial port, some of the lights on the front seem to be blinking still so it's not completely dead during this time.

Does it have a reset button? And does the reset in that case solve the problem or is it only a power off that solves it?

But without a serial connection we are pretty much in the dark to find the actual problem since we can never know if the cpu actually runs when it crashes.

I have just reinstalled the firmware and will see how that fares in a few days - it does have a reset switch which I will give a go next time if it comes up again.

I also have a C6 v3,2 which “fails” intermittently with similar results. It would be good to know if a solution is found.

I tried to reflash the firmware which didn't help - I also discovered that if I left it long enough while it was in this failed state, it would eventually come back up on its own.

however oddly, I went home for the holidays (2 weeks) and came back to find it had remained up the whole time. So It might be related to how many devices are connected at a given time...?

Another data point. Mine crashed again just now, and I watched it briefly before power cycling. It seemed to be trying to soft restart itself and failing, specifically:

  1. All LEDs on
  2. Power LED solid on
  3. Power LED flashes for a couple of seconds
  4. All LEDs off
  5. Wait 10+ seconds and cycle repeats from 1.

I have also noticed that the interval between crashes varies. The shortest I have seen is under 12 hours, the longest was more than a week.

My first thought with these specific symptoms is actually that the psu have some issues.

Have you tried change the psu unit?

I haven’t, and I can try. I am using the manufacturer’s original PSU, so it shouldn’t be underpowered. It also feels unlikely that such an issue (PSU failure) would affect both me and @andeke07

Mine dropped out again about half an hour ago (I've been home since Tuesday, so approx 4 days since I got back). Seems very odd it was stable for the 17 days away, and then 4 days after I get back it crashes again. I'm not exactly an intensive user, I have 2 laptops, an iPad, 2 iPhones and a smart TV/console on it alongside a guest and IoT wifi.

The router itself is only about 2 months old and I'm using the PSU (12v, 1A) that shipped with it

how does the „crash“ look like in detail?

Does it look like joining clients no longer get IP addresses? 22.03.2 has an occasionally crashing DHCP service for some users after varying time of sometimes several weeks. It looks like the period depends on the client types and amounts of clients, how often that can happen.

I do not know, if that is your problem, I just wanted to point out that this is currently an issue in 22.03.2. The next release 22.03.3 might be adressing the DHCP problem (as the problem was fixed in master) and it looks like .3 is currently in build preparation.

Hi Pico,

What happens is all of the WiFi Networks (I have 3: Main, Guest, IoT) disappear and I can no longer connect over Ethernet either (it does not even register something is plugged in). The LEDs on the front go off and it seems to try and reboot itself several times (I see the same LED pattern as @timothyjward). Any device that was connected to wifi is no longer connected. After a physical reboot (or sometimes it will eventually come back on its own I discovered) everything is fine for a few days.


If you connect serial to it and watch what it actually say when crashing or trying to reboot?

I’m not set up at the moment to be able to monitor the serial port, I was hoping there might be a way to enable more verbose logging before the crash but it seems not (I have a syslog server setup but there are no messages of interest at all really in the lead up to the crash). I will see if I can get it pried open and get a serial cable on it.

I am an internet provider. I currently have 18 pcs on my desk after returns from customers who complain about the operation of the router. The customers have a point. What's happening. Routers have the latest version 22.03.2 anyway, it doesn't matter on older ones, the same thing happened. Routers hang after a few days of operation 2-3 days. You can't connect to wifi or the transmission to the router's ip is lost - no gateway and ip address. - that's the symptom. I configured them in bridge wan + lan, set him a rigid IP and connected to another router, which gives dhcp. Nothing helped. Cannot ping when hanged. The problem is catastrophic OPENWRT is completely wrong for this router. There are no problems with the original firmware. Only sometimes the wan changes the speed of 100Mbit to 10Mbit automatically - on the original tplink firmware, which I also do not understand. It doesn't always happen. Generally firmware 22.03.2 and previous are not usable for Archer C6 v3.2 and C6U same symptom. The ip transmission is lost, the router freezes. There is also a problem with connecting to WIFI. Lots of bugs must be in fw. I have stopped using these routers and Openwrt anymore because customers are getting annoyed and outraged by the internet and it's not my fault but Openwrt's fault!

1 Like

Wow! Well I suppose I’m glad I am not the only one seeing the issue. But it sounds like something isn’t working well with these routers and OpenWRT.

While I agree that the hangs are a serious problem, I haven’t found the rest of the system to be problematic. In fact I used to have issues with stock being unable to discover devices using mDNS over WiFi. OpenWRT does that fine.

@rufuss78 If you have access to a lot of failing boxes perhaps you might have time to help with debug, or one you could send to the OpenWRT team for analysis?

I have used one Archer C6v3 for 4 months, without any crash and have flashed and distributed about 30 routers without any major issues thus far. I have, however, build my own images and didn't download the respective snapshots. The packages I use are very slim though, wireguard is the only major thing running, no packages for special routing, adblocking, webinterface etc. So there might either be issues with the extra packages you have installed or with some other configuration you are running.

I am using the vanilla OpenWRT factory image with no additional packages. I have enabled 2.4 and 5GHz WiFi with WPA2/3 mixed mode, PPPoE for my internet access. Everything is default except that I have hardware acceleration enabled.