OpenWrt Firmware for Archer c6 v3.2

So I have to go back to stock ROM and then flash OpenWRT, right?
What about flashing a snapshot? Will I need to install LUCI manually?

Yes and yes. You can install LuCi manually after flashing the Snapshot.

Iirc, sysupgrade from 21 to 22 is mentioned as not recommended in the release notes of 22.03.X

After flashing the factory Rom from Souza, I suggest using the "search for firmware update" function in the interface first before uploading the OpenWrt image, since the version he supplied is an older one.

1 Like

Okay I flashed stock, updated it, then flashed OpenWRT snapshot v22.03.2. I edited the network config but it doesn't work because I can't update the packages in order to install LuCI. I followed a guide:

config interface 'wan'
option ifname 'eth0.2'
option proto 'pppoe'
option username 'username-given-by-isp'
option password 'password-given-by-isp'
option ipv6 'auto'
option persist 'true'
option maxfail '0'
option holdoff '10'

Then I restarted the network but don't have internet connection. Any help will be appreciated :pray:t2:

EDIT: The ISP modem is in bridge mode and the connection is PPPoE. Maybe I'm missing options in the config file?

Try clone your Mac address.some isp need Mac address to match their database.

I solved it! Seems I was missing a single quote character (') in the ifname (which I renamed it to eth0). I also deleted the last 4 lines.


came out 22.03.3

1 Like

Anyone updated to 22.03.3? How's the router running? I had no problems since 22.03.02 and I dont really want some by doing the update.

I have just done a factory.bin flash on a device I reset to TP-Link original software and will also sysupgrade another router shortly. I'll report back in 2 days, but the factory.bin flash with a newly build image was successful and everything is working as expected.

1 Like

I installed back the TP-Link OM FW, then, OpenWRT 22.03.3 with config backup, no problems yet, everything runs just the same.


The sys upgrade from 22.03.02 to 22.03.03 worked fine for me. Has been running fine for 48 hours

1 Like

EDIMAX EW-7811UTC (8812AU) creates a random bug in OpenWRT if after loading it connect/disconnect several times within 5-30 minutes (sometimes more).
During such a bug, the ping does not work for, DHCP does not work.
Manually assigned IP sometimes works, but not for long time. Wireless connection to router Connect/Disconnect with a bug continues to work, but no internet.

Tested on 5GHZ, Windows10/11, Realtek drivers was updated.

I can now confirm that 22.03.3 still has the crash/reboot bug as described in Archer C6 on 22.03.2 crashes every ~3 days

Haven't experienced any crash like you said on my Archer C6 v3.2 US. I had a 13 days uptime on 22.03.2. Now I am on 22.03.3 and it has almost done 5 days uptime.

I just bought Archer A6 v3.2 and tried to install the OpenWrt factory image 22.03.3 and snapshot from Jan 14th for A6 and C6 without any luck.

You have managed to install OpenWrt on C6 v3.2 that has the same hardware as A6. Can you tell me what kind of magic tricks you have done to achieve this?

These questions should be directed at existing threads for the Archer A6, or in a new thread. Attempting to ask them here just causes confusion and risks nobody getting the right answers, either to the original question or yours.

Hi Guys, How did you do that?

I got the EU version 3.20, just installed from the OM Fw. Flashed the factory version and that's all. Use the FW Selector, search for "c6 v3.2" and download the file.


There is no version c6 3.2 on :frowning:

Sorry, my mistake. I have the Archer C6 V3.20 EU and I used the C6 V3 Firmware. It's running good, no problems since 22.03.2, now 22.03.3.

@RaresC95, How have you originally uploaded it to the router overwriting the original TP-Link firmware?