OpenWrt Firmware for Archer c6 v3.2

Hi All,

I just looked up the Router database and ordered a TP-Link Archer C6 to install OpenWRT and setup VPN on it. However, I have received version 3.2 from the seller and not v2 which has support as per the database.

The key difference being that v3.2 has a different chipset (MediaTek7621DAT) and not Broadcom!
https://wikidevi.wi-cat.ru/TP-LINK_Archer_C6_v3.0

Now I would have even tried to install the C5 or any other OpenWRT version that supports MediaTek but I even the Stock Firmware is not available anywhere for download (just in case things go wrong & I brick it)

Here is what I am looking for:

  1. Is there any other version / router firmware that i can try on this router?
  2. Is there a likelihood for this to be supported in future (so i wait instead of messing around with the router)
  3. Can someone share the link to stock firmware so that if i try I can at least go back (unless I totally brick it for good!)
  4. If someone has gone through this drill and has any experience to share, pls do.

Thank you!

v2 is a qualcon chipset...
v3 is a MT7621... It is supported by openwrt (it have hardware acceleration)...
In Brazil, TPLink have the stock firmware in their site.

I dont know if it is the sabe hardware as yours, so be careful...

Thanks for your response, yes somehow when I check in my region it’s not there!!thanks for sharing the firmware..

Would you know which openWRT version will work as there is nothing listed for c6 v3.2 on the download page..

Cheers!

The C6 v3 and v3.2 are not compatible yet... But the chipset is supported, and the wireless drivers are supported too... It just need that someone port the router...

Hmm... Thanks... I guess will have to wait this out...

Support for the A6 v3 is being discussed here:

The C6U and C6 v3 appear to be at least very similar, so supporting the v3.20 probably won't be that hard.

Edit: comparing the C6 v3.20's firmware to that of the A6 v3, the kernel and file system appear to be identical. The flash layout is also identical, so maybe you can even already try booting an A6v3 initramfs if you have serial access.

Hey Thanks for the suggestion. Do you mean A5?
I cant see the firmware for A6 and then one that do is a Qualcom not MT.

A5 on the other hand has similar processor although a higher spec CPU...

Or am i missing something.

Cheers!

No, definitely A6 v3. TP-Link doesn't list all hardware version for a specific region. The us page has v3, but e.g. the nl-be page doesn't.

Ah my bad...you are talking about stock firmware
i was thinking OpenWRT alternative :slight_smile:

I got the stock already from the brazil site posted by @gaspare above...

So now i need to find a viable OpenWRT build to experiment...

Cheers!

Anyone developing this

last two weeks ago, i brought c6v3.2 replacing c60. that was my very bad bad decision. c6 has better configuration, i don't know why c6 doesn't perform near c60... i don't wanna use this stock firmware. we need badly openwrt firmware for c6 v3.2..... please please please

Hello,
Just bought a c6 and it also came with v3.2 hardware. Anything I can test on it ?
Thanks !

I just bought c6 thinking it was a v2 and i can create a mesh with it and my other router running openWRT but no luck because i got the new v3.2. Someone please get this supported!

Not yet... There is a snapshot but its not worth putting on!

I've been following this post: https://github.com/openwrt/openwrt/pull/3786
Apparently there is a running version for v3.2 but still needing review to be merged on openwrt trunk.

I have mid-knowledge about building and testing from sources and/or imagebuilder, however, I dont have a UART cable in case it fails, and can't easily find one in Brasilia during pandemics. I risk bricking and not having a way to recover my router, and this is why I cant right now test and give feedback. If anyone could, I guess it would solve the issue of all tplink devices being built with mediatek nowadays (probably huge amount of devices). It is pretty sad having an almost finished patch ready for merging, needing just a couple tests, lagging from february 21 to now !

Hey, good news ! Apparently there are already builds to test !
Here:
https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/

tplink_archer-a6-v3-initramfs-kernel.bin 95d31b9e6e46776ea8d92e199fa93e99f2920970ae451c6806aee35fa8476689 4659.8 KB Fri May 28 11:30:47 2021
tplink_archer-a6-v3-squashfs-factory.bin 93f15e14c59448dfd3246aaeb1985ad2e0bd7f634e44a58664f88c49d2596558 6257.9 KB Fri May 28 11:30:50 2021
tplink_archer-a6-v3-squashfs-sysupgrade.bin 6b8259b218247c76b3c44115ea63ef201fe77b7dd5cea0ef1b59ce41c4ac601d 6208.6 KB Fri May 28 11:30:50 2021
tplink_archer-c6u-v1-initramfs-kernel.bin 1c1737010ec4155f1d254f63c9f7c225d82020ed6bad286aff394c0d15330ce0 4659.9 KB Fri May 28 11:30:47 2021
tplink_archer-c6u-v1-squashfs-factory.bin ee020b0c42b147eb2dbc1bda879c41430d7ca70d1879a6ec54f2d099027de0c0 5873.9 KB Fri May 28 11:30:50 2021
tplink_archer-c6u-v1-squashfs-sysupgrade.bin 4a3a062d66296140e2e2ce1ac120f1d13f09635d39819a34540b6394be25b089 5824.6 KB Fri May 28 11:30:50 2021

Did anyone tried it out with C6 V3.2 yet ?

I have opened a PR #4222 https://github.com/openwrt/openwrt/pull/4222 for adding Archer C6 V3.2.
This apparently has the same board as Archer A6 and I was able to force A6 build once I uploaded my modification and it worked without any issues on both the builds.

Model TP-Link Archer C6 v3
Architecture MediaTek MT7621 ver:1 eco:3
Firmware Version OpenWrt SNAPSHOT r16846-9bda91d805 / LuCI Master git-21.153.23025-1255c48

Cheers!

2 Likes

How do you get the build output?