OpenWrt Firmware for Archer c6 v3.2

As I need the Deo VR app to work over wifi with my VR headset and I have to plug in my previous router (TP-Link WR841N) into the C6 for that but didn't want to use the stock firmware on that either, I've flashed DD-Wrt on it. Even though OpenWrt is available for that router, which also stopped being updated for it since 2020, I thought I shouldn't risk compatibility again between Deo VR and OpenWrt.
I wasn't sure if something other than the stock firmware would work with Deo VR but DD-Wrt on the WR841N does work with it. Hopefully the problem will be solved in OpenWrt so that I can stop using the old 2.4GHz router and use the C6 over 5 GHz.

Wi-Fi Clients Intel AX201 and Edimax EW-7811utc (Realtek 8812AU) - breaks 5Hz.
There is no ping, but you can connect/disconnect as much as you want.

C6 v3.20 22.03.3 After a few days only the power LED is on, no internet. After turning it off, everything works for a few days. 22.03.3 very unstable software. I installed the original TP-LINK for the client. Customer reports no problems for 2 weeks.

Hello I tried to flash OpenWrt on my archer C6 v3.2. I flashed it following instructions on this page But now I cant get to WebUI of openwrt, I tried but it didnt work. If I connect LAN from Internet to my router and LAN from my computer to router, I do have an internet connection, but still cant access WebUI. I am total noob.

Maybe you flashed an Snapshot version that don't include LuCI, u have to connect with SSH to the router and type:

opkg update
opkg install luci

After that restart the router and it should work.

1 Like

As mentioned in other posts, you have probably installed a development snapshot, not a “release version”. Development snapshots are potentially unstable and don’t come with a web user interface.

If you really are a new user with little experience then I would strongly recommend installing a proper release (currently 22.03.3).

You’re going to need an ssh client to get access to your current router. You likely have one built into your operating system so go to your terminal and use:

ssh root@

This should get you into your router. From there I would recommend manually “downgrading” to the release version as described in


How has 22.03.3 been working for you?
I'm still on 22.03.2 because I've read that some people here had issues with 22.03.3

23.03.4 isn’t officially announced yet - installing may cause issues due to missing packages.

Yes this was the case, thank for your help.

1 Like

Well, it's released now and the build is the same. What should we be waiting for?

Nothing. It’s ready to go now.

Hi, I have this router with OpenWRT 22.03.3. I am using it with FTTH PPPoE 1 Gb/s connection. I have Software and Hardware offload enabled in Firewall settings. The problem is that when I download something on a wired client, the Wi-Fi networks(both 2.4Ghz and 5Ghz) don't have any internet connection anymore, once I stop the download it all gets back to normal. My ISP delivers 940/940 Mbps symetric bandwith, GPON, it's not their fault. It doesn't matter if I download at 10 MB/s or 50 MB/s, the Wi-Fi networks basically get no internet once a high speed transfer is started on wired LAN. I get my internet from a ONT that is in bridge, no routing on it. On original TP-LINK FW it runs perfect, I download at maximum speed on wired clients and the WI-FI clients still have high speed internet.

I can’t be certain but it’s entirely possible that you’re hitting the switching limits of the hardware.

It might help to look at

1 Like

AFAICT it won't work for the Archer A6 and C6 v3:

Devices That Can't Benefit This:

RGMII2 pins are used as GPIO on these:

  • mt7621_tplink_archer-x6-v3.dtsi
    • mt7621_tplink_archer-a6-v3.dts
    • mt7621_tplink_archer-c6-v3.dts

EDIT: It appears to be possible, but you'd have to do some 'hacking' to exchange the WPS button (functionality) for increased speed. Details: 2 Gbps WAN/LAN NAT Routing on ramips MT7621 devices - #180 by arinc9

Is the issue with Archer A6/C6 v3 crashing and ceasing to work after every few days, leaving only the power LED glowing and internet LED not glowing, fixed with 23.03.4?

It's definitely still a problem

I don't have issues anymore since a couple of images build from master over the past 2 months, paired with the memorycheck script I posted earlier this thread. Before latest sysupgrade, a couple of devices had an uptime of 45+ days.

I strongly prefer not to run from master as it's a moving target and subject to potentially catastrophic regressions. When they branch for 23.x and create a first release candidate I'll be on it like a shot!

1 Like

I usually feel the same and did two weeks of testing in different circumstances on 2x C6v3 and on 2x EAP615v1, which uses the same chipsets. No issues under different loads/use cases, so I felt safe to jump this time.

I am now moving onto the AX23v1 which seems to have some issues on its own. Hopefully this will be solved as well with 23.X release.

22.03.5 is not released right now but it is compiled

I am still on 22.03.2, I understand from the comments above that 22.03.3 and 22.03.4 have serious issues.