Mounting USB storage with existing files?

Hi. New here and recently flashed OpenWrt for the 1st time and really enjoyed much of it but currently hitting a wall with USB storage.

My goal is to attach this external HDD to my wrt1900acs so that I can access it as a network drive. This was doable with Linksys' default firmware and I had no problem previously (except IPv6 causing long loading time but this likely isn't relevant), and I'm sure the stock firmware was also using Samba.

I've got two problems at the moment.

  1. The external HDD appears to mount but I couldn't see the files stored in the HDD when I ssh and navigate to the mounting point.

  2. Samba seems to work as I can access the shared directory on my laptop (although it's empty), but for the life of me I couldn't access it on my desktop and get the below error prompt:
    Snipaste_2020-05-17_21-27-04

I've spent the whole weekend doing research and trying different options hoping to resolve these issues but to no avail. Along the way I've even learned ssh.

Would great appreciate any help.

Some relevant details:

  • Again, my router is Linksys wrt1900acs.

  • I flashed davidc502's latest OpenWrt build (built specifically for the Linksys WRT series). I'm pretty sure all required packages are installed. Full-list here: https://dc502wrt.org/releases/openwrt-mvebu-cortexa9.manifest

  • The external HDD is in NTFS. Because there are files on it I didn't reformat it into any other filesystems as suggested in some wiki guides.

  • Again, previously when I was using Linksys' stock firmware to setup the network drive I had no problem accessing the drive on any device.

How about if you use the IP of the router instead of the host name?

Did you install support for NTFS? There is a separate page in the documentation for that.

Thanks for replying

Tried \\192.168.1.1, same error prompt.

I have both kmod-fs-ntfs and ntfs-3g installed, and I did come across this wiki article: https://openwrt.org/docs/guide-user/storage/writable_ntfs
Would these be what you are talking about?

Does it appear to mount, or does it really mount? Mount the drive and execute "df" and "mount" to check it.

1 Like

Now I'm thinking very likely it didn't mount... The thing is that I'm not even 100% sure what mounted looks like...

But I've tried to mount it. I've executed mount -a, results didn't change. I've enabled then mounted all in luci web ui, still same results.

Start by verifying that you have all necessary packages to mount ntfs partitions and create the entry in fstab.

Definitively, you have not mounted any USB drive. Perhaps you could share what steps you followed and what files you edited.

1 Like

Hey Mate. Someone in the davidc502 build main post helpped with the command for manual mounting:

I can now access the files in the HDD through my laptop, but my desktop still couldn't get in; getting the same error message. Any troubleshooting suggestions? Thanks!

Make sure you have samba support for whichever version you are using.

Yeeeees! Finally worked this out.

So, to answer the two questions I had

  1. @eduperez suggested checking if the drive actually mounted and turned out it didn't

Then @onja in the davidc502 main post helpped with commands for manual mounting which worked like a charm:

So, the issue appears to be that ntfs isn't well supported by OpenWrt/Linux. Apparently there are some UUID related bugs but anyway in my case, the symptoms being mounting through Luci does nothing, automount didn't work, and execute "mount -a" via SSH also does nothing.

Upon re-reading this wiki article https://openwrt.org/docs/guide-user/storage/writable_ntfs I realised it does show how ntfs drive should be config'ed.

  1. After almost pulling all my hair out I thought, heck I'll just try map the network drive anyway 'n maybe this could bypass the error. Then I got another error message which is much more helpful:
    0
    (Windows troubleshooting didn't reveal this info at all - goes to show how useless it is..)

Some quick googling revealed where the source of the problem is
https://support.microsoft.com/en-us/help/4046019/guest-access-in-smb2-disabled-by-default-in-windows-10-and-windows-ser

Start form there I went into group policy editor and changed the specific policy from Not configured to "Enabled" and vuala~

@onja also showed how the policy can be configured in the registry (though I didn't try it myself):

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.