Linksys WRT1200AC wireless performance on latest stable

So I’ve been trying to find the perfect OpenWRT router recently, I’ve gone through quite a lot.

So I’ve got a Linksys WRT1200AC v1 now, got OpenWRT loaded just fine but notice WiFi performance on both bands isn’t great.

On stock the speeds would be around 400mb DL which is acceptable because the line is 500 and the ping will be 5-7ms.

On wrt I get 200-300ish which is okay but the ping increases to 20ms in tests, but the latency in games is very unstable from about 20ms in games on stock to about 60-120 (unstable).

Disabling WMM Mode took the ping down to 7ms but Wi-fi speed is drastically hindered only pushing about 20mb.

I’m not technically illiterate but I’m no expert and no settings I changed seemed to make much of a difference.

Any advice on what’s going on? With this router being built for third party firmwares (if I’m not mistaken) I thought performance would be very high.

1 Like

WMM is a required component of 802.11n and faster (HT/ VHT modes), disabling it limits your performance to 54 MBit/s.

Yup, but I was just noting that when it was turned off it resolved the ping issue.

I’ve got it turned back on now to solve wireless speed but still have a ping at least 4x higher than it should be

Marketing and reality are often different things. Linksys has tried to market these as the heir to the throne of the WRT54g in more ways that one. Regrettably, as I understand it, open-source support from the chip vendor has not been what some would consider sufficient.

I know that problem, what you have to do is send a "0" to two files in sysfs on startup to disable a broken feature of the WiFi drivers called "TX AMSDU".

#!/bin/sh /etc/rc.common



echo "0" >> /sys/kernel/debug/ieee80211/phy0/mwlwifi/tx_amsdu && echo "0" >> /sys/kernel/debug/ieee80211/phy1/mwlwifi/tx_amsdu && logger "AMSDU Disabled"

This is a startup script I wrote that fixes it (copy that text to a file in /etc/init.d, set it to be executable and then enable it).


I actually came across the firmware from @davec502 last night and got that installed.

I believe it has that tweak along with various other useful packages preinstalled. Performance now is great, WiFi DL around 2-300 which is great, not quite the 400 on stock but more than enough for me and pings ~7ms and stable.

I don’t know whether that firmware has any other tweaks - but I guess I’d prefer to be running on standard OpenWRT rather than a custom snapshot so I may flash and implement that tweak you suggested and see how I get on.

@NamesAreAPain so I should copy that text to a file, scp it across, then how would I make it executable? Thanks!

Run chmod +x amsdu (or what ever you end up calling the file).

Very useful thanks - I’ve had an annoying couple of weeks getting a wrt setup that actually worked so I’ll leave it be for a while.

Other than this issue - is there anything else you’re aware of that hinders wrt1200ac performance? Even with amsdu disabled I see speeds of ~300 instead of around 400~ but I’m guessing this isn’t resolvable.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.