Lantiq XRX200 Easybox 904xDSL and Speedport W 921v build

In this thread i share here my build for the Easybox 904xDSL and Speedport W 921v device.
I have outsourced the image-builds from the Easybox 904xDSL developing thread.

I use the default config from snapshot which have all devices enable, i have too, so that all images for xrx200 devices will be build.
But my main focus is the Vodafon Easybox 904xDSL with the realname: Arcadyan Arcadyan VGV952CJW33-E-IR. This router will more or less full support without ISDN
Another interresting device is the Telekom Speedport W 921v with realname: Arcadyan VGV953AKW22-B-23 This suport is very raw (only Soc VDSL and Ethernet working).

My interrest are Router with Telephon support, at the moment only router with Lantiq SLIC 1xx are working.

The source are here: https://github.com/plonkbong/openwrt.git branch xrx200-1
It based on https://github.com/Quallenauge/Easybox-904-XDSL.git branch master-lede_rebased_5.4
The source for the very raw Speedport W 921v u-boot is here: https://github.com/plonkbong/openwrt.git branch very-raw-uboot-for-vgv953akw22

I build my images in 5 steps:
0 = download the whole xrx200 snapshot and prepare the build
1 = build openwrt from source
2 = build extra packages with the SDK
3 = copy the packages together and create a reposatory
4 = build customized image by the image builder

step 0 is the openwrt_download_xrx200_snapshot-${TIME}.tar.xz 3-4GB big file which contain all required stuff inclusive buildscripts for building step 1-4
step 1-4 ist ca 2GB big openwrt_build_xrx200_snapshot-x86_64-${TIME}-${BUILD}.tar.xz

################
Builddate: 18.20.2020

The whole directory:
https://mega.nz/folder/NgUTBISL#JswsaBbVLhk_6-Sxus2fsw

All downloaded packages and preparation for build:
openwrt_download_xrx200_snapshot-20201018.151620.tar.xz sha256: 4e614f073172b647371fa1cee06eede52e4ca0dff54c94d094fb37faee51d45a

Build from source SDK and imagebuilder inclusive the whole package reposatory.
openwrt_build_xrx200_snapshot-x86_64-20201018.151620-b1.tar.xz sha256: 4d79fced9aa740c47062ffe5bb6b4ddc55846972be5c35d60f69e4c7248b7785

Separated images from openwrt_build_* An archiv contain the bootloader, ramdisk, install-manuell and various squashfs-images:
full = all kmods and some extra packages so that all Hardware are working (without the things that are not supported)
basic = only all kmods, no extra packages like luci
vpe = one VPE (core) is for the voice process reserved, no SMP support but with Telephon (FXS port support)
smp = with SMP support but the telephon ports will not support
eb904x.tar.xz sha256: f6fec4a50019e1cdc6fd599fc355c295da1cd2213fbb04c0b1cf60243ed11300
spw921v.tar.xz sha256: 7c9dccf223bd5b4aef3e5826996a703f3cd4e01a784483e4c5cc95d897fbe323
################

I will be on top of this thread in future by editing these both post.

1 Like

The FXS ports on the Speedport W 921v are not working i do not know can everyone help ?
in dmesg came this error:

[  113.489685] WARNING: ** ACCESSING SLIC DEVICE FAILED **

in Asterisk came this error:

e[1;30m  == e[0mres_pjsip_publish_asterisk.so => (e[0;33mPJSIP Asterisk Event PUBLISH Supporte[0m)
e[1;30m e[0mLoading chan_lantiq.so.
Bus error

I have add the nosmp code in bootargs from Easybox 904xDSL:

bootargs = "console=ttyLTQ0,115200 mem=116M phym=128M vpe1_load_addr=0x87e00000 vpe1_mem=2M maxvpes=1 maxtcs=1 nosmp";

and add vmmc in DTS:

&vmmc {
	status = "okay";
};

but i have no idea whis GPIO i should set for vmmc.

###########################################

I have enable the FXS ports on the Speedport W921v and get a beep
by enabling the most stuff at the TAPI driver

...
CONFIG_PACKAGE_kmod-ltq-tapi=m
CONFIG_VOICE_CPE_TAPI_FAX=y
CONFIG_VOICE_CPE_TAPI_CID=y
CONFIG_VOICE_CPE_TAPI_LT_GR909=y
CONFIG_VOICE_CPE_TAPI_DECT=y
CONFIG_VOICE_CPE_TAPI_KPI=y
CONFIG_VOICE_CPE_TAPI_QOS=y
CONFIG_VOICE_CPE_TAPI_STATISTICS=y
# CONFIG_VOICE_CPE_TAPI_METERING is not set
CONFIG_VOICE_CPE_TAPI_HDLC=y
CONFIG_VOICE_CPE_TAPI_TRACES=y
CONFIG_VOICE_CPE_TAPI_LINUX_HOTPLUG=y
CONFIG_PACKAGE_kmod-ltq-vmmc=m
CONFIG_VOICE_CPE_VMMC_WITH_DEVICE_VR9=y
# CONFIG_VOICE_CPE_VMMC_DISABLE_DECT_NIBBLE_SWAP is not set
CONFIG_VOICE_CPE_VMMC_MPS_HISTORY_SIZE=128
...

and add all GPIOs that are used in other Router with SLIC-100 devices


&vmmc {
        status = "okay";
        gpios = <&gpio 30 GPIO_ACTIVE_HIGH  //fxs relay
                         &gpio 31 GPIO_ACTIVE_HIGH   //still unknown
                         &gpio 37 GPIO_ACTIVE_HIGH   // from eb904x (reset slic)
                         &gpio 3  GPIO_ACTIVE_HIGH>; //reset_slic?
};

I will see i future what will really need.

But no idea how to get the FXO port running.

Until the Telekom no longer sold Speedports with
the inner workings of AVM, I had dealt with speed-2-fritz.
The firmware of the current t-com devices is often encrypted
or packed or both. I only dealt with alternative firmwares
this year for the EB904.

You have probably already figured out what I am writing.

The Arcadyan VGV952CJW33-E-IR

https://www.onlinekosten.de/forum/showthread.php?t=134416&page=4

(I've found this page only in german)

seems like chips like the TP-Link Archer VR200 / VR200v

https://openwrt.org/toh/tp-link/vr200v

to have.

Here at least the firmware is not encrypted, is partly available
in the source code and is based on OpenWrt

https://www.tp-link.com/de/support/download/archer-vr200v/

(I've found this page only in german)

Maybe it is helpful

@Plonk34 Thank you so much for helping me in the 904xdsl main thread!
(Support for Easybox 904 LTE)

I did not even think it could be possible to use the dsl as ethernet wan port and it works perfectly! Did I miss a documentation about this or is the 904xdsl a rare exception (recent Avm devices got dsl and wan as separate ports)?

After i did the config as you wrote, everything was shown in the webinterface, but i guess it would not have worked via the webinterface alone (similar to the wifi)?

Now I got two more questions that are probably more specific to your build:

After rebooting, the lan port my PC was plugged in becomes disabled.
If I unplug it after issuing the reboot and replug it after it has finished booting, everything is fine.
Does this happen intentionally for some reason?

Is there a way to get a printserver working via Usb?

root@OpenWrt:~# opkg install kmod-usb-printer p910nd luci-app-p910nd
Installing kmod-usb-printer (5.4.72-1) to root...
Downloading https://downloads.openwrt.org/snapshots/targets/lantiq/xrx200/packages/kmod-usb-printer_5.4.72-1_mips_24kc.ipk
Unknown package 'p910nd'.
Unknown package 'luci-app-p910nd'.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-printer:
 *      kernel (= 5.4.72-1-9e5db683a6c79158a9465aec1807cb9b)
 * opkg_install_cmd: Cannot install package kmod-usb-printer.
 * opkg_install_cmd: Cannot install package p910nd.
 * opkg_install_cmd: Cannot install package luci-app-p910nd.

@RENErica thanks for the link, whenn i have time i will take a look to find some usefull code for enabling FXO

yes the AVM Fritzbox 7490 generation, Arcadyan IADs from this time and TP-Link Archer VR200 are the same SoC, but AVM use the Dialog SC 14441 chip for Dect and POTS the China companys use the Lantiq xway SLIC-100er for POTS where the driver exist.

@Matzeee

I think it is a littlebit vendor specific i would say TP-Link = no, AVM = no, Arcadyan = yes, Zyxel = yes, you can take a look in ./target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_*.dts files and numbering the ethernet ports.
But the Easybox is a rare exception in general starting by the screen, using of two switches and the Gray Wan port that can connect "all". When i right see here https://www.dropbox.com/s/3w85q8fn4oi946i/Easybox_904_xdsl_phone_line
Than is behind the gray port a splitter so that the gray port are for FXO, ISDN-in, xDSL and ethernet.
I think it has goods and bats, because the stuff before DSL make the Signal not better, I have a Provider Fritzbox 7360v1, and the DSL Values a litlebit better.

I do not use the webinterface for config my network, but general the switch configuration should work, but the WLAN will not work because the exotic and old driver.

I do not really what you mean, in General it take a long time if the LAN of the Easybox up after reboot.

The reason why it is not working by you, is that you try the kernel modules from openwrt download page.
You can not mix kernelmodules from different kernels.
I have build and upload the complete reposatory, once that nowhere came to the depency hell, and of course because the different kernelbuild.
The whole reposatory is in the openwrt_build_* tar.xz archiv under the path ./3_repo/repo_root
Theroreticly you can copy it to / but you do not have enought space.
Copy only the etc diretory with opkg configuration and keys to your router root and copy the other to an USB stick ideal with f2fs (vfat or ntfs should work too) and modifie etc/opkg/customfeeds.conf with the right link or set a right link to your USB-stick
example:

ln -svf /mnt/usb1/opt/repo_owrt /opt/repo_owrt

Hi,
here is new Easybox904 and OpenWRT user. I found this box already flashed with OpenWRT on ebay kleinanzeigen.
It displays "OpenWrt SNAPSHOT r9245+78-4b403821c6 / LuCI Master (git-19.038.66435-4e5111e)"
I would like to use this router as a mesh repeater / wifi2lan bridge. my basic dsl modem is a fritzbox7490.
LAN and DCHP adresses are working, but I can not get wifi running. Network scan does not work. Is
there anything in need to change?

thanks in advance...
haha

Hi haha,
the wifi configuration with Luci does not work at the moment.
wifi must be set on the ssh command line under /etc/config/wireless

As far as I remember, the Easybox only runs as an AP.

the firmware also seems to be a bit older.
try to login to the box with

ssh root@IPaddress

and enter

uname -a

the firmware from Plonk34 at the top of the page has the version:

OpenWrt SNAPSHOT, r14721+16-4ff7bdfeeb

Linux OpenWrt 5.4.71 # 0 SMP Sun Oct 18 15:51:39 2020 with GNU / Linux

@haha
WLAN works in AP mode only. The driver is very old and not be configured via modern tools like iw, for this reason the webinterface will not work.
For getting WLAN:

1.) configure /etc/config/wireless
unmark option disabled '1'
like

option disabled '1'

or
option disabled '0

2.) be shure that in /etc/init.d/rt3883
load_module are inside start and boot

..
boot() {
        load_module
}

start() {
        load_module
}
..

3.)
test it via:
/etc/init.d/rt3883 restart

4.) look that the startpoint are late:
should be
START=95

5.) disable and enable it:
/etc/init.d/rt3883 disable; /etc/init.d/rt3883 enable

Guessed reason why it not start automatic (when /etc/init.d/rt3883 restart works):
The /etc/init.d/rt3883 must be restarted after the Network is working, because the Ralink RT3883 is a WiSoc which is connected via VLAN-3
For serveral reason the start up of this router is long.

@Plonk34

I've the same problem to connect to the box as Matzeee.
I waited about 45 minutes and none Connection was established after reboot.

After rebooting, the lan port my PC was plugged in becomes disabled.
If I unplug it after issuing the reboot and replug it after it has finished booting, everything is fine.
Does this happen intentionally for some reason?

I do not really what you mean, in General it take a long time if the LAN of the Easybox up after reboot.

It occurs on both Linux Mint 20, 19.3 live DVDs as well as under Windows 10 2004 and 20H2.
But only since kernel 5.4.x

If the /etc/config/network file exists when booting is between Easybox and PC no connection established.
A change of the LAN cable on the ports of the Box fixes the problem.

There is one onBoard ethernet card

"Intel (R) Ethernet Connection I217-V"

installed in my pc.

If I set Auto-Negotiation to

auto
or
1.0 Gb full-duplex

under Windows 10 20H2, no connection is established.

With 100Mb full-duplex the error no longer occurs with present /etc/config/network.

With Kernel 4.19.x this still had to be done without this Auto-negotiation setting works.

Great build, I'm happy that I can turn off the power LED, in previous builds this was not working properly. Thank you very much :slight_smile:

Matzeee have the problem that try to load wrong kernel modules ?
When i say long time, imean max 10 minutes.

I try to confirm your Problem, but i can not.
Is this on all ports or only one ?
Can you post your /etc/config/network (pastebin or so ) ?

The /etc/config/network is posted here:

https://pastebin.com/mVkHWdvL

i think thats the default network file.
if file /etc/config/network deleted, it is automatically created new after reboot.
i've tried your build from the top of the page.
But with my snapshots do i've the same problem.

if you mean with all ports the yellow switch ports.
yes, on all ports of the switch.

I don't have a problem with that. DHCP is working correctly with Ethernet controller I217-V.

Try my new snapshots.

=> New OpenWrt (kernel 5.4.77 VPE) + Asterisk 18.0.1 LTS - Easybox 904 xDSL

Backup link => Click on the button "Pobierz" (file openwrt-lantiq-xrx200-arcadyan_vgv952cjw33-e-ir-vpe-xdsl-squashfs-sysupgrade.bin)
The download is free.