Easybox 904 xDSL OpenWrt installation

If you use VDSL (or ADSL/ annex B) for your internet connection, you can use the DSL marked port, which connects to the internal xDSL modem of this router. If you need WAN over ethernet, you can repurpose one of its LAN ports as WAN port, by configuring the switch(es) accordingly - however, this device is not supported by upstream OpenWrt and rather complicated to work with (two internal switches with a rather peculiar interconnection and magic VLAN incantations, very problematic wireless drivers also connected to these internal switches on a special VID, lots of fun with non-standard BBT markers (which is the main reason why it isn't supported by plain OpenWrt), and a quite complicated way to use the display).

The USB port is on the (very-) slow side, it doesn't make sense to use it for an ethernet card or NAS like features.

If you want to retain your sanity, 10-30 bucks for a better supported/ faster 802.11ac device (the eb904 can route at up to ~55-60 MBit/s) would be well spent (if you need a display, esp32 with an OLED display will get you there easier for a few bucks). This device has some tempting features, both for its time and -with the display- even today, but also a lot of warts, making it a nightmare to work with.

--
Disclaimer: I own an Easybox 904 xDSL, but haven't actually used it in quite a while.

1 Like

@_vvventsi, please read the instructions carefully.

How to use the Small [Recovery] OpenWrt system.

Flash a full OpenWrt system:

  • Use the browser to connect to http://192.168.1.1.
  • Login (no password needs to be set up).
  • Use menu item System -> Backup -> Flash Firmware.
  • After succesfull flash router will reboot into full OpenWrt image.

The DSL port (grey) is a WAN over ethernet (eth0.2) for Internet connection.

ah, cool!

the DSL port can be used as WAN, then there's absolutely no need for an USB ethernet dongle :slight_smile:

Hi, i succesfuly installed the fullimage, but when i try to install a full OpenWrt system it's being downloaded to the router but a seconds later it says that the file is invalid. I tryed with both files but no success. Here is a Video . Any ideas?

Well i tried to flash the firmware again and it doesn't work. It transfers to the TFTP Server but the router stays in resque mode and doesn't do anything

Listen, you must use TFTP server.
Use Ubuntu/Debian/Mint (Live).

Open a Terminal window, press Ctrl+Alt+T.
Download small OpenWrt [Recovery] firmware:

wget https://github.com/zuzia-dev/Easybox-904xDSL/raw/master/fullimage.img-VPE -O fullimage.img

or

wget https://github.com/zuzia-dev/Easybox-904xDSL/raw/master/fullimage.img-SMP -O fullimage.img

Run commands:

su
apt-get install atftpd
mkdir /srv/tftp
chmod 777 /srv/tftp
cp fullimage.img /srv/tftp
rm /etc/default/atftpd
cat << EOF >> /etc/default/atftpd
USE_INETD=false
OPTIONS="--tftpd-timeout 300 --retry-timeout 5 --maxthread 100 --verbose=5 --bind-address=192.168.2.100 /srv/tftp"
EOF
ifconfig eth0 down
ifconfig eth0 192.168.2.100 netmask 255.255.255.0 up
systemctl restart atftpd.service

Now connect your EasyBox 904 xDSL (yellow port) with your PC with a LAN cable. Turn the box on while pressing the reset button. Release the button after 5 seconds. You now should see the red recovery screen.
1

2

3

When it states that rescue process is complete, turn it off and on.

Change the IP addres of your computer to 192.168.1.2

ifconfig eth0 192.168.1.2 netmask 255.255.255.0 up

Open a browser and browse to: http://192.168.1.1
Use menu item System -> Backup -> Flash Firmware.
Click the Browse button in section "Flash new firmware image" and choose the openwrt-lantiq-xrx200-arcadyan_vgv952cjw33-e-ir-vpe-squashfs-sysupgrade.bin or openwrt-lantiq-xrx200-arcadyan_vgv952cjw33-e-ir-smp-squashfs-sysupgrade.bin from your downloads directory. Click Flash Image and wait. Then on the new site click Proceed.

The router will now flash the firmware image. Wait about 3 minutes and then open the website http://192.168.1.1

Thanks for the instructions! Just turning on my Ubuntu laptop, will try these in a sec. Hope it works!!!:smiley:

UPDATE:
I did the commands but the last ones for ipconfig i get error no such device (i saw that the command is for changing the ip to 192.168.2.100 and i already chose it). I checked the srv/tftp folder and the fullimage.img file is there. Everything would work BUT the router just stays on the resque process is detected... And doesn't flash the firmware 🤷
It did the same on my windows pc
P.S.
It was because of the eth0 commands. I replaced it with enp9s0 and it worked.

Yes, eth0 is the first Ethernet interface, this is an example.

1 Like

It works!!!! Thank you, you're awesome :heart::heart::heart:

Any ideas why in the settings the wifi seems to be open but my phone detects both wifis with password protected

Unfortunately encryption settings just won't show up in LuCI.

Do not use LuCI for Wi-Fi configuration. You can only turn ON/OFF WiFi in LuCI. All wireless settings must be made in the command line with vi or nano. You can edit the configuration file /etc/config/wireless.

1 Like

You said that the DSL port= WAN...i plugged my Wan cable there but unfortunely there isn't any internet :man_shrugging:

Restart ISP's modem and your router.
But if it doesn't work, restore default settings in LuCi. Use menu item System -> Backup \ Flash Firmware -> Perform reset.

1 Like

Unfortunately no success :disappointed:

Could it be because of the switch configuration? This is my current configuration https://i.postimg.cc/Kzd3ZwpV/IMG-20210520-205843.jpg
I saw that i need to create a second VLAN with everything off and WAN- untagged but as soon as i apply it, it goes back to the last settings 🤷

Why do you want to change VLANs configuration? The default settings are correct, the grey port is the WAN port (over Ethernet). Connect it to your ISP's equipment.

/etc/config/network

## Port on Easybox 904x switch1 ETH-0 - ETH-3: [DSL+WAN][ISDN][ISDN][ETH-0][ETH-1][ETH-2][ETH-3] (Power)
#Lantiq switch0
#port 0 ---Lan1----------------------- rtl8367 switch1
#port 4 ---Lan2----------------------- WAN
#port 5 ---Lan3-Vlan66-Vlan71--- WLAN WiSoC rt3883

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'
    option ipv6 '0'

config globals 'globals'
    option packet_steering '1'

config device
    option name 'eth0'
    option macaddr '9C:80:DF:63:F9:D0'
    option ipv6 '0'

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ipv6 '0'
    list ifname 'eth0.1'
    list ifname 'eth0.66'
    option force_link '0'

config device 'lan_eth0_1_dev'
    option name 'eth0.1'
    option macaddr '9c:80:df:63:f9:de'
    option ipv6 '0'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'
    option ipv6 '0'
    option metric '20'
    option delegate '0'
    option broadcast '1'

config device 'wan_dev'
    option name 'eth0.2'
    option macaddr '9c:80:df:63:f9:22'
    option peerdns '0'
    option ipv6 '0'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option fid '1'
    option ports '0 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 6t'

config switch
    option name 'switch1'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch1'
    option vlan '1'
    option ports '0 1 2 3 6t'

config device 'inic_dev'
    option name 'eth0.3'

config interface 'inic'
    option proto 'none'
    option ifname 'eth0.3'
    option ipv6 '0'

config switch_vlan
    option device 'switch0'
    option vlan '3'
    option vid '3'
    option fid '3'
    option ports '5 6t'

config device 'wlan_dev'
    option name 'eth0.66'
    option macaddr '9c:80:df:63:f9:d1'
    option ipv6 '0'

config switch_vlan
    option device 'switch0'
    option vlan '4'
    option vid '66'
    option fid '4'
    option ports '5t 6t'

#config device 'guest_wlan_dev'
#	option name 'eth0.71'
#	option macaddr '9c:80:df:63:f9:d2'

#config switch_vlan
#	option device 'switch0'
#	option vlan '5'
#	option vid '71'
#	option fid '5'
#	option ports '5t 6t'


#config interface 'wan6'
#	option ifname '@wan'
#	option proto 'dhcpv6'
#	option reqaddress 'try'
#	option reqprefix 'auto'
#	option auto '1'

I don't have any equipment from my isp. I have just a Wan cable which goes to the router and from the router it splits...

I don't know, maybe IP address 192.168.1.1 conflicts with the WAN IP subnet.
Check System Log: http://192.168.1.1/cgi-bin/luci/admin/status/syslog

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.