Support for Easybox 904 LTE

well by now i managed to install openwrt on the device, finally lol. but now i have the problem with WAN. i kinda dont understand how to handle 2 vlan switches to assign WAN to a lan port. any combination i do does not work. they either turn each other off in the switches settings, or the changes revert.
so what i try to do is, to use EB904xdsl as a wlan router, not as a dsl modem, since i already use another a dsl modem.
is there any good tutorial how to assign properly a WAN connection to a lan port? or is it even possible to assign WAN to the dsl port or to the isdn port?
im also a bit confused aobut how the ports are named. so i guess LAN1 - LAN 4 are named eth0,1, eth 0,2, eth0,3 and eth 0,66?
and the dsl port is just eth0 while the black isdn port is eth0,77? am i right?

i actually managed to get internet connection without switching modems, but problem is, i managed it by adding an unmanaged to interfaces. i actually want to seperate EB904xdsl with the modem router and i want EB904xdsl to manage the IP, not my modem. so the unmanaged route is not good for me. so yeah, if anyone has any idea how to properly assign a WAN to one of the ports, i would be glad to know.
i run the newest snapshot btw by quallenaugo from 2020-07-10 from this link: https://app.box.com/s/hvqg535dnubt4r2ontpmtodpvt6ydf00/folder/36913951101

EDIT: also tried to add a new WAN to (example) eth0,3. internet works but stillIP is not managed by eb904xdsl. usually it the IP should be displayed in the interfaces under the WAN addition. what i basically want, is to have my modem and eb904xdsl independent as if i would plug in just a wlan router (works with my other openwrt wlan router). jnot sure if this issues accure bc eb904 is actually a dsl modem and not solely a wlan router.

another problem is, somehow i cant update the software packages. i get "Failed to send request: Operation not permitted". how do i actually install some/can connect to the package repos? reason i need this, is, bc there is no wpa set up. no wlan encryption set ups, nothing.

also, somehow i dont get why in switches, in vlan switch0, the LAN is connected to vlan switch01 LAN1. whnever i turn off LAN in switch0, automaticall LAN1 in switch01 is turned off. besides eb904 fails to save the settings. let me show you quickly what i do: https://i.imgur.com/V9YVkYj.png
i basically tried to use lan port 2 as wan.

EDIT 2: so now i connected the lan cable directly to my main dsl router and it turns my eb904 to a switch without any ip. cant access its standard gateway ip anymore. i could do it before when i connected the lan cable to my current openwrt wlan router that connected to my main dsl router. but direct connection between eb904 and my main modem results in my modem overtaking the eb904 and making it non.existence in the network, as if it was just a switch without any interface.

either im a total noob or eb904 is just depressing if you want to use it as a openwrt wlan router connected to the main dsl modem router

Hi @Jum you are totally wrong
ISDN is only for ISDN
There is intern the Lantiq switch0 connected to WLAN WiSoc rt3883 and connected to rtl8367 switch1

Lantiq switch0
port 0 ---Lan1----------------------- rtl8367 switch1
port 4 ---Lan2----------------------- WAN
port 5 ---Lan3-Vlan66-Vlan71--- WLAN WiSoC rt3883
(port means the intern ports not the yellow port outside)

This should work, note guest WLAN eth0.71 are not conneted/enable and not much tested in the past:


config globals 'globals'
	option ula_prefix 'fd36:68fe:1571::/48'

# Port on Easybox 904x switch1 ETH-0 - ETH-3: [DSL+WAN][ISDN][ISDN][ETH-0][ETH-1][ETH-2][ETH-3] (Power)

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch
	option name 'switch1'
	option reset '1'
	option enable_vlan '1'

	
###################################################################
	
	
## hauptswitch switch 1
config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 6t'

## DSL port + wan on eth0.2
config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

## wlan inic
config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option fid '3'
	option ports '5 6t'

## wlan normal
config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '66'
	option fid '4'
	option ports '5t 6t'

## wlan guest
config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '71'
	option fid '5'
	option ports '5t 6t'

##########################################################
	

## hauptswitch switch 1 ports
config switch_vlan
	option device 'switch1'
	option vlan '1'
	option ports '0 1 2 6t'

##########################################################


config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '9c:80:df:91:c9:02'
	
config device 'ethwan_dev'
	option name 'eth0.2'
	option macaddr '9c:80:df:91:c9:01'

config device 'dsl_dev'
	option name 'dsl0'
	option macaddr 'c8:07:84:ed:38:54'

config device 'wlan_dev'
        option name 'eth0.66'
        option macaddr '9c:80:df:91:c9:03'

## guest wlan
# config device 'guest_wlan_dev'
#        option name 'eth0.71'
#        option macaddr '9c:80:df:91:c9:04'

###########################################################


config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option tone 'av'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'
#	option firmware '/lib/firmware/FB7360.111.06.30/dsp_vr9/vr9-B-dsl.bin'
	

#############################################################


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	
config interface 'inic'
	option proto 'none'
	option ifname 'eth0.3'
	
config interface 'isp0'
	option proto 'none'
	option ifname 'dsl0'
	option ipv6 '0'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.41.1'
	option ip6assign '60'
	option ip6hint 'aa'
	list ip6class 'wan6_dsl'
	list ip6class 'wan6_eth'
	list ifname 'eth0.1'
	list ifname 'eth0.66'

#################################################################


config interface 'wan_dsl'
	option ifname 'dsl0'
	option proto 'pppoe'
	option username 'USER'
	option password 'PASSWORD'
	option ipv6 '1'
	option defaultroute '1'

config interface 'wan6_dsl'
	option ifname '@wan_dsl'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config interface 'wan_eth'
	option proto 'dhcp'
	option ifname 'eth0.2'
	option auto '1'

config interface 'wan6_eth'
	option ifname '@wan_eth'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option auto '1'


## DSL port + wan on eth0.2
config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

config device 'ethwan_dev'
	option name 'eth0.2'
	option macaddr '9c:80:df:91:c9:01'

Unfortunately, it doesn't work with kernel 5.4.
Interface eth0.2 is not able to obtain an IP address via DHCP. @Plonk34, can you please help with this matter?

Hmm, Dammed i wich this this device works full once at the beginning.
I check it and i have the same problem.
but the dtsi file diver from the 4.19 wich was working:

1 Like

File dtsi from github @QAuge:

&eth0 {
	lan: interface@0 {
		compatible = "lantiq,xrx200-pdi";
		#address-cells = <1>;
		#size-cells = <0>;
		reg = <0>;
		mac-address = [ 00 11 22 33 44 55 ];
		lantiq,switch;
		/*rtl8367*/
		ethernet@0 {
			compatible = "lantiq,xrx200-pdi-port";
			reg = <0>;
			phy-mode = "rgmii";
			fixed-link {
				speed = <1000>;
				full-duplex;
			};
		};
		/* rt3883 soc */
		ethernet@5 {
			compatible = "lantiq,xrx200-pdi-port";
			reg = <5>;
			phy-mode = "rgmii";
			tx-delay = /bits/ 8 <3>;
			fixed-link {
				speed = <1000>;
				full-duplex;
			};
		};
	};

	wan: interface@1 {
		compatible = "lantiq,xrx200-pdi";
		#address-cells = <1>;
		#size-cells = <0>;
		reg = <1>;
		mac-address = [ 00 11 22 33 44 66 ];
		lantiq,wan;
		/* wan port */
		ethernet@4 {
			compatible = "lantiq,xrx200-pdi-port";
			reg = <4>;
			phy-mode = "gmii";
			phy-handle = <&phy13>;
		};
	};
};

I just replaced that section and eth0.2 functionality is back.

&eth0 {
	interface@0 {
		compatible = "lantiq,xrx200-pdi";
		#address-cells = <1>;
		#size-cells = <0>;
		reg = <0>;
		mac-address = [ 00 11 22 33 44 55 ];
		lantiq,switch;
		
		ethernet@0 { /*rtl8367*/
			compatible = "lantiq,xrx200-pdi-port";
			reg = <0>;
			phy-mode = "rgmii";
			fixed-link {
				speed = <1000>;
				full-duplex;
			};
		};

		ethernet@5 { /* rt3883 soc */
			compatible = "lantiq,xrx200-pdi-port";
			reg = <5>;
			phy-mode = "rgmii";
			tx-delay = /bits/ 8 <3>;
			fixed-link {
				speed = <1000>;
				full-duplex;
			};
		};
		
		ethernet@4 { /* wan port */
			compatible = "lantiq,xrx200-pdi-port";
			reg = <4>;
			phy-mode = "gmii";
			phy-handle = <&phy13>;
		};
	};
};

@Plonk34, thank you very much for your suggestion.

1 Like

Here i share my build. I am unhappy, the -initramfs-kernel.bin is bigger than 5MB and do not work for the same reason.
How it is possible to make tham smaler on the same build without much changing, specially for the the other devices.

I build it in 4 steps download, build-from-source, SDK-build, and build a imamage-via-imagebuilder.
See post 203

Downloaded packages and preparation for build: Ca 3,4GB split into 200MB parts
for add than together use this command:

cat openwrt_download_xrx200_snapshot-20201003.233027.tar.xz.part* > openwrt_download_xrx200_snapshot-20201003.233027.tar.xz

openwrt_download_xrx200_snapshot-20201003.233027.tar.xz
sha256: 12816c725ec89453e2ab679fb19a9b76b1d2eaab72deed0799acec1d80902dc3

Build from source SDK and imagebuilder: Ca. 1,8GB split into 200MB parts
for add than together use this command:

cat openwrt_build_xrx200_snapshot-x86_64-20201003.233027-b1.txr.xz.part* > openwrt_build_xrx200_snapshot-x86_64-20201003.233027-b1.tar.xz

openwrt_build_xrx200_snapshot-x86_64-20201003.233027-b1.tar.xz
sha256: 51c3f5541fb0b0a29ac684711c722539ada1a068e0aebeb2262627020287e8e8

As i say below the ramdisk will not work on this build. Use the old fullimage.img with kernel 4.19
Here the VPE image with Telefon support and the old working fullimage.img:
eb904x-images-2020.10.03
fullimage.img
sha256: e56920cb5df61c2fd82ab887c32aaee4e4ded52e8985c6031c8a9c48b5ea9c26
openwrt-lantiq-xrx200-arcadyan_vgv952cjw33-e-ir-vpe-squashfs-sysupgrade.bin
sha256: 5f64e5190bdad861d5b44879d91b550fcdbfa81a1e2c734fdc24f6f57f452ce5

#############

Now i have to start to share my build in a separated thread the last is from 18.10.2020
Question to this build please in the additional thread.

2 Likes

In the old thread, kovz in 2017 shared the following diagram:

https://www.dropbox.com/s/3w85q8fn4oi946i/Easybox_904_xdsl_phone_line .png?dl=0

However, I don't quite understand where the S0 bus port is found in that picture. Maybe someone can elaborate.

The diagramm shows the entry on the Gray DSL connector: and when i right see is it:

WAN -> Ethernet on port4
       or:

       xDSL Modem
       and:
       ??? TEA1 (N/U) on FXS1
       or: 
       ? ISDN input over "4B3T ISDN NT" 
       or:
       ? FXO POTS over Si3050 and Si3011

When i right understands work the Easybox 904xDSL on Ethernet WAN, Full-IP DSL line and various combination of DSL-lines with POTS or ISDN. (The splitter are inside the Box and i guess that is the reason why the EB904x have litle worse DSL signal like my Provider Fritzbox 7360)
In this diagram it looks like that FXS-1 have direkt access to the Provider-Landline. But no idea if general or under which circumstances (no power ?).

I fear that this diagramm does not show the S0-Bus.

I found This: TP-Link TD-W8970/TD-W8980/TD-W9980 disable SW_ROUTING kernel patch
It should prevent to forward broadcast to all switch ports.

I add this to my build from 18.10.2020 and it looks like that works OK.

Is it possible to use one of the LAN-ports as WAN with the 904xdsl?
I tried to set it up via a VLAN but I got puzzled because of the two switches.

My assumption was to create a second VLAN and assign one of the LAN-ports as untagged, but never got it to work as expected.
The webinterface never offered eth1.x and eth0.2 was already there before, but binding it to WAN (instead DSL) did not work.

Or might it be necessary to configure this via ssh instead of luci (similar to wifi)?

I am on Plonk34's latest smp-full_nofxs

If you want to use the gray (DSL) port as ethernet WAN port than you can add the followig code
(but of course it is an example you can change the MAC etc.)


config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'
	
config device 'ethwan_dev'
	option name 'eth0.2'
	option macaddr '02:26:33:51:69:02'
	
config interface 'wan_eth'
	option proto 'dhcp'
	option ifname 'eth0.2'
	option auto '1'

config interface 'wan6_eth'
	option ifname '@wan_eth'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option auto '1'
	

If you want to separate an single Yellow port for example as WAN Port use the following code
Port 3 means the port next the USB and power connector.
(it use vlan 7 and eth0.7 for example but the next free is normally 6)


config switch_vlan                                                            
	option device 'switch0'                                               
	option vlan '7'                                                       
	option vid '7'                                                        
	option fid '7'                                                        
	option ports '0t 6t'
	
config switch_vlan
	option device 'switch1'
	option vlan '7'
	option ports '3 6t'
	
config device 'port3_dev'
	option name 'eth0.7'
	option macaddr '02:26:33:51:69:07'
	
config interface 'wan_eth'
	option proto 'dhcp'
	option ifname 'eth0.7'
	option auto '1'

config interface 'wan6_eth'
	option ifname '@wan_eth'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option auto '1'

and of course you must remove port 3 from eth0.1:


config switch_vlan
	option device 'switch1'
	option vlan '1'
	option ports '0 1 2 6t'

If you want a tagget VLAN 8 on Port 3 of the yellow switch. this should work:


config switch_vlan                                                            
	option device 'switch0'                                               
	option vlan '8'                                                       
	option vid '8'                                                        
	option fid '8'                                                        
	option ports '0t 6t'

config switch_vlan
	option device 'switch1'
	option vlan '8'
	option vid '8'
	option ports '3t 6t'

What I have not succeeded so far a tagget VLAN with vid = 100 but on eth0.9 or so.
And i have not really understand the meaning of FID.

2 Likes

Hi,
I just got an EasyBox 904 xDSL a few weeks ago. I'm planning to use it either as a gateway or as a dumb modem (via pppoe passthrough), with telephony (VPE) enabled.
I used Quallenauges fullimage.img from 2018 to flash an image I built from Plonk34s openwrt xrx200-1 github branch. I did a clean build (scripts/update and install, make menuconfig, make download, make -j5).
I flashed the image successfully (forceupgrade, version checks out).

I'm now trying to get VDSL to work. My ISP is Vodafone Germany (used to be Arcor), but I'm sure it's a Telekom line (there's a Telekom logo on the TAE). Speed should be 50/10Mbit.
The EasyBox 804 states the 'DSL Mode' is G.993.5. It also has always falsely claimed the speed to be 110/37Mbit, but that's probably the unthrottled speed.

I'm aware that specific points have been raised in this thread before (and elsewhere).

Still, here are some things I am not sure about:

  • VLAN ID: Should be 7 for Telekom. Do I configure the physical DSL port (switch0 port 4) as untagged VLAN 7? Or do I just use 'dsl0.7' in the wan section?
  • Vectoring-capable firmware: I downloaded installed 5.9.0.C.1.7-5.9.0.A.0.2 from https://xdarklight.github.io/lantiq-xdsl-firmware-info/
  • PTM: for VDSL, xfer_mode in dsl section should be 'ptm'. Do I have to create a ptm device section? Do I keep the atm-bridge section? Do I use dsl or ptm for wan interface?

My /etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdba:2027:3db5::/48'

# Is this section needed when using ptm?
config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

#Or do I need a section like this one:
#config device 'ptm_dev'
#	option ifname 'dsl0'
#	option name 'dsl0.7'
#	option type '8021q'
#	option mtu '1500'
#	option vid '7'

config dsl 'dsl'
#      or annex b?.
	option annex 'j'
#	option firmware '/lib/firmware/lantiq-vrx200-b.bin'
#      ^ no vectoring; fritzbox firmware:
	option firmware '/lib/firmware/fb/vr9-B-dsl.bin'
	option line_mode 'vdsl'
	option xfer_mode 'ptm'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.2.8'
	option dns '1.1.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list ifname 'eth0.1'
	list ifname 'eth0.66'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr '9c:80:df:91:5a:60'

config interface 'wan'
	option ifname 'dsl0.7'
	option proto 'pppoe'
	option username 'vodafone-vdsl.komplett/vk0123456789'
	option password 'secret'
	option ipv6 '0'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '9c:80:df:91:5a:61'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 6t'

# DSL/WAN port, was set to VLAN 2
config switch_vlan
	option device 'switch0'
	option vlan '7'
	option vid '7'
	option ports '4 6t'

config switch
	option name 'switch1'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch1'
	option vlan '1'
	option ports '0 1 2 3 6t'

config device 'inic_dev'
	option name 'eth0.3'

config interface 'inic'
	option proto 'none'
	option ifname 'eth0.3'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option fid '3'
	option ports '5 6t'

config device 'wlan_dev'
	option name 'eth0.66'

config device 'guest_wlan_dev'
	option name 'eth0.71'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '66'
	option fid '4'
	option ports '5t 6t'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '71'
	option fid '5'
	option ports '5t 6t'

With the non-vectoring firmware, I got a DSL link once.
The pppoe-wan interface even got an address, but I could only ping the pppoe-peer.
After a reboot I didn't even have a dsl interface anymore. :expressionless:

I apologize for my post being a bit of a mess, but I don't get many maintenance (breaking the internet) windows and I'm mostly one-handed at the moment.

Anyway, I will try to get more detailed information on my next 'maintenance window'.

It is right you have VDSL2 with Vectoring and enought SNR (because your ATTNDR is higher them you use) ?
The switch should not involved but i never try differnt configs like the default.
option annex 'j' is totally wrong on VDSL2

Try:


# the following part should not be relevant but it works by me
config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
#       option annex 'b'
        option tone 'av'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'
#       option firmware '/lib/firmware/extra-dsl-fw/fb7490-7.21/vr9-B-dsl.bin'
        option firmware '/lib/firmware/extra-dsl-fw/eb904x-4.13/dsl_vr9_firmware_xdsl-05.07.03.03.00.07_05.07.04.03.01.02.bin'
        
config device 'dsl_dev'
        option name 'dsl0'
#       option macaddr 'c8:0e:46:ed:83:07'

config interface 'wan'
        option ifname 'dsl0.7'
        option proto 'pppoe'
        option username 'USERNAME'
        option password 'PASSWORD'
        option ipv6 '1'
        option defaultroute '1'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'
        option iface_dslite '0'
        option reqaddress 'try'
        option reqprefix 'auto'

Note on VDSL it does not make sense to use "option annex" and "option firmware" because the right annex will be choice by the FW the dsl_control script make only a choice between annex-A or annex-B Firmware.
Try different DSL-FW if it not works.
On me (i have a regional ISP without Vektoring) i have the strange "problem" (but it works well) that i must set "option tone 'av'" then it works well but it show my that i am cannected via Annex-A.
If i do not my DSL-line are extrem unstable. This is totally strange and i never found the reason.

Please print alway the result with:

/etc/init.d/dsl_control dslstat

If you have an sync please post the result of

ifconfig

too

Normally the telekom line have an fallback to VDSL2 without vectoring, with maxspeed 20Mbit/s.
It is a good strategie to use the default FW ("option annex 'b'" without "option firmware", be shure that the default FW are installed), because they is more stable, after that works try different FWs.

Hi Plonk34,
I really appreciate your reply.
This morning I got a maintenance window again. I used the xDSL firmware I mentioned ( 5.9.0.C.1.7-5.9.0.A.0.2). I got VDSL running with the following dsl section:

config dsl 'dsl'
	option annex 'b'
#	option firmware '/lib/firmware/lantiq-vrx200-b.bin'
	option firmware '/lib/firmware/fb/vr9-B-dsl.bin'
	option tone 'bv'
#	option ds_snr_offset '0'
	option line_mode 'vdsl'
	option xfer_mode 'ptm'

Because it seemed illogical to me that I could only ping the peer on the ppoe-wan interface while also having an address not in the usual range, I checked my documents again and it turned out I used wrong (outdated) DSL credentials :upside_down_face:
After I put in the right ones, it worked!

This is my dslstat:

ATU-C Vendor ID:                          Broadcom 192.26
ATU-C System Vendor ID:                   Broadcom
Chipset:                                  Lantiq-VRX200
Firmware Version:                         5.9.0.12.1.7
API Version:                              4.17.18.6
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.5 (VDSL2 with down- and upstream vectoring)
Profile:                                  17a
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 163548
Errored seconds (ES):                     Near: 0 / Far: 183
Severely Errored Seconds (SES):           Near: 0 / Far: 3
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 147 / Far: 147
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency [Interleave Delay]:               0.15 ms [Fast]   0.0 ms [Fast]
Data Rate:                                Down: 109.981 Mb/s / Up: 36.996 Mb/s
Line Attenuation (LATN):                  Down: 7.6 dB / Up: 5.5 dB
Signal Attenuation (SATN):                Down: 7.6 dB / Up: 5.6 dB
Noise Margin (SNR):                       Down: 14.3 dB / Up: 9.2 dB
Aggregate Transmit Power (ACTATP):        Down: -3.6 dB / Up: 14.4 dB
Max. Attainable Data Rate (ATTNDR):       Down: 108.840 Mb/s / Up: 40.574 Mb/s
Line Uptime Seconds:                      2907
Line Uptime:                              48m 27s

Speed test checked out (50/14 Mbit).

It is a good strategie to use the default FW ("option annex 'b'" without "option firmware", be shure that the default FW are installed), because they is more stable, after that works try different FWs.

Do you mean the firmware installed by dsl-vrx200-firmware-xdsl-b? That one isn't vectoring capable, right? Or can the xdsl firmware be extracted from the vendor firmware?

Anyway, I just got everything up and running. Time and tests will tell how stable everything is.

You can also refer to my experiments with different vectoring-enabled firmwares from August this year (see above).
Your line is in fact a DTAG line leased by Vodafone (they do not lease the naked copper line, but they rather purchase IP-based connectivity). The DSLAM is configured to limit your DSL connections to 110000/37000 kbps (apparently that's the profile used for such configurations). The IP data stream should be limited to your subscription's parameters, which I guess are 50 Mbps downstream and 10 Mbps upstream (those browser-based speed tests are not necessarily too accurate).
Thanks to this data rate capping the Easybox 904 is fast enough to sustain the throughput (would be a different picture if you had a 100 Mbps subscription).

I finally got my hands on an Easybox 904LTE. Are there any OpenWRT images available for inastallation via tftp? Am I correct that the LTE modem is not supported by OpenWRT at this point?
My box has the AT904L-03.18 firmware installed, so no telnet support :frowning:

Try software from this site (http://chomikuj.pl/ZuzannaCK/ROUTERY/EASYBOX+904+LTE/Firmware+Vodafone). It is definitely possible to downgrade. I made also a downgrade on mine device, because I needed telnet to change lte provider.

1 Like

Despite the title, this thread is more about the xDSL variant and not the LTE device. While the xDSL variant is mostly supported out-of-tree (as there are considerable difficulties to support it in a way that doesn't break other lantiq devices), there hasn't been a lot of development for the LTE variant so far.

Thanks for the hints. With the 3.07 image's SQL Injection-type of bug I was able to activate telnetd and perform the necessary settings (https://router-kaufen.com/vodafone-easybox-904-lte-fuer-andere-provider-zugaenglich-machen/ and https://www.home-network.org/projekte/easybox-904 provide good tutorials).
Network traffic works nicely.
Now does the 904LTE also support voice telephony via 2G or 3G (not via VoIP)? A quick trial suggests it doesn't, but maybe there's a trick to activate it?

Hello. What happened to your site with software?