Help setting up PPPoE connection

First I'm sorry if I wrote something wrong, I'm Brazilian and I don't speak English very well, I'm using Google Translate.

My router is the Archer C60 V2
I installed Openwrt 18.06.4

My connection is via PPPoE, but I can't connect to the internet, could anyone help me set up?
I do not know why but when I used the original firmware, to configure the network I had to put username and password and Mac Adress, only then I could connect to the internet. I don't know how to configure in Openwrt.

Go to the Webgui (LuCI) login and go to Network->Interface. Then add a new Interface on pressing the button. Then select the Protocol pppoe and add your credential. After saving and everything is correct you should push the connect button and then everything should work as expected.

Better edit the wan interface and change the protocol from DHCP, which is the default to PPPOE. Then add username, password, and MAC address.

2 Likes

I didn't find the option to add the MAC address.

If I add only the username and password gets error.

Try the following:

config device 'wan_dev'                                                         
        option name 'eth0'                                                      
        option macaddr 'xx.xx.xx.xx.xx.xx'

Change eth0 with the appropriate interface name that you use to connect the PPPoE.

Thanks so much for the help. I did it this way: in WAN, I changed DHCP for PPPoE, added the username and password.
In WAN6 / Advanced Settings / Override MAC address, I added the MAC address.
It worked for me.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.