Setting up PPPoE on Archer C50 V4

Hello guys,
I have installed the OpenWRT on my TP-Link Archer C50 v4 with Luci but I can't figured out how to set up the PPPoE.

Firmware Version: OpenWrt 19.07-SNAPSHOT r10269-5100629e32 / LuCI openwrt-19.07 branch (git-19.190.55584-ab90938)

On Network->Interfaces, I've editted the WAN, here at Protocol it's PPPoE, at PAP/CHAP username and password I've added the username & password from my internet provider.
After clicking on Save & Apply, on WAN I have "Error: Connection attempt failed"

I've tried this and at wan6->Advanced Settings Ovveride MTU I have an error "Expectig value smaller or equal with 9200"
If it helps, I'm using VMware with Ubuntu. I'm connected to the router with a wire, also with by Wi-Fi.

Do you have any suggestions?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

uci export network; uci export wireless; \
uci export dhcp; uci export firewall; 

Use ssh to connect to the device.

Uci export network;

package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxx:xxxx:xxx::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr 'xx:xx:xx:xx:xx:44'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'pppoe'
	option username 'my internet provider username'
	option password 'my internet provider password'
	option ipv6 'auto'
	option keepalive '0'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

uci export wireless;

package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option htmode 'HT20'
	option country 'RO'
	option legacy_rates '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option country 'RO'
	option legacy_rates '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option disabled '1'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'Licenta'
	option encryption 'psk2'
	option key 'xxxx'

config wifi-iface
	option ssid 'OpenWrt'
	option encryption 'none'
	option device 'radio1'
	option mode 'ap'
	option disabled '1'

config wifi-iface
	option ssid 'OpenWrt'
	option encryption 'none'
	option device 'radio1'
	option mode 'ap'
	option disabled '1'

config wifi-iface
	option device 'radio1'
	option mode 'ap'
	option ssid 'Licenta_5G'
	option encryption 'psk2'
	option key 'xxxxxx'

uci export dhcp

package dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

uci export firewall

package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

Under wan interface, advanced settings tab: LCP echo failure threshold 6 and LCP echo interval 10
Erase any value might be in MTU override. It should be grayed out 1492.
Change Obtain IPv6-Address to Manual, since you already have wan6 created.

I've changed and the error is still here.


There is the output from the previous commands

uci export network;

package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxx:xxxx:xxxx::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'pppoe'
	option username 'user from provider'
	option password 'pass from provider'
	option ipv6 '1'
	option keepalive '6 10'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

uci export wireless;

package wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option htmode 'HT20'
	option country 'RO'
	option legacy_rates '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option country 'RO'
	option legacy_rates '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option disabled '1'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'Licenta'
	option encryption 'psk2'
	option key 'xxxx'

config wifi-iface
	option ssid 'OpenWrt'
	option encryption 'none'
	option device 'radio1'
	option mode 'ap'
	option disabled '1'

config wifi-iface
	option ssid 'OpenWrt'
	option encryption 'none'
	option device 'radio1'
	option mode 'ap'
	option disabled '1'

config wifi-iface
	option device 'radio1'
	option mode 'ap'
	option ssid 'Licenta_5G'
	option encryption 'psk2'
	option key 'xxxxxx'

uci export dhcp

package dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

uci export firewall

package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

What does ip link show give?

This is the output:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
7: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
8: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
9: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
13: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
14: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff

Some (most?) ISPs require that the PPPoE connection is stablished using a certain VLAN. If you could connect to that ISP using another device, or the stock firmware, you could grab the configuration parameters from there.

I have another router (Netis WF2780).
Here are the configurations from WAN Settings:


I've tried to modify at WAN6->Advanced Settings->Override MAC address with my MAC Address (like in this and I still have the same error:

Also, I will post here the configurations from Luci, maybe I'm missing something:
Wan:

Wan6:

The 19.07 r10269 snapshot you have installed is very old. Have you considered upgrading to 19.07.2 stable release using LuCI?
19.07.2 for C50 v4 sysupgrade.bin

What is reported in the system log when it fails to connect?

Thanks for advice, I'm using 19.07.02 now.
There is the Syslog output:

Sun May 10 13:44:40 2020 daemon.notice netifd: Interface 'wan' is now down
Sun May 10 13:44:40 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun May 10 13:44:41 2020 daemon.err insmod: module is already loaded - slhc
Sun May 10 13:44:41 2020 daemon.err insmod: module is already loaded - ppp_generic
Sun May 10 13:44:41 2020 daemon.err insmod: module is already loaded - pppox
Sun May 10 13:44:41 2020 daemon.err insmod: module is already loaded - pppoe
Sun May 10 13:44:41 2020 daemon.info pppd[3035]: Plugin rp-pppoe.so loaded.
Sun May 10 13:44:41 2020 daemon.info pppd[3035]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sun May 10 13:44:41 2020 daemon.notice pppd[3035]: pppd 2.4.7 started by root, uid 0
Sun May 10 13:44:56 2020 daemon.warn pppd[3035]: Timeout waiting for PADO packets
Sun May 10 13:44:56 2020 daemon.err pppd[3035]: Unable to complete PPPoE Discovery
Sun May 10 13:44:56 2020 daemon.info pppd[3035]: Exit.
Sun May 10 13:44:56 2020 daemon.notice netifd: Interface 'wan' is now down
Sun May 10 13:44:56 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun May 10 13:44:56 2020 daemon.err insmod: module is already loaded - slhc
Sun May 10 13:44:56 2020 daemon.err insmod: module is already loaded - ppp_generic
Sun May 10 13:44:56 2020 daemon.err insmod: module is already loaded - pppox
Sun May 10 13:44:56 2020 daemon.err insmod: module is already loaded - pppoe
Sun May 10 13:44:56 2020 daemon.info pppd[3092]: Plugin rp-pppoe.so loaded.
Sun May 10 13:44:56 2020 daemon.info pppd[3092]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sun May 10 13:44:56 2020 daemon.notice pppd[3092]: pppd 2.4.7 started by root, uid 0
Sun May 10 13:45:11 2020 daemon.warn pppd[3092]: Timeout waiting for PADO packets
Sun May 10 13:45:11 2020 daemon.err pppd[3092]: Unable to complete PPPoE Discovery
Sun May 10 13:45:11 2020 daemon.info pppd[3092]: Exit.
Sun May 10 13:45:11 2020 daemon.notice netifd: Interface 'wan' is now down
Sun May 10 13:45:11 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun May 10 13:45:11 2020 daemon.err insmod: module is already loaded - slhc
Sun May 10 13:45:11 2020 daemon.err insmod: module is already loaded - ppp_generic
Sun May 10 13:45:11 2020 daemon.err insmod: module is already loaded - pppox
Sun May 10 13:45:11 2020 daemon.err insmod: module is already loaded - pppoe
Sun May 10 13:45:12 2020 daemon.info pppd[3151]: Plugin rp-pppoe.so loaded.
Sun May 10 13:45:12 2020 daemon.info pppd[3151]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sun May 10 13:45:12 2020 daemon.notice pppd[3151]: pppd 2.4.7 started by root, uid 0
Sun May 10 13:45:29 2020 daemon.notice netifd: Interface 'wan' is now down
Sun May 10 13:45:29 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun May 10 13:45:29 2020 daemon.err insmod: module is already loaded - slhc
Sun May 10 13:45:29 2020 daemon.err insmod: module is already loaded - ppp_generic
Sun May 10 13:45:29 2020 daemon.err insmod: module is already loaded - pppox
Sun May 10 13:45:29 2020 daemon.err insmod: module is already loaded - pppoe
Sun May 10 13:45:29 2020 daemon.info pppd[3237]: Plugin rp-pppoe.so loaded.
Sun May 10 13:45:29 2020 daemon.info pppd[3237]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Sun May 10 13:45:29 2020 daemon.notice pppd[3237]: pppd 2.4.7 started by root, uid 0

Did you verify the WAN port and PPPoE were both working on the C50 v4 work with original TPlink firmware prior to flashing with OpenWrt ?

I've added OpenWRT after unboxing, I didn't config the router with the original firmware.
Also I've made some research and I think I found out the problem. I have fiber internet and my ISP gave me a ZTE modem. Here I have 2 outputs(GE and FE). On the GE output I have a router with stock firmware and on the FE it's my OpenWRT router. I think it needs different configurations.

Are you running already PPPoE on the GE router?
If yes, does your ISP allow multiple PPP?

Further to @trendy question, have you removed your other router and tried the C50 in the GE port ?

I suspect you can only have one active router wired to your modem.

After your comments I've called the ISP.
Now it's working. Thank you guys.
There is the solution for my problem:
In my ZTE modem, it only works the GE port where I have my second router with the stock firmware.
In this router, I have connected my OpenWRT router.
Also, I have modified the IP from my stock firmware router with 192.168.2.1 and the OpenWRT has 192.168.1.1

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.