Configuring TPLink Archer C7 as Bell Canada Home Hub 3000 Replacement? [PPPoE]

Hi All

I am currently a Bell Canada FTTH customer (500 up / 500 down)
I have a Bell Home Hub 3000 modem/router that i wish to replace with OpenWRT on an Archer C7 v5

I'm using the 10Gtek media converter to connect the fiber sfp to the Archer C7

I may be trying too many things at once here, as i find the configuration options a bit confusing :slight_smile:

In order to setup the PPPoE connection, i followed these steps HERE
That alone didn't work for me.

Additionally, Bell's network specifically requires that the interface is tagged as VLAN 35, as detailed HERE

I therefore tried the settings listed HERE. (I wasnt able to figure out how to make these changes via ssh, so i just used mobaxterm's file browser to download a local copy of /etc/network/interfaces and made the changes, then uploaded it back and rebooted the router)

After that didn't work, i restored the network file, and tried going to Interfaces > VLANs > Create new > called it 35 and set each interface to "off" except for WAN, which was set to "tagged". That didn't do it either.

I feel like i'm just not navigating the UI / settings properly..
Can anyone offer some assistance?

I'm also somewhat confused as to where / how i turn this router into the "192.168.0.1" gateway i need it to be. I currently have it set to 192.168.0.8 while i try and configure it, but at some point it should be re-addressed right?

Thank you.

--------Goals--------

  • 192.168.0.1 - The aforementioned Archer C7 as the main Gateway / Router, which connects to Bell, with wireless enabled.
  • 192.168.0.2 - A second Archer C7 acting as a dumb Wireless AP.
  • 192.168.0.3 - A third Archer C7 acting as a dumb Wireless AP

I'm hoping to have my 3 Archers setup with final objective of smooth and fast wifi roaming through out my house. The AP's have seem to be working fine the past few days.. i'm just now getting stuck on the Bell Router replacement.

Thank you!

------EDIT--------
Here's what i did to finally get it working!

Network> Switch
Left Vlan 1 and 2 untouched
Created a new Vlan called 35
Have CPU (eth0) and WAN set as TAGGED. Have LAN 1 through LAN 4 as OFF.

Network > Interfaces > WAN6
Didn't touch it

Network > Interfaces > WAN > General Settings
Protocol: PPPoE
Enter username and password

Network > Interfaces > WAN > Physical Settings
Bridge Interfaces: enabled
Interface: Only have "SwitchVLAN: "eth0.35" (wan) selected

Network > Interfaces > LAN > General Settings
Protocl: Static Address
IPv4 address: 192.168.0.1
IPv4 netmask: 255.255.255.0
IPv4 gateway: LEFT IT BLANK

Network > Interfaces > LAN > Physical Settings
Bridge Interfaces: enabled
Interface: I have Switch VLAN "eth0.1" (lan), and both my 2.4Ghz and 5Ghz wireless options selected

While you should be able to get that working, the archer c7 is rather dated by now and very unlikely to reach NAT throughput of 500/500 MBit/s while also doing PPPoE (imho about half of that at best), you need (a lot!) more CPU performance for that.

Appreciate that. I definitely noticed it get stuck around 300/300 during a speed test. Did some reading and found that enabling Software flow offloading under Network > Firewall fixed that problem.

However, i am now noticing that mobile and "Chromecast with GoogleTV" kept disconnecting off the wifi every 15, 20 minutes or so. AP was maybe 10ft from me. I assumed it was doing some weird roaming thing, but maybe something else was going on? EDIT: ya the router I'm using for the pppoe gateway is just rebooting every 15-30 minutes!