umayer
February 12, 2023, 3:51pm
3447
I was able to recover the second device which broke when I did the attended sys-upgrade.
I haven't had changed anything on that one. @rincewind correctly spotted the root cause of my problem: kmod-mt7915-firmware
was missing
After opkg install kmod-mt7915-firmware
this device is back to normal operation.
Question remains: could a hick-up in attended sysupgrade cause packets to be dropped?
Because the older image I was running also required that package.
And e.g. kmod-mt7622-firmware
was still installed.
daniel
February 12, 2023, 4:28pm
3448
This is not a hick-up of attended sysupgrade, but rather a change in OpenWrt's development tree: previously all firmware needed was shipped in the kmod-mt7915e
package. Only recently the firmware has been split-off into a package of its own (kmod-mt7915-firmware
). Obviously asu can't know about that (there is a mechanism to configure package replacements and such, but in it is not expressive enough to cover this situation, unfortunately)
umayer
February 12, 2023, 6:52pm
3449
I have had the situation of mobile devices loosing connectivity again, similar to what @Brain2000 described:
Four people visited, i.e. slightly more mobile devices than usual.
router: 192.168.1.1
AP apw: 192.168.1.3
AP apa: 192.168.1.5
AP aps: 192.168.1.7
Laptop: 192.168.1.174 wired to apa
desktop: 192.168.1.35 wired to apa
printer: 192.168.1.20
mobile: 192.168.1.108 wifi to apa
works:
ping from mobile to all destinations but router
ping from apa and machines wired to apa to mobile
no connection:
ping from router to mobile:
ping from mobile to router
in between:
ping from aps/apw to mobile
root@aps:~# ping 192.168.1.108
PING 192.168.1.108 (192.168.1.108): 56 data bytes
64 bytes from 192.168.1.108: seq=0 ttl=64 time=539.550 ms
64 bytes from 192.168.1.108: seq=1 ttl=64 time=344.466 ms
^C
--- 192.168.1.108 ping statistics ---
28 packets transmitted, 2 packets received, 92% packet loss
round-trip min/avg/max = 344.466/442.008/539.550 ms
Note that the first two pings worked, but then it fails to continue and 28 lost packages follow.
executing
wifi
on apa brings back full connectivity on mobile
config files on APA:
/etc/config/network:
cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'wan'
config interface 'lan'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.1.5'
option gateway '192.168.1.1'
option device 'br-lan.100'
list dns '192.168.1.1'
option delegate '0'
option ip6ifaceid '::5'
list ip6class 'local'
list ip6addr 'fd00:0:0:1::5'
option ip6gw 'fd00:0:0:1::1'
config device
option type '8021q'
option ifname 'br-lan'
option vid '100'
option name 'br-lan.100'
config device
option type '8021q'
option ifname 'br-lan'
option vid '107'
option name 'br-lan.107'
config device
option type '8021q'
option ifname 'br-lan'
option vid '200'
option name 'br-lan.200'
config bridge-vlan
option device 'br-lan'
option vlan '100'
list ports 'lan1:u*'
list ports 'lan2:u*'
list ports 'lan3:u*'
list ports 'lan4:u*'
list ports 'wan:t'
config bridge-vlan
option device 'br-lan'
option vlan '107'
list ports 'wan:t'
config bridge-vlan
option device 'br-lan'
option vlan '200'
list ports 'wan:t'
config interface 'guest'
option proto 'none'
option device 'br-lan.200'
config interface 'IoT'
option proto 'none'
option device 'br-lan.107'
/etc/config/wireless:
cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/18000000.wmac'
option band '2g'
option htmode 'HT20'
option channel '11'
option country 'DE'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'xxxxx'
option encryption 'psk2+ccmp'
option key 'xxxxx'
option ieee80211k '1'
option ieee80211r '1'
option reassociation_deadline '20000'
option ft_over_ds '0'
option ft_psk_generate_local '1'
option bss_transition '1'
option wnm_sleep_mode '1'
option time_advertisement '2'
option time_zone 'GMT0'
option rrm_neighbor_report '1'
option rrm_beacon_report '1'
config wifi-device 'radio1'
option type 'mac80211'
option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option channel '36'
option band '5g'
option country 'DE'
option cell_density '0'
option he_su_beamformee '1'
option he_bss_color '5'
option htmode 'VHT80'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'xxxxx'
option encryption 'psk2+ccmp'
option key 'xxxxx'
option ieee80211k '1'
option ieee80211r '1'
option reassociation_deadline '20000'
option ft_over_ds '0'
option ft_psk_generate_local '1'
option bss_transition '1'
option wnm_sleep_mode '1'
option time_advertisement '2'
option time_zone 'GMT0'
option rrm_neighbor_report '1'
option rrm_beacon_report '1'
config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'ap'
option ssid 'xxxxx-Gast'
option network 'guest'
option encryption 'none'
option isolate '1'
config wifi-iface 'wifinet3'
option device 'radio0'
option mode 'ap'
option ssid 'xxxxx-IoT'
option encryption 'psk2'
option network 'IoT'
option key 'xxxxx'
/etc/config/bridger:
config defaults
# example for blacklisting individual devices or bridges
list blacklist eth0
For anyone following my travails with the 2.4Ghz radio not working on a Belkin RT3200, I found the solution and updated the most relevant post in this thread with everything .
Should there perhaps be advice against , or a more in-your-face warning about, the schedutil
CPU scaling governor setting on MT7622 devices, how it's considered "out-of-spec" and may not work? Maybe it works for some lucky souls, but not in my case.
I spent an embarrassing amount of time and effort debugging this when it was my fault for putting the schedutil
CPU scaling governor setting in from the very beginning, assuming it was well-vetted and safe, since it's even suggested in the official device wiki .
2 Likes
Anteus
February 12, 2023, 8:54pm
3451
Snapshot runs ondemand as default for a while . I've updated the wiki example to ondemand.
3 Likes
umayer
February 13, 2023, 8:26am
3452
On 01/09 @Anteus wrote
For master snapshots newer than 9a07895
If you upgrade with auc you need to manually install these packages and reboot to enable wifi after upgrade so make sure to have some form of wired access (or hotspot and vpn to the router or home network).
kmod-mt7915-firmware
kmod-mt7915e
kmod-mt7622-firmware
As pointed out you can also add the packages manually before by going to advanced update options through luci.
git #9a07895 is long before 895f38ca1efeb46f0cd3029c732e6156d4589eb0, which is the one I tried to upgrade from.
I do actually recall that I did not need to install kmod-mt7915e
but only the two FW packages.
That is why I mentioned that the FW for 7622 was still installed.
I did open an asu issue before the issue seems to have resolved and I initiated my then failing upgrade:
opened 09:04AM - 05 Feb 23 UTC
closed 08:16AM - 13 Feb 23 UTC
Error building the firmware image
```
Server response: Unsupported package(s… ): bridger
[Please report the error message and request](https://github.com/openwrt/asu/issues)
Request Data:
{
"url": "https://sysupgrade.openwrt.org",
"revision": "r21757-895f38ca1e",
"advanced_mode": "0",
"branch": "SNAPSHOT",
"efi": null,
"profile": "linksys,e8450-ubi",
"target": "mediatek/mt7622",
"version": "SNAPSHOT",
"packages": [
"auc",
"avahi-daemon-service-http",
"avahi-nodbus-daemon",
"base-files",
"bridger",
"busybox",
"ca-bundle",
"ca-certificates",
"diffutils",
"dnsmasq",
"dropbear",
"firewall4",
"fstools",
"irqbalance",
"kernel",
"kmod-gpio-button-hotplug",
"kmod-leds-gpio",
"kmod-mt7615-firmware",
"kmod-mt7615e",
"kmod-mt7622-firmware",
"kmod-mt7915-firmware",
"kmod-mt7915e",
"kmod-nft-offload",
"kmod-usb3",
"less",
"libc",
"libustream-openssl",
"logd",
"luci",
"luci-app-attendedsysupgrade",
"luci-app-dawn",
"luci-app-uhttpd",
"luci-lib-px5g",
"mtd",
"netifd",
"nftables-json",
"ntpclient",
"odhcp6c",
"odhcpd-ipv6only",
"openssl-util",
"opkg",
"ppp",
"ppp-mod-pppoe",
"procd",
"procd-seccomp",
"procd-ujail",
"px5g-standalone",
"uboot-envtools",
"uci",
"uclient-fetch",
"urandom-seed",
"urngd",
"vim-full",
"wpad-openssl"
],
"diff_packages": true,
"filesystem": "squashfs",
"client": "luci/git-22.285.67526-18bfcca"
}
```
Don't get me wrong. I really appreciate asu. before that I compiled my own images, because otherwise it was not possible to keep the configuration.
I'm a little concerned that there might be a race condition which on rare occasions causes packets to not be (properly?) included.
I still have the itb file in question. Is there a way to inspect it?
umayer
February 13, 2023, 8:29am
3453
just for completeness:
wifi
only brought the mobile up for a short period.
/etc/init.d/bridger restart
had the same effect.
But only a reboot on apa fixed it for good.
When I use ondemand
the same thing happens to me only in one of the two routers that I have and I solved it by changing the minimum frequency to 600000 kHz up from the default 437500 kHz.
~# cat /sys/devices/system/cpu/cpufreq/policy0/scaling_available_frequencies
437500 600000 812500 1025000 1137500 1262500 1350000
Testing:
437500 kHz = Using the default minimum frequency does not boot after reboot.
600000 kHz = Boot without problems after reboot.
Fix:
echo 600000 > /sys/devices/system/cpu/cpufreq/policy0/scaling_min_freq
echo ondemand > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor
This is why this problem happens and why it is solved by changing the minimum frequency:
Minimum frequency to 437500 kHz = 1.0V .
Minimum frequency to 600000 kHz = 1.05V .
6 Likes
rpugsley
February 15, 2023, 12:01am
3455
I created a snapshot from yesterday master branch and 160mhz is gone from luci. I only have 80mhz. Anybody expericed the same? The country is set to CA.
Just found this : Belkin RT3200/Linksys E8450 WiFi AX discussion - #3381 by namidairo
Thansk! So the command shouldn't be needed after 23.xx release?
Cheers.
1 Like
There is a discussion on Github about the removal of 160Mhz on the RT3200 .
Another, newer Github comment here .
It was removed (in development/snapshot), on purpose, but some are saying it was not necessary to remove.
I asked ChatGPT a question that I had after reading this comment on Github .
Is this accurate?? When are we going to test & try this on the RT3200?
(transcription of image text: "Yes, the MediaTek MT7915E chipset used in the Belkin RT3200 router supports the 6GHz frequency band, which includes the new Wi-Fi 6E standard.")
loopy321
February 16, 2023, 11:13pm
3459
1 Like
This must be why it's labeled/marketed as "dual band" (2.4GHz & 5GHz) and not "tri-band" (adding 6GHz)?
Anyone care to help me troubleshoot why I'm crashing on 22.03.3?
BusyBox v1.35.0 (2022-10-07 23:34:56 UTC) built-in shell (ash)
_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
-----------------------------------------------------
OpenWrt 22.03.1, r19777-2853b6d652
-----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# cat /sys/fs/pstore/*
Oops#1 Part1
<6>[ 8.283886] input device check on
<6>[ 8.287555] Actions configured
<6>[ 8.299107] Loading modules backported from Linux version v5.15.81-0-ge4a7232c917c
<6>[ 8.306721] Backport generated by backports.git v5.15.81-1-0-ge1867d55
<6>[ 8.333981] xt_time: kernel timezone is -0000
<7>[ 8.401759] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
<7>[ 8.413123] mt7915e 0000:01:00.0: assign IRQ: got 150
<7>[ 8.418300] pci 0000:00:00.0: enabling bus mastering
<6>[ 8.423293] mt7915e 0000:01:00.0: enabling device (0000 -> 0002)
<7>[ 8.429397] mt7915e 0000:01:00.0: enabling bus mastering
<6>[ 8.476395] mt7622-wmac 18000000.wmac: HW/SW Version: 0x8a108a10, Build Time: 20190801210006a
<6>[ 8.476395]
<6>[ 8.579115] mt7622-wmac 18000000.wmac: N9 Firmware Version: _reserved_, Build Time: 20220630094834
<6>[ 8.620259] mt7915e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20211222184017a
<6>[ 8.620259]
<6>[ 8.748625] mt7915e 0000:01:00.0: WM Firmware Version: ____000000, Build Time: 20211222184052
<6>[ 8.807644] mt7915e 0000:01:00.0: WA Firmware Version: DEV_000000, Build Time: 20211222184111
<6>[ 8.957229] PPP generic driver version 2.4.2
<6>[ 8.963609] NET: Registered protocol family 24
<14>[ 8.974019] kmodloader: done loading kernel modules from /etc/modules.d/*
<6>[ 11.444204] mtk_soc_eth 1b100000.ethernet eth0: Link is Down
<6>[ 11.453911] mtk_soc_eth 1b100000.ethernet eth0: configuring for fixed/2500base-x link mode
<6>[ 11.462881] mtk_soc_eth 1b100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
<6>[ 11.471588] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
<6>[ 11.478830] mt7530 mdio-bus:00 lan1: configuring for phy/gmii link mode
<6>[ 11.486794] 8021q: adding VLAN 0 to HW filter on device lan1
<6>[ 11.498812] br-lan: port 1(lan1) entered blocking state
<6>[ 11.504068] br-lan: port 1(lan1) entered disabled state
<6>[ 11.511070] device lan1 entered promiscuous mode
<6>[ 11.515813] device eth0 entered promiscuous mode
<6>[ 11.531079] mt7530 mdio-bus:00 lan2: configuring for phy/gmii link mode
<6>[ 11.538390] 8021q: adding VLAN 0 to HW filter on device lan2
<6>[ 11.556284] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control off
<6>[ 11.556584] br-lan: port 2(lan2) entered blocking state
<6>[ 11.568845] br-lan: port 2(lan2) entered disabled state
<6>[ 11.577396] device lan2 entered promiscuous mode
<6>[ 11.585504] br-lan: port 2(lan2) entered blocking state
<6>[ 11.590757] br-lan: port 2(lan2) entered forwarding state
<6>[ 11.598150] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
<6>[ 11.611162] mt7530 mdio-bus:00 lan3: configuring for phy/gmii link mode
<6>[ 11.620857] 8021q: adding VLAN 0 to HW filter on device lan3
<6>[ 11.625170] mt7530 mdio-bus:00 lan3: Link is Up - 100Mbps/Full - flow control rx/tx
<6>[ 11.631561] br-lan: port 3(lan3) entered blocking state
<6>[ 11.639435] br-lan: port 3(lan3) entered disabled state
<6>[ 11.651581] device lan3 entered promiscuous mode
<6>[ 11.659555] br-lan: port 3(lan3) entered blocking state
<6>[ 11.664829] br-lan: port 3(lan3) entered forwarding state
<6>[ 11.677674] mt7530 mdio-bus:00 lan4: configuring for phy/gmii link mode
<6>[ 11.684875] 8021q: adding VLAN 0 to HW filter on device lan4
<6>[ 11.689288] mt7530 mdio-bus:00 lan4: Link is Up - 100Mbps/Full - flow control rx/tx
<6>[ 11.693124] br-lan: port 4(lan4) entered blocking state
<6>[ 11.703430] br-lan: port 4(lan4) entered disabled state
<6>[ 11.709981] device lan4 entered promiscuous mode
<6>[ 11.717997] br-lan: port 4(lan4) entered blocking state
<6>[ 11.723229] br-lan: port 4(lan4) entered forwarding state
<6>[ 11.737616] mt7530 mdio-bus:00 wan: configuring for phy/gmii link mode
<6>[ 11.744701] 8021q: adding VLAN 0 to HW filter on device wan
<6>[ 11.749072] mt7530 mdio-bus:00 wan: Link is Up - 1Gbps/Full - flow control off
<6>[ 11.757592] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
<6>[ 14.090634] mt7530 mdio-bus:00 lan1: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[ 14.178544] br-lan: port 1(lan1) entered blocking state
<6>[ 14.183803] br-lan: port 1(lan1) entered forwarding state
<6>[ 14.555105] br-lan: port 5(wlan0) entered blocking state
<6>[ 14.560425] br-lan: port 5(wlan0) entered disabled state
<6>[ 14.566024] device wlan0 entered promiscuous mode
<6>[ 14.570904] br-lan: port 5(wlan0) entered blocking state
<6>[ 14.576261] br-lan: port 5(wlan0) entered forwarding state
<6>[ 14.726971] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[ 15.264046] br-lan: port 6(wlan1) entered blocking state
<6>[ 15.269478] br-lan: port 6(wlan1) entered disabled state
<6>[ 15.275076] device wlan1 entered promiscuous mode
<6>[ 15.279955] br-lan: port 6(wlan1) entered blocking state
<6>[ 15.285336] br-lan: port 6(wlan1) entered forwarding state
<6>[ 15.291866] br-lan: port 6(wlan1) entered disabled state
<6>[ 16.082877] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
<6>[ 16.089451] br-lan: port 6(wlan1) entered blocking state
<6>[ 16.094782] br-lan: port 6(wlan1) entered forwarding state
<1>[ 2372.271514] Unable to handle kernel paging request at virtual address ffffff8003000000
<1>[ 2372.279480] Mem abort info:
<1>[ 2372.282269] ESR = 0x96000147
<1>[ 2372.285320] EC = 0x25: DABT (current EL), IL = 32 bits
<1>[ 2372.290662] SET = 0, FnV = 0
<1>[ 2372.293718] EA = 0, S1PTW = 0
<1>[ 2372.296859] Data abort info:
<1>[ 2372.299752] ISV = 0, ISS = 0x00000147
<1>[ 2372.303594] CM = 1, WnR = 1
<1>[ 2372.306563] swapper pgtable: 4k pages, 39-bit VAs, pgdp=000000004497e000
<1>[ 2372.313306] [ffffff8003000000] pgd=000000005fffc003, p4d=000000005fffc003, pud=000000005fffc003, pmd=000000005ffe3003, pte=0000000000000000
<0>[ 2372.326056] Internal error: Oops: 96000147 [#1] SMP
<7>[ 2372.331015] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 iptable_mangle iptable_filter ipt_REJECT ipt_ECN ip_tables cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS xt_LOG xt_HL xt_DSCP xt_CLASSIFY x_tables slhc sch_cake nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_ipv6 nf_log_ipv4 nf_log_common nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c hwmon crc_ccitt compat sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_tcindex cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred
<7>[ 2372.331373] act_gact ifb seqiv leds_gpio xhci_plat_hcd gpio_button_hotplug
<7>[ 2372.425436] CPU: 0 PID: 1168 Comm: mt76-tx phy0 Tainted: G S 5.10.161 #0
<7>[ 2372.433434] Hardware name: Linksys E8450 (UBI) (DT)
<7>[ 2372.438312] pstate: 80000005 (Nzcv daif -PAN -UAO -TCO BTYPE=--)
<7>[ 2372.444316] pc : 0xffffffc0100170f8
<7>[ 2372.447800] lr : 0xffffffc0100161fc
<7>[ 2372.451283] sp : ffffffc010d439d0
<7>[ 2372.454593] x29: ffffffc010d439d0 x28: ffffffc010d43ae0
<7>[ 2372.459906] x27: ffffff8001b68148 x26: 0000000000000002
<7>[ 2372.465220] x25: ffffff8005647100 x24: ffffff8003ee394c
<7>[ 2372.470533] x23: 0000000005647d80 x22: ffffff8000349410
<7>[ 2372.475847] x21: ffffff800215ed30 x20: 0000000005647d80
<7>[ 2372.481160] x19: ffffff8000349410 x18: ffffff80028b8000
<7>[ 2372.486473] x17: 00000000ffffffff x16: 0000000000000001
<7>[ 2372.491787] x15: ffffff8001bf91a4 x14: 0000000000000028
<7>[ 2372.497101] x13: 0000000000000590 x12: 0000000000000000
<7>[ 2372.502414] x11: ffffff800215ed30 x10: 0000000000000001
<7>[ 2372.507727] x9 : 0000000000000000 x8 : ffffffc010d43cf0
<7>[ 2372.513039] x7 : 000000004215ed30 x6 : 0000000000000000
<7>[ 2372.518352] x5 : 0000000000000000 x4 : 0000000000000002
<7>[ 2372.523665] x3 : 000000000000003f x2 : 0000000000000040
<7>[ 2372.528978] x1 : ffffff80077a6ab0 x0 : ffffff8003000000
<7>[ 2372.534290] Call trace:
<7>[ 2372.536734] 0xffffffc0100170f8
<7>[ 2372.539870] 0xffffffc0100948e0
<7>[ 2372.543020] 0xffffffc008a35088 [mt76@000000005914d1c8+0xe000]
<7>[ 2372.548854] 0xffffffc008a38fcc [mt76@000000005914d1c8+0xe000]
<7>[ 2372.554687] 0xffffffc008a39c70 [mt76@000000005914d1c8+0xe000]
<7>[ 2372.560519] 0xffffffc008a39f74 [mt76@000000005914d1c8+0xe000]
<7>[ 2372.566352] 0xffffffc008a4edb0 [mt7615_common@0000000032738e2a+0x12000]
<7>[ 2372.573051] 0xffffffc008a3362c [mt76@000000005914d1c8+0xe000]
<7>[ 2372.578879] 0xffffffc01004c5e0
<7>[ 2372.582015] 0xffffffc010005f68
<0>[ 2372.585160] Code: 9ac32042 8b010001 d1000443 8a230000 (d50b7a20)
<4>[ 2372.591250] ---[ end trace aa0c89fbdbc05358 ]---
Panic#2 Part1
<7>[ 8.401759] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
<7>[ 8.413123] mt7915e 0000:01:00.0: assign IRQ: got 150
<7>[ 8.418300] pci 0000:00:00.0: enabling bus mastering
<6>[ 8.423293] mt7915e 0000:01:00.0: enabling device (0000 -> 0002)
<7>[ 8.429397] mt7915e 0000:01:00.0: enabling bus mastering
<6>[ 8.476395] mt7622-wmac 18000000.wmac: HW/SW Version: 0x8a108a10, Build Time: 20190801210006a
<6>[ 8.476395]
<6>[ 8.579115] mt7622-wmac 18000000.wmac: N9 Firmware Version: _reserved_, Build Time: 20220630094834
<6>[ 8.620259] mt7915e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20211222184017a
<6>[ 8.620259]
<6>[ 8.748625] mt7915e 0000:01:00.0: WM Firmware Version: ____000000, Build Time: 20211222184052
<6>[ 8.807644] mt7915e 0000:01:00.0: WA Firmware Version: DEV_000000, Build Time: 20211222184111
<6>[ 8.957229] PPP generic driver version 2.4.2
<6>[ 8.963609] NET: Registered protocol family 24
<14>[ 8.974019] kmodloader: done loading kernel modules from /etc/modules.d/*
<6>[ 11.444204] mtk_soc_eth 1b100000.ethernet eth0: Link is Down
<6>[ 11.453911] mtk_soc_eth 1b100000.ethernet eth0: configuring for fixed/2500base-x link mode
<6>[ 11.462881] mtk_soc_eth 1b100000.ethernet eth0: Link is Up - 2.5Gbps/Full - flow control rx/tx
<6>[ 11.471588] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
<6>[ 11.478830] mt7530 mdio-bus:00 lan1: configuring for phy/gmii link mode
<6>[ 11.486794] 8021q: adding VLAN 0 to HW filter on device lan1
<6>[ 11.498812] br-lan: port 1(lan1) entered blocking state
<6>[ 11.504068] br-lan: port 1(lan1) entered disabled state
<6>[ 11.511070] device lan1 entered promiscuous mode
<6>[ 11.515813] device eth0 entered promiscuous mode
<6>[ 11.531079] mt7530 mdio-bus:00 lan2: configuring for phy/gmii link mode
<6>[ 11.538390] 8021q: adding VLAN 0 to HW filter on device lan2
<6>[ 11.556284] mt7530 mdio-bus:00 lan2: Link is Up - 1Gbps/Full - flow control off
<6>[ 11.556584] br-lan: port 2(lan2) entered blocking state
<6>[ 11.568845] br-lan: port 2(lan2) entered disabled state
<6>[ 11.577396] device lan2 entered promiscuous mode
<6>[ 11.585504] br-lan: port 2(lan2) entered blocking state
<6>[ 11.590757] br-lan: port 2(lan2) entered forwarding state
<6>[ 11.598150] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
<6>[ 11.611162] mt7530 mdio-bus:00 lan3: configuring for phy/gmii link mode
<6>[ 11.620857] 8021q: adding VLAN 0 to HW filter on device lan3
<6>[ 11.625170] mt7530 mdio-bus:00 lan3: Link is Up - 100Mbps/Full - flow control rx/tx
<6>[ 11.631561] br-lan: port 3(lan3) entered blocking state
<6>[ 11.639435] br-lan: port 3(lan3) entered disabled state
<6>[ 11.651581] device lan3 entered promiscuous mode
<6>[ 11.659555] br-lan: port 3(lan3) entered blocking state
<6>[ 11.664829] br-lan: port 3(lan3) entered forwarding state
<6>[ 11.677674] mt7530 mdio-bus:00 lan4: configuring for phy/gmii link mode
<6>[ 11.684875] 8021q: adding VLAN 0 to HW filter on device lan4
<6>[ 11.689288] mt7530 mdio-bus:00 lan4: Link is Up - 100Mbps/Full - flow control rx/tx
<6>[ 11.693124] br-lan: port 4(lan4) entered blocking state
<6>[ 11.703430] br-lan: port 4(lan4) entered disabled state
<6>[ 11.709981] device lan4 entered promiscuous mode
<6>[ 11.717997] br-lan: port 4(lan4) entered blocking state
<6>[ 11.723229] br-lan: port 4(lan4) entered forwarding state
<6>[ 11.737616] mt7530 mdio-bus:00 wan: configuring for phy/gmii link mode
<6>[ 11.744701] 8021q: adding VLAN 0 to HW filter on device wan
<6>[ 11.749072] mt7530 mdio-bus:00 wan: Link is Up - 1Gbps/Full - flow control off
<6>[ 11.757592] IPv6: ADDRCONF(NETDEV_CHANGE): wan: link becomes ready
<6>[ 14.090634] mt7530 mdio-bus:00 lan1: Link is Up - 1Gbps/Full - flow control rx/tx
<6>[ 14.178544] br-lan: port 1(lan1) entered blocking state
<6>[ 14.183803] br-lan: port 1(lan1) entered forwarding state
<6>[ 14.555105] br-lan: port 5(wlan0) entered blocking state
<6>[ 14.560425] br-lan: port 5(wlan0) entered disabled state
<6>[ 14.566024] device wlan0 entered promiscuous mode
<6>[ 14.570904] br-lan: port 5(wlan0) entered blocking state
<6>[ 14.576261] br-lan: port 5(wlan0) entered forwarding state
<6>[ 14.726971] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
<6>[ 15.264046] br-lan: port 6(wlan1) entered blocking state
<6>[ 15.269478] br-lan: port 6(wlan1) entered disabled state
<6>[ 15.275076] device wlan1 entered promiscuous mode
<6>[ 15.279955] br-lan: port 6(wlan1) entered blocking state
<6>[ 15.285336] br-lan: port 6(wlan1) entered forwarding state
<6>[ 15.291866] br-lan: port 6(wlan1) entered disabled state
<6>[ 16.082877] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
<6>[ 16.089451] br-lan: port 6(wlan1) entered blocking state
<6>[ 16.094782] br-lan: port 6(wlan1) entered forwarding state
<1>[ 2372.271514] Unable to handle kernel paging request at virtual address ffffff8003000000
<1>[ 2372.279480] Mem abort info:
<1>[ 2372.282269] ESR = 0x96000147
<1>[ 2372.285320] EC = 0x25: DABT (current EL), IL = 32 bits
<1>[ 2372.290662] SET = 0, FnV = 0
<1>[ 2372.293718] EA = 0, S1PTW = 0
<1>[ 2372.296859] Data abort info:
<1>[ 2372.299752] ISV = 0, ISS = 0x00000147
<1>[ 2372.303594] CM = 1, WnR = 1
<1>[ 2372.306563] swapper pgtable: 4k pages, 39-bit VAs, pgdp=000000004497e000
<1>[ 2372.313306] [ffffff8003000000] pgd=000000005fffc003, p4d=000000005fffc003, pud=000000005fffc003, pmd=000000005ffe3003, pte=0000000000000000
<0>[ 2372.326056] Internal error: Oops: 96000147 [#1] SMP
<7>[ 2372.331015] Modules linked in: pppoe ppp_async nft_fib_inet nf_flow_table_ipv6 nf_flow_table_ipv4 nf_flow_table_inet pppox ppp_generic nft_reject_ipv6 nft_reject_ipv4 nft_reject_inet nft_reject nft_redir nft_quota nft_objref nft_numgen nft_nat nft_masq nft_log nft_limit nft_hash nft_flow_offload nft_fib_ipv6 nft_fib_ipv4 nft_fib nft_ct nft_counter nft_chain_nat nf_tables nf_nat nf_flow_table nf_conntrack mt7915e mt7615e mt7615_common mt76_connac_lib mt76 mac80211 iptable_mangle iptable_filter ipt_REJECT ipt_ECN ip_tables cfg80211 xt_time xt_tcpudp xt_tcpmss xt_statistic xt_multiport xt_mark xt_mac xt_limit xt_length xt_hl xt_ecn xt_dscp xt_comment xt_TCPMSS xt_LOG xt_HL xt_DSCP xt_CLASSIFY x_tables slhc sch_cake nfnetlink nf_reject_ipv6 nf_reject_ipv4 nf_log_ipv6 nf_log_ipv4 nf_log_common nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c hwmon crc_ccitt compat sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_tcindex cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred
<7>[ 2372.331373] act_gact ifb seqiv leds_gpio xhci_plat_hcd gpio_button_hotplug
<7>[ 2372.425436] CPU: 0 PID: 1168 Comm: mt76-tx phy0 Tainted: G S 5.10.161 #0
<7>[ 2372.433434] Hardware name: Linksys E8450 (UBI) (DT)
<7>[ 2372.438312] pstate: 80000005 (Nzcv daif -PAN -UAO -TCO BTYPE=--)
<7>[ 2372.444316] pc : 0xffffffc0100170f8
<7>[ 2372.447800] lr : 0xffffffc0100161fc
<7>[ 2372.451283] sp : ffffffc010d439d0
<7>[ 2372.454593] x29: ffffffc010d439d0 x28: ffffffc010d43ae0
<7>[ 2372.459906] x27: ffffff8001b68148 x26: 0000000000000002
<7>[ 2372.465220] x25: ffffff8005647100 x24: ffffff8003ee394c
<7>[ 2372.470533] x23: 0000000005647d80 x22: ffffff8000349410
<7>[ 2372.475847] x21: ffffff800215ed30 x20: 0000000005647d80
<7>[ 2372.481160] x19: ffffff8000349410 x18: ffffff80028b8000
<7>[ 2372.486473] x17: 00000000ffffffff x16: 0000000000000001
<7>[ 2372.491787] x15: ffffff8001bf91a4 x14: 0000000000000028
<7>[ 2372.497101] x13: 0000000000000590 x12: 0000000000000000
<7>[ 2372.502414] x11: ffffff800215ed30 x10: 0000000000000001
<7>[ 2372.507727] x9 : 0000000000000000 x8 : ffffffc010d43cf0
<7>[ 2372.513039] x7 : 000000004215ed30 x6 : 0000000000000000
<7>[ 2372.518352] x5 : 0000000000000000 x4 : 0000000000000002
<7>[ 2372.523665] x3 : 000000000000003f x2 : 0000000000000040
<7>[ 2372.528978] x1 : ffffff80077a6ab0 x0 : ffffff8003000000
<7>[ 2372.534290] Call trace:
<7>[ 2372.536734] 0xffffffc0100170f8
<7>[ 2372.539870] 0xffffffc0100948e0
<7>[ 2372.543020] 0xffffffc008a35088 [mt76@000000005914d1c8+0xe000]
<7>[ 2372.548854] 0xffffffc008a38fcc [mt76@000000005914d1c8+0xe000]
<7>[ 2372.554687] 0xffffffc008a39c70 [mt76@000000005914d1c8+0xe000]
<7>[ 2372.560519] 0xffffffc008a39f74 [mt76@000000005914d1c8+0xe000]
<7>[ 2372.566352] 0xffffffc008a4edb0 [mt7615_common@0000000032738e2a+0x12000]
<7>[ 2372.573051] 0xffffffc008a3362c [mt76@000000005914d1c8+0xe000]
<7>[ 2372.578879] 0xffffffc01004c5e0
<7>[ 2372.582015] 0xffffffc010005f68
<0>[ 2372.585160] Code: 9ac32042 8b010001 d1000443 8a230000 (d50b7a20)
<4>[ 2372.591250] ---[ end trace aa0c89fbdbc05358 ]---
<0>[ 2372.610045] Kernel panic - not syncing: Oops: Fatal exception in interrupt
<2>[ 2372.616922] SMP: stopping secondary CPUs
<0>[ 2372.620846] Kernel Offset: disabled
<0>[ 2372.624332] CPU features: 0x00000002,04002004
<0>[ 2372.628683] Memory Limit: none
eginnc
February 22, 2023, 7:14pm
3463
campbelltech:
on 22.03.3?
Maybe try flashing 22.03.3? There may still be value in diagnosing the issue, but if it's fixed in 22.03.3, less so.
I believe what you're looking at is the version of initramfs recovery (22.03.1). The router (22.03.3) had just crashed so I connected to recovery with ssh to pull the logs. I've tried 22.03.3 and the latest snapshot but I have crashes with both.
eginnc
February 22, 2023, 11:16pm
3465
That's unfortunate. So much for the simple fix. Sorry I can't help further.
No worries. Hopefully someone will come along.