Belkin RT3200/Linksys E8450 WiFi AX discussion

Signal range on PS4 is good (+80%) and I don’t have other router/signal interfering nearby

Hello, I would like to run zigbee2MQTT in my belkin rt3200 router.

Is anybody running it or a similar package?

Do you think it would have enough power?

It uses nodejs, it needs node, node-npm and git and git-http packages.

I have tried to install cloning the repository anfter installing the node and javascript environment.

But it get short of disk space. I am thinking of adding an usb pen and mount it in a directory and try to install all these in that directory. Would it work?

The load won't be too much, not so many zigbee devices and only would send messages from time to time (TRV valves, may be some thermometer,...)

1 Like

I've got zigbee2mqtt running in an lxc container on an x86_64 openwrt box. I just took a quick look at the size of my zigbee2mqtt directory, and with all the npm packages installed its taking up 187MB. It looks like its taking about 160MB of RAM with 2 zigbee devices currently. I use my rt3200s as dumb APs, so I have gobs of RAM sitting around... if you solve the storage, I suppose its should be possible (although, memory on different platforms is a bit of an apples to oranges comparison.)

For storage I'd look for something meant to take lots of reads/writes like a usb SSD instead of a usb flash drive. I've gotten bitten by a flash drive going bad with lots of writes (back in the day I kept my dhcp leases and logs on a flash stick.)

The only thing you'd need to overcome is there's only one USB connector, so you'd need a hub to get both your drive and your zigbee coodinator hooked up.

1 Like

Thank you.

In the thread about installing z2M in openWRT I was told that after compilation wht package would use only 6MB or less of disk space. But you need all that disk in order to do the compilation.

An idea would be to use the usb to do the compiation and after that, copy it to other place.

BUt I am not sure of being able to do all that, nor know exactly where puts node the compiled files...

it sound quiten complicated.
Good point your advice about usb SSD.

Does z2M make so much writes after it has been installed and is running?

No problem having just one usb and no need of a hub, the zigbee radio (coordinator) is an athom ZG01 with ethernet and wifi connection and TCP serial service that can be accessed by z2M as if were a serial port and control the radio remotely.

I haven't been tracking it, but there is a state file that seems to be updated when your devices report in. It looks like there's a quite active log directory as well. At least for me its active, one of my devices is an Aqara FP1 presence sensor in my home office so as I move in and out of the room through th day I'm causing changes.

Neat! I really like athom's stuff and I somehow missed that.

1 Like

160 might get disabled in the next mt76 bump anyway.

Lemme pull that up.

80+80 likely never worked, but I believe there are still retail devices shipping with 160mhz support advertised in their datasheets so... I'm not sure what's going on there.

3 Likes

Interesting, thanks for the info. Will try 80Mhz for a while and see if it's any more stable.

Please, can anyone help me? I'm literally going crazy

Does the PlayStation support 5 GHz? Could try that, in case your problem is due to interference on 2.4 GHz.

I tried but it gives the same problem :smiling_face_with_tear:

On 5 GHz try using 80 MHz wide or less, and select ac, not ax. If you are using 160 MHz width, that could be a problem. If you are using ax that could be a problem. My RT3200 5GHz is pretty stable at distance on 802.11ac 80 MHz width. You might also try staying off the DFS channels (so use 36 or 149 for 80MHz wide 802.11ac 5GHz).

2.4 GHz would not be my go to band for a stable low latency WiFi connection....

2 Likes

I would love to see those files! I am currently having a crash when using vlan filtering and I've been searching high and low to find out why.

1 Like

Ah dash - only hours before you posted I deleted them in WSL 2 in Windows 11. If you know a way to recover those deleted files, I will try that.

The way I was able to put the router into this crash was to set up a VLAN based on wan port with ID 2 wan.2 and then make wan.2 a member of br-lan. And then enable bridge filtering in LuCi and set VLAN ID to 2 and set all then lan ports to untagged and wan.2 to tagged, and not set any primary VLAN ID. Like this, but also with the VLAN member lan.2 with ID 2:

If I am remembering correctly, I think then on 'service network restart' the router crashed and those files got generated.


UPDATE:

Actually I think it might have backed them up to my OneDrive. I just identified these:

@daniel I rebuild 1 time per month a new image for e8450 and i noticed since 4.1.2023 this change in the .config. Was it intended?


+CONFIG_DEFAULT_kmod-mt7615e=y
+CONFIG_DEFAULT_kmod-mt7615-firmware=y
-CONFIG_DEFAULT_kmod-mt7622-firmware=y
+CONFIG_DEFAULT_kmod-mt7915e=y
-CONFIG_DEFAULT_kmod-mt7915-firmware=y
+CONFIG_DRIVER_11N_SUPPORT=y
+CONFIG_PACKAGE_kmod-mt7615-firmware=y
-CONFIG_PACKAGE_kmod-mt7622-firmware=y
-CONFIG_PACKAGE_kmod-mt7915-firmware=y

In "menuconfig" the item "kernel" is empty

This should be realted: https://github.com/openwrt/openwrt/commit/9a07895729a9701a673951a31ceb71f16f0a6fad

The latest mt76 commit seems to have fixed the sudden drop in TX speeds on AX mode! :+1:

Many thanks to all the contributors who have been working on improving this devices :smiley:

On the recent BW160 and BW80+80 capabilities removal in mt7915:

  • Is it a key contributor to the performance improvement?
  • Is it a temporary solution, or is it likely to become permanent?
3 Likes

Is the drop in speed due to the number of barriers between the transmitter and the receiver or is this something else?

In my case it seems to be due to the numbers of barriers. M1 Mac client, 7m from the router and a single wall in between. When the RSSI gets roughly below -65dBm, TX HE-MCS suddenly drops to 0. RX seems to be largely unaffected.

1 Like

I can say that the bug is still present on my Redmi RX6000 (not RT3200), building the latest from master:

Behind multiple barriers gives me iperf3 speeds >300 Mbit/sec in upload mode.
Channel = 100
Width = 160 MHz

If I switch to channel =149 with 80 MHz width, the identical test from the same location runs 10-12 Mbit/sec.

Very nice it seems to be fixed. Tested at the same spot as earlier where I got <20 Mbits ( 802.11ax worse than 802.11ac with mt76 driver? - #223 by Anteus )

AX

[ ID] Interval           Transfer     Bitrate         Retr  Cwnd          RTT
[  7]   0.00-1.00   sec  74.1 MBytes   621 Mbits/sec  2972744   2.20 MBytes   12ms
[  7]   1.00-2.00   sec  69.8 MBytes   585 Mbits/sec  2054712   1.64 MBytes   22ms
[  7]   2.00-3.01   sec  69.4 MBytes   580 Mbits/sec    0   1.71 MBytes   21ms
[  7]   3.01-4.00   sec  68.2 MBytes   574 Mbits/sec  1505920   1.77 MBytes   20ms
[  7]   4.00-5.00   sec  65.3 MBytes   548 Mbits/sec  1624656   1.82 MBytes   14ms
[  7]   5.00-6.00   sec  55.9 MBytes   469 Mbits/sec  1637688   1.94 MBytes   46ms
[  7]   6.00-7.00   sec  59.8 MBytes   502 Mbits/sec    0   1.98 MBytes   33ms
[  7]   7.00-8.00   sec  68.6 MBytes   575 Mbits/sec    0   2.03 MBytes   31ms
[  7]   8.00-9.00   sec  70.0 MBytes   587 Mbits/sec    0   2.08 MBytes   27ms
[  7]   9.00-10.00  sec  63.4 MBytes   531 Mbits/sec    0   2.12 MBytes   37ms
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  7]   0.00-10.00  sec   664 MBytes   557 Mbits/sec  9795720             sender
[  7]   0.00-10.02  sec   662 MBytes   555 Mbits/sec                  receiver
2 Likes

My results on channel 36, htmode = HE80, across two walls. Before, upload speed was ~ 10Mb/s.

Wifi status

RX: 432.3 MBit/s, HE-MCS 4, 80MHz, HE-NSS 2, HE-GI 0, HE-DCM 0
TX: 816.7 MBit/s, HE-MCS 8, 80MHz, HE-NSS 2, HE-GI 1, HE-DCM 0

Upload

[ ID] Interval           Transfer     Bitrate
[  7]   0.00-5.00   sec   224 MBytes   376 Mbits/sec                  sender
[  7]   0.00-5.01   sec   223 MBytes   373 Mbits/sec                  receiver

Download

[ ID] Interval           Transfer     Bitrate         Retr
[  7]   0.00-5.01   sec   391 MBytes   655 Mbits/sec    0             sender
[  7]   0.00-5.00   sec   387 MBytes   650 Mbits/sec                  receiver
3 Likes