Archer C2 (V1) - How to debrick?

I will try to restore via serial. only the power light is on and the plug in blinks once the internet light. Where can I find the serial connection scheme?
It says wiki.openwrt "On some versions you need to solder 2 bridges to get serial port working. You need good soldering experiences for that!" I do not understand it.

https://openwrt.org/toh/tp-link/archer_c2_ac750#serial

It appears you already found the serial connection scheme. What part are you having problems understanding?

https://en.wiktionary.org/wiki/closed_circuit

"On some versions you need to solder 2 bridges to get serial port working. You need good soldering experiences for that!"
it is not clear which bridges to solder and where

Yes, I agree; the message about soldering bridges is rather cryptic.

Can you post a photo of the board showing the serial port pins? The best thing would be to update the TOH entry with some photos.

Note: avoid using the "wiki" links (wiki.openwrt.org) because the wiki is not being updated (as it says at the top of every wiki page). Instead use the link provided above by @lleachii.

Use the tftpd method.

2 3

does not work through tftp

What I did was putting a static address within the 192.168.0.0 subnet on the PC. I prepared the TP-LINK firmware with the name "tp_recovery.bin" in the tfptd program and it worked. Turn off the router. Turn it on by pressing the reset button for about 5 to 10 seconds and then release it when you see that the program shows the progress bar. And wait for it to restart on its own for 30 seconds or so.

I've seen photos of some TP-Link devices where it's obvious there are two missing jumpers - two solder lands ready to bridge with a drop of solder. I see nothing like it in this case. I suspect the comment about "some versions you need..." is really meaning, "some versions of TP-Link router..." See photos here: https://openwrt.org/toh/tp-link/tl-wa901nd?s[]=wa901nd#serial_console3 for mention of these bridges only for v4 and v5 of the WA901ND. Given your router is v1, you probably don't need to worry about this.

Interesting that one of the four pins is missing. I would guess this is for VCC, which you won't generally need for a console (and should avoid using). Just try plugging signal ground into the next pin along (next to the empty pin) and TX/RX on the other two and see how you go. Perhaps use the piezo buzzer trick to find which is TX.

What are you using for connecting to your PC?

Also see here, a photo of someone's Archer C2 (V1) with a serial header and no evidence of bridges being soldered on.
https://imgur.com/yYfY7oD [from https://wikidevi.com/wiki/TP-LINK_Archer_C2_v1.x]

I tried to connect in different ways, there is no reaction.
I use "USB to TTL UART Module CH340" and "Prolific USB-to-Serial Comm Port PL2303".
now I do not know what to think

I've used a PL2303 device in the past, but not the CH340. My PL2303 broke, so now I use an old Nokia phone cable (DCU-11).

Use a loopback test to confirm that your USB-TTL device is working, by joining its TX and RX, and you should see what you type.

checked CH340 and PL2303, are working.

Sorry, I don't know what else to suggest. Perhaps the router is defective.

1 Like

The flash memory dropped out, it was empty. stitched, soldered, everything works.

@Murchic , thanks for the update. Great news that it's working again.

Can you please elaborate? What do "dropped out" and "stitched" mean? How did you discover that it was a problem with the flash memory?

Can you confirm that no bridge soldering was required?

bridges failed to solder, very thin wiring
I connected the CH341A to the flash memory and read it, there was only "00000000000", there was no data. soldered off flash memory 25Q64BVSIG, wrote down a dump on it and soldered back.
sorry for bad english i'm from Russia

CH341A Programmer
Inked3686303796_LI

Wow, that's brilliant! Well done! I'm glad it's working for you now.

1 Like

Just a hint: I debricked my C2's via CH341A. You do not need to de-solder flash memory from board in order to flash it. Actually, de-soldering is very hard to do (I destroyed one of my routers trying to remove flash chip). I was able to both read and write C2 flash in-situ, while soldered. Red wire needs to go on the dot. Router should be disconnected from power.

IMG_2024

That being said, C2 is a bad router for OpenWRT. Only 5GHz is usable as 2.4GHz driver is buggy and will fold under heavy usage. See my thread here: Archer C2: 2.4GHz (MT7620) support is broken

I have since replaced all my C2's for C7's. Much better throughput on 5GHz and also better radio.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.