Archer C2: 2.4GHz (MT7620) support is broken

You can find the snapshot link here: https://openwrt.org/toh/hwdata/tp-link/tp-link_archer_c2_ac750

OK, just tried the http://downloads.openwrt.org/snapshots/targets/ramips/mt7620/openwrt-ramips-mt7620-tplink_c2-v1-squashfs-sysupgrade.bin. it didn't want to flash via Luci.

Then I copied the file directly to router and tried to force the upgrade from SSH via "sysupgrade -F openwrt-ramips-mt7620-tplink_c2-v1-squashfs-sysupgrade.bin". It wrot e the file but bricked the router.

I have a Flash burner so I can probably unbrick it, but I need to know which image should be used...

Any hints?

I am now trying to burn http://downloads.openwrt.org/snapshots/targets/ramips/mt7620/openwrt-ramips-mt7620-tplink_c2-v1-squashfs-factory.bin directly on flash via CH341A Flash burner....will know in 15 minutes if it works.

IMG_2024

Not the most elegant way to upgrade the router... :stuck_out_tongue: (TFTP does not work on this particular example. It seems that they used whatever Flash was available. Some are not recoverable via TFTP)

2 Likes

Nope, doesn't work. I even flashed back to OEM and then tried to flash to OpenWRT via factory image but router do not accept the file. This snapshot is broken.

Somebody from openwrt team, should look what is going. It is weird that it even breaks the bootloader.

It was still possible to do TFTP recovery after forced upgrade, it is just this particular C2 had problems with TFTP so I had to re-flash it via brute force (flash programmer).

I tried following alternatives:

  1. Upgrade from LEDE 17.something via LUCI using http://downloads.openwrt.org/snapshots/targets/ramips/mt7620/openwrt-ramips-mt7620-tplink_c2-v1-squashfs-sysupgrade.bin. Did not accept the file.
  2. Upgrade directly on router by uploading same file to /tmp and running "sysupgrade -F openwrt-ramips-mt7620-tplink_c2-v1-squashfs-sysupgrade.bin". It flashed but bricked the router.
  3. Directly flashing http://downloads.openwrt.org/snapshots/targets/ramips/mt7620/openwrt-ramips-mt7620-tplink_c2-v1-squashfs-factory.bin onto Flash chip. (didn't work, probably due to ofset).
  4. Reverting router to factory image, then trying to upgrade via GUI using http://downloads.openwrt.org/snapshots/targets/ramips/mt7620/openwrt-ramips-mt7620-tplink_c2-v1-squashfs-factory.bin (GUI did not accept the image).

You may have one or more variable on uboot misconfigured: http://www.denx.de/wiki/publish/DULG/to-delete/UBootEnvVariables.html

Anyway.. If the UI does not accept the image there is definitely something wrong. You also said you tried sysupgrade. Instead of using -F that is almost never going to result with a working router, you could try-v` to get a more descriptive error of what is going on.

If you access to console, it would be also interesting to see what the error is.

I'm having this exact problem with my Archer C20i v1, which has the same specs as the Archer C2 v1, and OpenWrt 18.06.1. Was this ever fixed in 18.06.2?

I have exactly same model router. Archer c2 v1.1
Please can you help me with dump file?

Please update to snapshot or 19.07-SNAPSHOT. It was fixed.

Unfortunately router it's bricked and i want to rewrite chip with CH341A!
TFTP or serial not working!

Helllo,

is 5Ghz working on 19.07 ?

5Ghz is not working for me. Tried the build thats listed in the wiki as flashable from recovery and then also tried to update to current build from there. Tried changing around almost every setting in wireless. For example my Android phone pretends its connected to 5Ghz and the router lists it as connected but then i get no connection to anywhere (in both all bridged or wan/lan seperate) and disabling and enabling 5Ghz prevents me from connecting at all then (not even pretending anymore then). If I do a reboot i can atleast go back to the phone pretending its connecting. 2.4Ghz works fine in either configuration.

I also have issues on 5Ghz, it only pretend to work for me and shows on for a short period of time.
Only Lucy it looks OK, but none of my devices can connect to it stable. As you, I tried every single configuration, but got no luck.
Is there a BUG open for this issue?

Issue I had was that output power was capped to 10mW regardless of what you configured in Luci.

how did you flash the stock firmware? Just downloaded from TP-Link site and wrote it to the chip as-is?
Or did you skip first 512B?

I do not really remember. I believe I just did a read out from working router and then flashed it on non-working one. MAC number was hard-coded in flash so I had to edit that, otherwise I got identical MAC# on both.

could you please provide the bin file and the mac address location?
Edit: found the address: 0x7DF100
I have made a dump of the flash (using flashrom), downloaded stock firmware, removed first 512B from stock bin (header, which is not being flashed), appended rest of the partitions from dump and flashed it.
mac address is in flash the same as is on the case. ie. not reversed

I just read the chip contents and searched for MAC in CH341A.exe. Then I edited MAC directly in HEX dump in burner software and burned it back to the flash. I believe there was only one MAC for WiFi, 5GHzr MAC was just ofsett by 2.

Anyway, write down all your MAC before, search them in HEX and edit them to whatever you like. Burn it back to flash and that's it.