Zbt wg3526 16M 512M version "incorrect model" 18.06.04

I just bought a ZBT WG3526 with 16M flash and 512M RAM.
I tried to install OpenWrt using the stock web interface.
But got "incorrect model" message.
I've tried various .bin files but got the same message.

The commit that added support for this device says
The WG3526 is the follow-up to the 2626 and is mostly the same, with the
excaption that the mt7602 has been replaced with the mt7603. The internal wifi
setup has also changed slightly. Based on my tests, everything that worked on
the 2626 works on the 3526 and with roughly the same performance.
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=30fbc1a4d146ae0060d02946709fd6d8cc2a2b56

So I think you need to follow the instructions for the wg2626 https://openwrt.org/toh/zbt/wg2626

Thank you! But I got the same result "incorrect model" with wg2626 BIN.
I just wait for next openwrt version and see if it will work.

The instructions say you cannot update from web interface. You need to use SSH.

1 Like

"port 22 refused" message when I tried ssh 192.168.1.1 .
I've turned the firewall to "off" with the stock web interface before trying
ssh.

Cool, the wiki is wrong then. Try recovery mode as explained here https://ltehacks.com/viewtopic.php?f=12&t=5
The "wifix" and "GoldenOrb" (actually ROOTer) firmwares mentioned there are customized OpenWrt firmwares, so the procedure should work with OpenWrt too.

If you confirm that it works I'm adding that to the wiki.

First, "recovery mode" method didn't allow ssh either. However, it gave me a hint.... Here's how I eventually flashed the "openwrt-18.06.4-ramips-mt7621-zbt-wg2626-squashfs-sysupgrade.bin" -

  1. With Lan cable connected to computer, follow the "recovery mode method" - hold the reset button and plug in power. Wait for about 10sec. (I won't try flashing firmware with Wifi instead of Lan cable)

  2. Instead of showing default router web admin interface, "192.168.1.1" on browser will bring up a "firmware recovery mode" interface in Chinese (only). SSH won't work. An instruction on lte-hacks in 2018/8 was based on a pandorabox based stock firmware. From 2019/8 the stock firmware seems to be based on some version of openwrt. So the "firmware recovery mode" screen is a bit different now 2019/8.

  3. Don't panic if you can''t read Chinese. You just need to recognise these few words/phrases. 固件恢复模式 = firmware recovery mode . 恢复 = recovery. 备份 = backup

  4. To play safe, press 备份 to backup the stock firmware first. The filename seemed to be set to "eeprom.bin" . The file size for this 20190809 stock version was just 65.5k.

  5. I renamed the "openwrt-18.06.4-ramips-mt7621-zbt-wg2626-squashfs-sysupgrade.bin" file to "eeprom.bin". It may be unnecessary. You may try bypassing this step.

  6. Press 恢复 to "recover" the eeprom.bin file to the router. As usual this process takes a while and any interruption will brick your router. It will show some messages in Chinese. FYI, 重启中=rebooting, 重启=reboot, 等候=wait, 完成=done