Xiaomi mi wifi 3 support

btw my mistake with compilation issues. when i downloaded their tags without messing with scripts/feeds all worked like a charm

Thanks for your suggestion.

Hmm I checked Padavan, but their installation seems to not mention anything about "Enabling Write to Console" or "Get SSH/dropbear access" which is found in the OpenWRT MIR3 wiki

If I may want to revert to stock in the future, is enabling write to console & get ssh/dropbear access necessary before I flash Padavan?

EDIT: Also, does any of the custom roms support WPA3? Seems like OpenWRT 19.07 already supports it.

No, the prometheus script will do everything for u...all u need to do is flash the old dev firmware, reset it and set password then do the prometheus script thing..the script will do every trick automatically what the wiki has. @templeIsland2

1 Like

Are there newer versions of padavan or how can you update the version after the first installation of padavan? What's the way back to original or openwrt?

To revert back to stock, there's a section on the wiki describing how to do it https://openwrt.org/toh/xiaomi/mir3.

If the Prometheus script really does enable SSH & dropbear access, then stock reverting should be exactly the same.

I'm curious though, I'm using stock ROM, and only get 2Mbps/5Mbps DL/UL out of repeater mode (from the 50Mbps UL/DL internet I have). If I flash custom ROM, will it improve?

EDIT: Also, Padavan has not been updated for 2 years. Looks like its time to move on from my brand new device haha. I think I'm going to resell it and buy a new one. Does OpenWRT has a "abandoned" banner available for devices that are abandoned? Otherwise more users might buy this device and instantly regrets it.

Don't, that is a unique piece of hardware. Asus/Netgear will ask u double for the same hardware. I bricked mine over an year ago and can't find it anywhere bcoz xiaomi don't make it anymore. @templeIsland2

Hi everyone I am trying to unbrick my xiomi mi router 3, and I try using hyperterminal putty(windows) cu, minicom on linux, and I can send the number and another thing is so fast to try to press some number, could you help me? thanks in advance I read this post Bricked Xiaomi Mi WiFi Router 3. Stuck in infinite loop but didnt work for me

U-Boot1.13(Apr 15 2016 - 7:6:3)

Board: RalinkAPoC RAM:  128 MB
owr o mmory test. emoy ize 128 MB...OK!
rloatecode Pointer t: 7f8000
enableeph lock.done.rf reg 29= 
!! nn pag ize = 2048,add ln=4
Ralnk Bot Vrsion: 4.2.S.1
AIC762_MP (Port5<->Nne
RAM_CONF_ROM: ut-deecion 
DRAM componnt: 04 Mbts
Total meory: 2 MBye
Flash componet:NAN Flash
dcche: sets:256,was:4 inesz:3 ,total3268

 stmat memorysize 128Mbtes ### 

lase coose the peatin: 
   1: Lod ystm ode to DRAM vi FTP 
                                     2: Load sysem od then writ toFlsh iaTFTP. 
   3:Boo sste code via Flah defult).
   4: ntrbot ommand line intrace
  9 Load Boo Lode code then write t las via TFTP.

: ystem Boot sysem od via Flash.
Botig ystm 2
..raanders_write: offs4000,count:20000
## otingimage at bc60000..
  Imge ame:   IPS Oenrt inx-4.14.89
   Data Size:   59367 Bytes =  . M(lzma cmpessd)
  Lad Address: 800000
  Entry Point: 800000
.........................  Veifyng Checksm .. O
  Uncompresin Kere Imae ... K
                             comandline uart_en= actoy_mde=0 mem=12m
                                                                    No nitrd
# Tranferin cntrol to Liux ataddess80000000) ..
                                               ## iving linux memiz inMB, 128

Statin krnel ...

[   0.000000 Liuxversion 4.14.89(aor@bntu) (gcc versin .3. (OpenWrt GCC .3. r365-95daf4c441)) 0 Te ec 18 17:25:50 01
[  .000000] Boad hs DR2
[    0.0000] Aalg PU set to h cntrl
[    0.00000]Digtl PMU set to hwcotro
    0.000000]SoCTye: MediaTekMT62A vr: eco:6
    0.000000]Linx erson 4.14.89 (aorubntu) (gcc version7.30 OpenWrt GCC 73.0r765-5da4c441)) # Tu Dc 18 17:25:50 2018
                                                                                                                       0.00000] Boar ha DR2
                                                                                                                                           [    0.000000 Aalo PMU set to h conrl
    .000000] iita PU set to hwconro
[   0.00000] oC Tp: MediaTek MT7620Ave:2 co:6
[   0.000000] Linx erson 4.4.89 (ado@bunt) (gcc versio 7..0(OpnWrt CC 7.3. r36595af4c441)) #0 Te ec 8 17:25:0 201
   0000000] Board hs DR2
                        [    0.00000] Aalg MU se to hw cotrl
    0.000000]Digta PM set to hw cotrol
                                          0.000000] SoC yp: MdiaTek MT7620 ve:2eco6
[   .000000] Liu vesin 4.14.9 (adorubntu (gcc version7.3. (penrt CC 7.3.0 r36-95af4c441) #0 Te Dc 1 17:25:50 2018
[   0.000000] Anao PMUset t hw conrol                                                                            [   .00000] Board ha DR2
[   0.000000] SoC Tye:MeiaTek MT720A vr: ec:0000] Diial PUset to w contrl
[   0000000] Linuxverso 4.14.89 (ador@ubut) (cc versin 7.30 OpeWt GCC 7.3.0 r735-5df4c441)) #0 Tu Dc 1 1:25:50 018
[   0.000000 Anlo PM st to hw contrl
   0000000] Digita PM st to hw conrl
[  0.00000] SoC Typ: ediTk MT7620A ver: ec:6
                                            [   .000

Really? But isn't WPA3 coming out (like in OpenWRT 19.01)? Kinda pointless to keep it if the device doesn't support WPA3 officially nor unofficially though. Its a shame Xiaomi decided to go with a crippled U-Boot that restricted a lot of modding capabilities, or we really have a great device.

Also, the router repeating capability is quite bad (on the official firmware), I've only managed 2Mbps (from 30Mbps direct) even under extremely close distance, which is impossible for anything other than light browsing. Can I expect something better with unofficial firmware though?

is it possible to share build scripts for 19.07.3 ?

Hello everyone!

I started hunting for something for the Xiaomi Mi Router 3 because I would like to use its USB port for access via NFS, but the X-WRT does not have it built in.

Apparently the X-WRT maintainer tried to include official support through this PR: https://github.com/openwrt/openwrt/pull/597

If you install the newest version of X-WRT you will see that the kernel used is 5.4.61: Linux X-WRT 5.4.61 # 0 Sat Sep 5 18:58:19 2020 GNU / Linux mips

And even several packages are updated. So it works, but I don't know why the support doesn't exist.

Guys, we don't need to invent the wheel. Execute further commands in Linux:

git clone git://git.openwrt.org/openwrt/openwrt.git openwrt-mir3
cd openwrt-mir3
./scripts/feeds update -a && ./scripts/feeds install -a
git rev-parse --short HEAD

Put mir3-support.patch to git cloned openwrt-mir3 directory

patch -p1 <mir3-support.patch 
make menuconfig

In menuconfig select:
Target System (MediaTek Ralink MIPS)
Subtarget (MT7620 based boards)
Target Profile (Xiaomi Mi Router R3)
and Luci and whatever packets you want, NFS or other. Than click save, push Enter and exit menuconfig.

make -j5

After half an hour you will find your build firmware in "bin" directory.

Or you can try prebuilt firmware link
How to install/flash link
Just know, that by default after you install firmware, wifi is disabled and Luci service is not started.
So you must connect through LAN, SSH to using Linux or Putty, make password for Lucy, start Luci service, enter web interface, start wifi, set wifi password.
Information taken from Link

ssh -root@

BusyBox v1.31.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt SNAPSHOT, r14390-7716a43092
root@MiR3:~# cat /proc/cpuinfo 
system type		: MediaTek MT7620A ver:2 eco:6
machine			: Xiaomi Mi Router R3


There is no official MIR3 OpenWrt support, because of the copyright of NAND driver code for this device and will not be probably.


I will like to try flashing prebuilt image,any flashing tips? (Steps). Can u please share some info.

For those interested, I had asked on x-wrt's github to include support for NFS.

The project maintainer, @ptpt52 said that it was enough to configure and passed these steps:


Prepare the compilation environment.


git clone https://github.com/x-wrt/x-wrt.git
cd x-wrt
./scripts/feeds update -a
./scripts/feeds install -a

cp feeds/x/rom/lede/config.ramips-mt7620 .config

make menuconfig
#select kmod-nfs and nfs-kernel-server


I had already cloned the x-wrt repository and done the rest of the steps, but without the config file to import the settings ready for menuconfig I was getting lost in what was needed.

With the file in question it's easy.

I'll try.

Wish me luck, LOL!

PS: Thank You @ptpt52


i have the same problem ... can anyone help to solve this problem??

First you can try this recovery proceture:

  • Download miwifi_r3_all_55ac7_2.11.20.bin
  • Rename downloaded file to miwifi.bin
  • Put miwifi.bin into a USB flash drive (must be FAT/FAT32)
  • Plug said USB drive to router's usb port
  • Unplug router's power
  • Press reset button and then re-plug the power
  • Keep pressing reset button until the orange status LED starts blinking
  • wait until the LED turns blue.

If that doesn't work https://openwrt.org/toh/xiaomi/mir3, see paragraph " Recovering from Softbrick". You will have to buy CP2102, open you router and connect cables to hardware and follow the whole procedure.

1 Like

I have done it and it doesn't work ... now the way it turns on doesn't turn on only lan port 1 one is on ... ttl port is also not working

1 Like

If none of these works, you can change ROM chip, buy and solder SPI W25Q128FVSIG. Use the same source https://openwrt.org/toh/xiaomi/mir3, paragraph "SPI Flash Mod" also russian forum, use google translator https://4pda.ru/forum/index.php?s=&showtopic=837667&view=findpost&p=69926582

@romandas Ty for the prebuild firmware, i successfully flashed my MIR3.
I have only one question, i need some packages, like kmod-usb, but the repository have only the version 5.4.67. What i can do? Re-Compile the kernel with latest version of files or have a better approach?

Obs.: I would like to avoid the recompile part, my ISP use some "Hardware method" to authenticate and when i flashed from padavan -> stock -> openwert, i have lost internet connection for one day and need to call they tech support to "reset" they config.i don`t now if a sysupgrade can cause this issue again.

Yes. You have to rebuild firmware yourself, because you cant change kernel.

Ok, ty, rebuild and do sysupgrade?