Xiaomi mi wifi 3 support

I get 25Mbps down and 17mpbs up, which is about as good as I'd expect at the moment.

Thanks, and what's your internet speed defined by ISP ?

I'm on FTTC (VDSL), sync speed is 58Mbps or so, but I've never got anything like that from speedtest - 30-40 is the best I could ever get even using a LAN cable directly attached to the Fritz router.

1 Like

Probably a stupid question but I did this on a stock mir3 and now it won't boot anymore. Ethernet ports light up when connecting power supply and blink if I attach an ethernet cable but that's it. No serial connection atm. Total brick or recoverable?

Did you converted your mir3 to mi wifi mini beforehand?

Because I did (my router was bricked):

Here's what my router looks like the last time I opened it:

Foolish me did not :sweat_smile:
Tried flashing Padavan via Prometheus but it gave me a size error. Thus, I tried flashin X-WRT which went well except for flashing rootfs which gave an error so I thought what the heck, flash a different bootloader and profit. Which is kinda stupid in hindsight. Probably need an USB TTL adapter to unbrick?

Having USB TTL/UART around is always a good idea. But you probably need to convert yours to mi wifi mini (at least temporarily) to be able to use it again...

Peoples from 4PDA have a few tutorials for that (use Google translate):

  1. Installing an SPI chip on Mi WiFi R3 (and converting it to Mi WiFi Mini)
  2. Recovering the NAND chip
1 Like

Thank you, will buy and use an USB TTL to fix my problem using the guides you provided :slight_smile:

Edit: kind of confused which resistor I should solder, a 1k Ohm one, a 4.7k Ohm one or both

4.7 Ohms for the chip (between feet 3 and 8)
1k Ohms for the board (between J90 and J91)


You are a (router) life saver :smile:

Hey guys, (maybe this is unrelated but) in the Xiaomi 4A we managed to flash OpenWrt just by software using a exploit. Maybe it works for the MiRouter 3, find the exploit here: https://github.com/acecilia/OpenWRTInvasion. If it works for you please report it :slight_smile:



does anyone know how the situation is with Openwrt 19.07 on the MIRouter3?


He provides also very promising driver support for MI3 Router and similar devices.


Would someone try to test or compile something new?

Any experiences or news of today's situation with the device?

it has been a long time. too much going on in the thread and havent really caught up.

i am interested in bringing official "xiaomi mi router 3" support in the latest master branch of openwrt.

the only commit i could find regarding the device is on the x-wrt fork:

tried simply cherry-picking but probably due to changes in firmware isnt compatible.

if anyone is interested to help i would like to add official support for this device on openwrt.
if this already happened by someone please let me know and show me your sources :slight_smile:


(it does run fine on x-wrt fork, as im currently running it on my mi router 3)


after experimenting in source and finding a somewhat compatible device tree i experimented and modified the source and finally managed to output an image without compilation errors. thinking that if id manage to brick the router id still be able to recover with a serial adapter. i flashed the sysupgrade only (coming from x-wrt) which under normal conditions should work with a regular working image. however after flashing this sysupgrade now i get no serial console output anymore. is there some kind of chance due to the nand patches somehow the bootloader could have been wiped by a sysuprade?
furthermore i also have a jtag adapter is there anyway i could pin it to the nand chip and reprogram it?

as a worst case scenario if it didnt work on the openwrt source itself i was planning to create a modified version of x-wrt to resemble openwrt more or less. if anyone is interested the custom defconfig is usable on the source, however do not flash the images created for the mir3 by my source as you can tell from above.

however i do have a fake prolific serial chip which sometimes has issues, when i looped tx and rx onto itself i could type as a test. furthermore i have tried holding the reset button with a plugged usb having miwifi.bin stock firmware and it does blink orange till now. this could mean the bootloader is still intact? its been a while since i tinkered with this device i dont remember anymore.

its not blinking actually its more like a pulsating orange led. this happens when i plug it on while holding reset with or without a usb stick in the router. furthermore if i do the same while having serial connected nothing happens. the router on itself as long as serial isnt connected shows a short loop of purple led while booting for a second then orange for 2 seconds and repeat if i dont do anything to it.

update: turns out pandorabox bootloader was still fine. flashed the factory-breed image and recovered. for now i will release a modified image preferably on 5.4 testkernel of x-wrt for whoever is interested.

strangely enough i just found out i get this exact issue on x-wrt on a custom build with more or less exactly the same defconfig which i had used on openwrt which worked on the mi wifi mini with openwrt appears not to work with x-wrt on the mir3 one change of which the 5.4 testkernel.

hello, x-wrt working on my Mir3 but 2.4ghz band is so weak. Its going disappear for no reason and only gives 5 mbps at speedtest

my throughput on mir3 using x-wrt is fine. but then again i cannot compare how the range should be since im using two 9dbi omni antennas for 2.4ghz on the mir3.

furthermore concerning openwrt. most probably it is the defconfigs fault why it didnt boot after importing the mir3 device tree. im still at it but could use some help since my pc isnt the fastest in compilation.

x-wrt custom compilations boot now however no matter what i ty the 5.4 kernel doesnt get enabled using x-wrt on mir3 unfortunately.

theres no commit in source for the original defconfig used by x-wrt buildbot to show up in /proc/config.gz or something. does anyone know how i can get the config they use for wrt?

Hi, here are settings for X-Wrt, 2.4GHz wifi, from 4pda forum user 'kasper145'.
He got from 40 to 70Mbps. He found that problem lies is "Maximum transmit power" setting. Some dBm settings does not work well (26 and 28 works well). Also try changing channels, maybe your neighbors use the same.

If nothing works post to X-WRT creator feedback here: https://github.com/x-wrt/x-wrt/issues/79

1 Like

Hi, just as a warning (and some questions) if anyone is planning to buy this device for custom firmware.

  1. OpenWRT is NOT officially supported for this device. It has been 2 years without any updates, and most likely will continue until someone can resurrect it (which....looking at Xiaomi devices so far, if it doesn't, it doesn't).

  2. PandoraBox has been shut down by the Chinese government (or so I heard) and is pretty much dead, but seems to be picking up speed little by little. However, the last release targeting this device is 19.01, which is more than a year ago. The latest release, 19.02, appears to NOT target this device, and hence the future is uncertain.

Can someone confirm whether this is working, stable, and if not, what stable release have you used, and recommend the community to use?

  1. X-WRT, another fork, is having some serious issues regarding the stability on BOTH 2.4Ghz and 5Ghz as seen in #52 on its GitHub. The issue has been going on for 9 months, and appears to have no solution for now.

Can someone let us know which X-WRT is considered stable for the community to use?

Also, can we apply this: Smartphone USB Tethering to an OpenWrt router using PandoraBox, X-WRT, and Padavan?

Thank you.

1 Like

my experience with x-wrt despite of the issues you mentioned has been really good. on openwrt normally i need to install some extra packages to get good throughput. in case of x-wrt on mi3 i have been running it ever since it was supported. however i did experience issues of source not always being able to compile an image and have had trouble even building off of their buildbot used defconfig at times it worked at other times it didnt, despite of checking out at certain release tags.

im not sure but i think their breed boodloader uses pandorabox bootloader in case of a brick you simply switch your router to recovery mode and can access it always through to directly flash an image so there would be no need even to go back to stock through usb and do that whole process all over again or even use a serial adapter once youre on that. all over im very pleased.

as we speak i updated both miwifi mini and mir3 which are the same hardware part from storage, to their latest published release as i usually do and all continues to work for me.

you could also try if you have no issues compiling now and then like me, enabling option "HAVE_TESTINGKERNEL" or something like this to switch to kernel 5.4 and checkout how that works for you. all over i have to say they also are very prompt with upstreaming, at least their kernel patchlevel is quite ahead compared to openwrt last time i checked.


Go for Padavan if u want the best wifi performance and stability, even better than stock firmware.

1 Like