Xiaomi ax3600 recovery

Hi everyone,

I am new here and also new to the openwrt. I have here Xiaomi ax3600 router, which is flashing red light and I assume it to be bricked. I tried to flash the customised firmware as well as the kernel on to the /dev/mtd12 partition of the router, before rebooting it.
Using UART is out of option because I didn't set any variable using nvram.
I know i am very stupid and will remember this forever. Anyone have any ideas, that could point me into recovering this router? any ideas would be appriciated. I am sorry for all the trouble.

Thank you.

Do you have tried this?

1 Like

Do you have UART working?

Without it, there is no way to know whether the bootloader survived

1 Like

I already brought the adapter online this morning, I will reported back as soon as I test it. Thank you again.

As long as you havent messed with the u-boot or breeze bootloader, then you can do a 'hold reset button' recovery - most of these routers have this recovery process.

Just need a dhcp,tftp server (tinypxe program for windows) and rename the original oem firmware (http://cdn.cnbj1.fds.api.mi-img.com/xiaoqiang/rom/rm1800/miwifi_rm1800_firmware_fafda_1.0.336.bin) to test.bin and put in the tftp folder. Then you can fully recover.

1 Like

Just make sure that your usb2serial adapter is 1.8 volt capable (not the more common 3.3 volts).

1 Like

Thank you for the information. Already downloaded the software, will try it out as soon as possible. This link download the firmware for AX1800, is it compatible with AX3600?

I was wandering about the voltage required. Thank you for confirming. But 1.8v seems to be very uncommon on the market, is it possible that I used 3.3v instead?

Only if you want fireworks. The SOC is running at 1.8 volts (which is common among highend ARM platforms, previous devices like TP-Link Archer C2600 or several hardkernel SBC have done the same), just that many other vendors added voltage level shifters.

Hi @KunWin, I'm trying to activate the recovery mode in my AX3600, but I don't understand this "four times twice" before you can release the button.", my router blink the orange light very fast, for like 3 times, and stops.

Hi I would say "multiple times twice" instead of "four time twice", then the MiWIFIRepairTool should start sending the firmware. I apologised if my answer was misleading. I will edit the answer.

Hi everyone. Thank you for taking your time to help me. I manage to flash the official firmware 1.0.17 to the partition and recover the router. To summarie the problem for anyone who faces the same ploblem as me, I flashed the customised kernel and firmware to partition /dev/mtd12 using command:

ubiformat /dev/mtd12 -f /tmp/flashed-img.bin -s 2048 -O 2048
nvram set flag_ota_reboot=1
nvram commit

I didn't touced the bootloader. I use the tools available in the xiaomi website for recovering:

The website to download this tools with normal browser doesn't work. Please used VM with incognito tab to open the link. I used VM Ubuntu 18.0.4 and firefox.

and followed the instruction in the link below:

The main different between is when you pressed the reset button after rebooting, the red light have to blink multiple times twice, i repeat, "multiple times twice" before you can release the button, then the MIWIFIrepairtool should start sending the firmware.

Also allow access to your local server, when promted the first time you open the xiaomi router recovery software. This was the problem, why it didn't work the first time I used it.

To activate recovery do you have the ethernet cable connected to the LAN port? What lan port (1, 2 or 3)?

I turned off my router, and turn on holding the reset button, my router turns on with an orange (amber) light, after a few seconds they start to blink this light very fast (if the ethernet cable is connected they blink 3 times only, if not they blink 5 times or more).

After stop blink, my windows shows "connected".

Do you have any type of video to show how to enter in recovery mode for this router? It will help me very much.

Thanks for your attention.

Any LAN port would be fine.

I am also not an expert in this area, may be you can tell us what did you do exactly to your router, so that others might have some clue.

If you only have a short video to show the way you do to activate the recovery mode it will be amazing. =)
Because I really don't know the exact release moment of the reset button.


Hoddy did a video on the Xiaomi 4a debrick method - timeline 2:40 debrick method, could be the same for your router?

I talked with Hoddy, and is different for xiaomi AX3600

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.