Xiaomi AX3600 Installation Doubts

Hi Xiaomi AX3600 experts,

I need to upgrade my WLAN hardware and found the very promising Xiaomi AX3600.
The device is on its way to me and I read quite a lot about how to bring OpenWRT to it. Especially here:

Gaining SSH access looks easy enough and I managed to compile the fork of @robimarko like this:

git clone https://github.com/robimarko/openwrt robiwrt
cd robiwrt
git checkout AX3600-5.10-restart
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig
make -j 5
ls -l bin/targets/ipq807x/generic

Now I have these files waiting to be flashed:

  • openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-nand-factory.ubi
  • openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-nand-sysupgrade.bin

All I changed with menuconfig is the target and device. Is that all or are there other important settings to take full advantage of the hardware?
Since the hardware is not officially supported, I guess I have to build additional packages (like luci) myself as well?

Finally the install guide link above is not very clear to me. Do I need to do all of this verbatim, with the google drive firmwares or can I work with my "own" firmware?
Like this:

scp openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-nand-factory.ubi root@

ssh root@
nvram set flag_last_success=0
nvram set flag_boot_rootfs=0
nvram set uart_en=1
nvram set boot_wait=on
nvram commit
flash firmware mtd write openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-nand-factory.ubi rootfs

scp openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-nand-sysupgrade.bin root@
ssh root@
sysupgrade /tmp/openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-nand-sysupgrade.bin

# and again...
scp openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-nand-sysupgrade.bin root@
ssh root@
sysupgrade /tmp/openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-nand-sysupgrade.bin

ssh root@
fw_setenv flag_last_success 1
fw_setenv flag_boot_rootfs 1

# done :) ?

I hope you can help me with those 3 questions.


1 Like

It's all written in the commit itself


cool, that makes sense. Was just dug a little too deep for me. Thanks!

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

the device arrived. It is soo big - didn't expect that... but hey, I guess it needs some space to vent.

Getting SSH had its quirks. Downgrading the international version 3.0.16 to the original chinese version went fine, but then configuring the device enough to be able to login and see the stok was a bit tough. I tried via lan, wlan and with mobile app. can't even remember what exactly it was that got me to the login page after the router setup confirmation page (that has no ok button or similar, just shows the new wlan config...)

I also noticed the stok is only temporarily valid. Don't make a long break after you get yours, or you'll see

{"code":401,"msg":"Invalid token"}

Finally: the commit message does not tell the whole truth (to a noob).
It says you need to ubiformat both rootfs and rootfs_1, but one is bound to fail since it is the current rootfs:

root@XiaoQiang:~# ubiformat /dev/mtd13 -y -f /tmp/openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-nand-factory.ubi
ubiformat: error!: please, first detach mtd13 (/dev/mtd13) from ubi0

I could format mtd12 but then needed to switch the rootfs and reboot to do the other one, like that:

root@XiaoQiang:~# nvram set flag_last_success=0
root@XiaoQiang:~# nvram set flag_boot_rootfs=0
root@XiaoQiang:~# nvram commit
root@XiaoQiang:~# reboot
root@XiaoQiang:~# Connection to closed by remote host.

That was the last time I saw subnet :slight_smile:

On to configuring and installing packages...

1 Like

Commit message was written for using initramfs basically, otherwise you can only flash to the not used partition.

1 Like

no problem! Just wanted to mention it for other people with my level of expertise...

Let me use that opportunity to thank you and all the others that contributed to this project so far.
I really didn't expect such a stable and usable state of firmware and build system so soon. I already like to use this WLAN more than the old WLAN mesh that it will replace at some point in time.


I like when people point out mistakes as I completely missed them.
I will update the instructions and add the flashing without the UART version.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.