Wwan -> ethernet Bridge Mode

Evening all,

having spent the last 3 days trying to get my Sierra EM7455 LTE card to connect to any network (and discovering the FCC lock that the card contains) I've finally now got a mbim connection established and transferring data.

Now the next part of my plan, does anyone know of a way to bridge the wwan interface to a network port? In essence, I want the network port to receive the IP address transparently from the lte connection.

I briefly looked at relayd but it wont allow the wwlan as a part of the relay. I also tried trelay, setting the link up between eth1 and wwan0. Sadly, that too failed.

Open to and would very much welcome any ideas?

Did you mean carrier lock (never heard of an "FCC Lock" - and if it were, it was illegal to override it)?

You have any documentation on this?

Just curious. Thanks.

Modem radio will be off until a command is sent from the driver (on PC) or an app like uqmi in our case:
uqmi [...] --fcc-auth

--fcc-auth: Set FCC authentication

There are some details here: https://forum.sierrawireless.com/t/em7455-deactivate-low-power-mode/8620

1 Like

Check this old thread: Bridge Mode - LTE USB Modem

1 Like

Yep, that's it. to remove the lock you can use this Git Repo. In the parent is a Live DVD image based on Ubuntu that contains all the needed tools pre-installed.

Thank you for this, I'll have a look through and see what I can dig up, sadly though it looks like the conversation fizzled out before a conclusion.

Yep...odd name for something more like an On/Off switch.

Wow...I apologize for my question.

Hopefully that information helped others (and was asking to help the OP - after I knew the model with such an unique setting name); but oh well. I know the info helped me, thanks @AndrewZ.

Yep, im trying to set up something like this, but i think it's not so easy, i have seen a script sometime ago, i think it was taken off a teltonika, which is based on openwrt, doing crazy things, to do lte bridge mode.
Because a WWAN is not a real ethernet interface, so most things don't work out of the box.
I tought i would use relayd or trelay, but you say it doesn't work, must sort out somethings.
But i really think it must be done something rea bad to accomplish this, also if you want to connect to your router, you must use vlan and set 1 vlan for bridge 1 fr accessing/managing the router.

You're right abput VLAN, see Using a router as "dumb" LTE gateway? - #25 by AndrewZ

I was referring to the conversation in the forum chain linked by @AndrewZ, not to the conversation in this chain. Your question was valid, and I hope the info regarding the Sierra card and the 'hidden lock' is useful, I know it took me sometime to narrow down the culprit of persistent low power mode and refusals to connect.

As far as the bridge goes, I'm still looking through the available info, one forum I found suggests that modemmanager has IP pass through inbuilt, I don't suppose anyone with more experience of that package can comment on the validity of that statement?

1 Like

Found a forum post where a user 'Kearney' on the s4gru.com forums stated that he built modemmanager into OpenWRT and that IP pass through worked out of the box with a Sierra card, anyone know if they are active on here under a different name? If not, anyone familiar with the guts of modemmanager?

Well...I know it does the FCC-Unlock...

Have you installed it?


It does, but:

Since release 1.18.4, the ModemManager daemon no longer automatically performs the FCC unlock procedure by default.

Nor does it tell you that the lock might be the thing that is wrong with your failing connection attempts. Further, in the OpenWRT implementation (at leat as far as I could see), the scripts to perform the unlock are not included in the location described in the link you posted.

Yes I've installed it and yes, the card and subsequent link made using modemmanager and the mbim protocol are both working fine. The last piece of the puzzle, as stated, is to transparently bridge the wwan0 and eth1 ports. The intent being to give any device attached to eth1 the IP assigned by my mobile operator.

As I said, someone in a forum I just linked seemed to think that was possible, but I have not found any reference to how, nor does the modemmanager man page shed any light.

1 Like

Evening all,

Turns out that modemmanager establishes the connection to the cellular network, receives and stores the assigned ipv4 address in a bearer object. modemmanager then brings up the wwan0 interface, assigns it the address that is stored in the bearer object and routes all traffic destined to the wwan0 interface to the modem device.

not sure how I can use this to passthrough the IP and make the bridge, in theory I could just assign the IP in the bearer to any interface and route all traffic to the modem device?


I'm pretty sure Teltonika just uses Quectel's proprietary drivers and connection manager to get bridge mode

12.7. AT+QETH RGMII Extended Configuration
if you read the at commands for quectel 5g module, you can put it on ippassthrough mode, basically you need a mac address to feed it, then it will do all the things,but must be scripted because you cannot set the module to fixed ippassthrough, you have to set it every time the modem reboot, but the commands are always the same,basically all the modem need is to set a macddress of an interface, in this case you make a vlan and make 2 interface for a lan port, and one you give the macaddress to the module whit

AT+QETH="ipptmac"[,<host_mac_a ddr>]

at least thats what it seeems.

1 Like