WIFI down, while ethernet is still up Archer C7 v2

Hello,
I am using a TP-Link Archer C7 v2 with firmware version 19.07.3
Every ~10 days the WIFI is down, while ethernet is up.
Nothing visible in the logs.

I solve it now by rebooting.

It looks like this is started after 19.07.3 installation.

I hope a newer firmware version will come out soon and solve this issue. Or I hope somebody can give me a tip how to solve it in the current version.

Here are some details about my system:

Model: TP-Link Archer C7 v2
Architecture: Qualcomm Atheros QCA9558 ver 1 rev 0
Firmware Version: OpenWrt 19.07.3 r11063-85e04e9f46 / LuCI openwrt-19.07 branch git-20.136.49537-fb2f363
Kernel Version: 4.14.180

Maybe with a wifi up you won't need to reboot the whole router.

2 Likes

Thanks, now let's hope someone can tell why thew WIFI is going down. Cause if that issue can be solved, a reboot is not needed then.

This router suffers from unacceptably high memory consumption in the ath10k-ct driver. Either disable the 5GHz WiFi, or switch to the kmod-ath10k-ct-smallbuffers driver, then the router will be rock solid.

1 Like

This is usefull information!
1st option is something I understand.
2nd is something that I need a bit more explanation on. Do you mean a new "lighter" firmware?

It's not firmware, it's a variant of the driver. Here is how to install it (not over wi-fi, as we are removing the old driver!):

opkg remove kmod-ath10k-ct
opkg install  kmod-ath10k-ct-smallbuffers
reboot
3 Likes

Hi Patrakov, sorry to disturb you again, but I have some questions:

  1. Do I need to repeat this command every time I do a openwrt firmware upgrade?
  2. If I want to roll-back, I assume then first to remove that package, and then install ```
    kmod-ath10k-ct again right?
  3. What does this kmod-ath10k-ct-smallbuffers basically do? Are there any disadvantages doing this command?
  1. Yes, you need to do this every time you upgrade the firmware.
  2. Yes.
  3. It is the same as kmod-ath10k-ct, but modified to have smaller buffers, in which it keeps packets that the application submitted but the radio is not ready to send, or vice versa. This, theoretically, leads to lower throughput, but on a resource-constrained router there is no choice.
2 Likes

Hi,

I get the following error: What should I do now?

root@OpenWrt:~# opkg remove kmod-ath10k-ct
Removing package kmod-ath10k-ct from root...
root@OpenWrt:~# opkg install  kmod-ath10k-ct-smallbuffers
Unknown package 'kmod-ath10k-ct-smallbuffers'.
Collected errors:
 * opkg_install_cmd: Cannot install package kmod-ath10k-ct-smallbuffers.

"opkg update" and retry

1 Like

I immediately installed the full firmware again from scratch, ( with keeping the settings)

Can you send me the commands again? When do I need to do the "update" ?

opkg update
opkg remove kmod-ath10k-ct
opkg install kmod-ath10k-ct-smallbuffers
reboot
2 Likes

Each and every time you do an opkg install, independent of the device you use, independent of the package you want to install.

1 Like

Thanks, it is now installed.
Let's hope the router will stay working now rock solid at least for couple months without a reboot :grinning:

thanks a lot for your excellent support Patrakov!
Also thank you Thomas!

@tmomas probably this (the use of non-smallbuffers driver for Archer C7) needs fixing in the next minor version update anyways. There was another instance of the issue: OOM issues on Archer C7 v5

I have now an uptime of 15 days, and it is still working fine :grinning: :grinning:

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Is there any forecast that the use of non-smallbuffers driver for Archer C7 will be fixed in the next minor version update, so it will work without this workaround?

I did a similar workaround by using the non CT driver.

Unfortunately after 25 days the issue appeared again. So I needed to reboot again to make it work again. For now the uptime is again 26 days, so lets hope it will continue to work.

Is there any forecast that the use of non-smallbuffers driver for Archer C7 will be fixed in the next minor version update, so it will work without the workaround?