What firmware to install on ALFA AP120C-AC?

I think the wiki page for AFLA AP120C-AP is very out of date, both firmware links are broken. The table of firmware downloads for the ALFA AP120C-AP lists a much newer firmware version.

This is honestly about as far as I've gotten. I tried flashing the unit with the openwrt-21.02.1...factory.bin (from the firmware downloads page) using the devices own "Upgrade devices firmware." button, but it rebooted back to factory defaults. :sweat_smile: Glad it's not bricked!

I requested Wiki access so I can update the wiki when I do figure out how to install OpenWrt.

Any advice is welcome. Last time I used OpenWrt was probably 20 years ago. I'm afraid my brain is a little less plastic, but I'm still learning!

  • fEsTiDiOuS

What stock firmware version do you have on this device now?

The Table of Hardware shows the AP120-AC is currently supported on 21.02.1

I was able to download both factory and sysupgrade firmware files.

Ah-Ha! Yes, thank you @pepe2k. -- I found the "Step 2" of the "Locate and Download the OpenWrt Firmware" instructions. Followed the "View/Edit data" link to the Techdata page, where down near the bottom I found "Installation method(s): GUI OEM, see git-commit"

In the git-commit I found an Installation Instructions section that says the factory firmware must first be updated to at least 1.1. My router had version 1.0.3 on it.

I found Alfa's Firmware Downloads and flashed the firmware to FW_AP120C-AC_v1.2_20190521_AP120C_AC.img. It did not automatically refresh the page after updating. For reasons I don't know I had to disconnect my ethernet connection to the router and reconnect before I could once more access the web console. Also, just for fun the default login had changed from root : alfa to root : admin.

Phew! Ok, now I'm going to try flashing OpenWrt again. ... annnd... It didn't work. The device rebooted and still shows up with the Alfa logo and shows firmware v1.2 r2457

Maybe I should try upgrading to the latest official Alfa firmware FW_AP120C-AC_v2.0-r2768_20201202_alfa.img

FYI: syslog output
kernel log output

Yes, please try updating to 2.0 first.
The problem might be outdated bootloader, let me know if that helps, otherwise I will provide you an image with upgraded bootloader.

Awesome! Ok, here goes. Updated to Alfa firmware v2.0 r2768 FW_AP120C-AC_v2.0-r2768_20201202_alfa.img - No problems, was actually very fast upgrade.

Upgrading to openwrt-21.02.1-ipq40xx-generic-alfa-network_ap120c-ac-squashfs-nand-factory.bin ... and failure. Still has the Alfa firmware v2.0 r2768

Kernel Log

@fEsTiDiOuS do you have serial console access to this device and if yes can you provide log from the U-Boot (bootloader)?

You are comparing apples with pears.

Mind that AP120C != AP120C-AC

Anyways, I have now corrected the dataentry of the AP120C to show the correct 18.06.9 download link.


Several websites say there is an RJ45 console port... I have a generic cable... There are also what appears to be debugging contacts, probably JTAG, on the circuit board. Might take me a while to figure this out. Not something I do daily, but yes I think I can.

I have this device here, let me do some tests and I hope to be able to provide you a working solution.

1 Like

Doe! I actually wanted to get the AP120C, so it seems I bought the wrong device. Thank you for pointing this out. I had noticed that the device I had seemed to be using different chips. - I'll still try to get OpenWrt running on this device. Thank you for getting the wiki updated.

Edit: Ha! I didn't buy the wrong one. The item was advertised as the AP120C, but they sent me a AP120C-AC. What a world, what a world.....

I've had no luck with a console cable...

The pads on the board that I thought might be a serial console port: are not. I'm pretty sure it's an unpopulated audio jack. I think the 20 pads in the middle of the board might be a JTAG port.

I've never used JTAG before.

I ordered a set of pin headers and a JTAG, uh, reader? It will be maybe 2-weeks until they arrive.

Forget about the JTAG. Without access to software and configuration files you won't be able to use it... the serial console connector is on the other side of the board (your photo shows the "back", console header, labelled as CONN3, is located on the "top" side). The only problem is the smaller connector pitch size - 2.0 mm, not the usual 2.54 mm:

G -> GND
T -> TX
R -> RX
V -> VCC (do not use)

I will provide you different firmware file in private message (can't share it publicly).


I've been attacking windmills... I was finally successful in connecting to the serial port. I made quite a few mistakes, and learned some lessons, some not for the first time. I wrote about finding the right USB to Serial device on my blog, if anyone cares.

8,N,1,115200, 3.3v (!) logic levels.

Serial Console Output with Firmware v2.0-r2768
uname -a
Linux ap120c-ac 3.14.77 #63 SMP PREEMPT Wed Dec 2 15:18:31 CST 2020 armv7l GNU/Linux

I loaded the firmware you sent; and I had problems connecting to the device afterward. Unfortunately I'm not sure if it was a PEBCAK error, or if something was really wrong. Using the serial console I was able to spam "f" which is supposed to trigger a failback/failsafe state. After that I could connect, and I was able to successfully load the OpenWRT firmware!

Victory! - Now I get to learn how to use OpenWRT. :slight_smile: Time to do some more reading.
Thank you so much for your help!

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.