Alfa AP120C-AC might be a brick

This was me: What firmware to install on ALFA AP120C-AC?

It worked for a little while, then some settings change I made caused it to stop working. (No web interface, no IP static or DHCP)

I have been trying to flash it back to a working state but no joy. How long should a flash and program after a hard reset take?

Fallback reset and load MFG Firmware v2.0

It erases the flash, reprograms the flash, then gives me a message that repeats very quickly saying that it's rebooting the CPU, but the device never reboots. Eventually (10 minutes) I pull the plug and restart it. But it won't boot up. the last message is:

"[ 6.620800] 6Waiting for root device ..."

Here is the full boot-up log from the serial connection.

Any Ideas? Is it a brick?

Somehow your kernel command line has the following twice:

ubi.mtd=rootfs2 rootwait

So it ends up failing. Not sure...

Anyway, do you have serial console access? It should be possible to load some initramfs based image and start over.

1 Like

I am connected to the serial port, I don't know how to interact with the device over serial. The serial terminals I've used so far let me read data, but sending data has been very unsuccessful. I think I sent and 'f' once for fallback, but maybe that was a observational failure.

I am able to enter a fallback firmware flash mode by holding down the reset button and accessing --- Your advice helped I was able to flash an initramfs image from there.

However strangely after doing so I can't communicate with the device over the PoE/LAN port, but if I add a cable to the other LAN port I can enter the OpenWRT configuration.

But something is still very wrong, because I can soft reboot the device, but if I unplug the PoE and hard reset it it won't boot back up again.

Serial output when upgrading to

Serial output when hard rebooting.

Interestingly I tried the newer openwrt-21.02.2 initramfs, and had the same results, with one exception. After changing the system password, and logging out and back in the password change message went away. However after soft rebooting, it once again said that I had not changed the password. A hard reboot produced the same results as above, it just reset itself forever and wouldn't boot.

This error seems to come up all the time even on "successful" boots:

Creating 1 MTD partitions on "nand1":
0x000004000000-0x000008000000 : "mtd=1"
UBI: attaching mtd2 to ubi0
UBI: physical eraseblock size:   131072 bytes (128 KiB)
UBI: logical eraseblock size:    126976 bytes
UBI: smallest flash I/O unit:    2048
UBI: VID header offset:          2048 (aligned 2048)
UBI: data offset:                4096
UBI error: ubi_read_volume_table: the layout volume was not found
UBI error: ubi_init: cannot attach mtd2
UBI error: ubi_init: UBI error: cannot initialize UBI, error -22
UBI init error 22
Not found valid kernel, switch to secondary part
Creating 1 MTD partitions on "nand1":
0x000000000000-0x000004000000 : "mtd=0"
UBI: attaching mtd2 to ubi0

I'm wondering why it always switches to the secondary partition, and if that might be important.

initramfs:es won't survive a reboot, they're supposed to run in RAM only.

1 Like

WO! - Excellent. Ok I loaded the initramfs, then using the web interface loaded the sysupgrade and now it works, and it survives a reboot!

Thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.