Unknown package 'tailscale' - No longer supported?

On 23.05.3, type
opkg update
opkg install tailscale

Unknown package 'tailscale'.
Collected errors:
 * opkg_install_cmd: Cannot install package tailscale.

Is Tailscale no longer available in opkg? (although it is quite outdated version 1.58 though)

1 Like

Seems that there may be build failures or something... it's still supported AFAIK, though.

Something is wrong.


It seems to be missing (in some cases just temporarily) from some platforms and not others. It shows up on my Pi4.

Yes you are right,

I check Index of /releases/23.05.3/packages/aarch64_cortex-a53/packages/ (openwrt.org)

there is no tailscale package,

but in Index of /releases/23.05.3/packages/aarch64_generic/packages/ (openwrt.org)

there is tailscale_1.58.2-1_aarch64_generic.ipk

I did not read your link thinking it was the wiki for tailscale.

There is now ...

1 Like

Yep, it is available now.


tailscale is still missing from https://downloads.openwrt.org/releases/23.05.3/packages/arm_cortex-a15_neon-vfpv4/packages/

Yes, last buildbot package errors

yes there is now~
I will mark this issue solved
but there could be other platform seeing the same problem as others mention.

It looks like it disappeared again for releases/23.05.3/packages/aarch64_cortex-a53/

I was trying to build it for Banana PI BPI-R3 and it failed

Collected errors:
 * opkg_install_cmd: Cannot install package tailscale.
make[2]: *** [Makefile:189: package_install] Error 255
make[1]: *** [Makefile:154: _call_manifest] Error 2
make: *** [Makefile:274: manifest] Error 2

That is weird: I cannot find it, now, either.

i was having problems with the imagebuilder docker image last night, Tons of packages couldnt be found (like uci, lol). but it seems to be working this morning. doubt it matters, but i was trying to build for nanopi r5s. i think it has something to do with the cdn mirrors and host resolution, but does seem temporary.

see here: Docker buildbot fails "opkg_install_cmd: cannotinstall package" - #9 by robot-ranger

Samesies on Raspberry Pi 4

is there any workaround? I'm facing same issue.

Tailscale is available:

Try it in the middle of the night; we have had server congestion issues for a couple weeks.

Maybe we need some donations to upgrade the servers.

Surprise to see the issue is still haunting some users...

Here are two workarounds:

  1. find it from the 23.05.02 packages, they won't be much different.
  2. If still no lucks, try the unofficial ports:
    ImmortalWrt Downloads I have tested the tailscale package is compatible.
    Or this github repo for a smaller tailscale:
    Admonstrator/glinet-tailscale-updater: This script updates the Tailscale installation on GL.iNet routers. (github.com)
1 Like

not for me though.

1 Like

I think it is hit or miss based on server congestion.

So, maybe not 'for you' at this moment.

~0300--0600 EDT is almost dead in the forums on weekdays at those times; of course weekends and holidays are always busy...
Try it later; bear in mind this is a 4 day holiday in the US so Monday through Tuesday night/morning would be my best suggestion.

:spiral_notepad: That edit I made would not show until I refreashed the page, so I presume there is server congestion right now.

1 Like