Tailscale on TP-Link ER605 - No Package Showing

Having recently installed 23.05.3 onto a new ER605, I am testing some of my basic requirements, one of which is to run tailscale.
After updating the package list it seems tailscale is just not in there.

opkg install tailscale
Unknown package 'tailscale'.

I am aware that on storage constrained devices with 16M or less available that tailscale won't run as it just won't fit (even though the current ipk shows only around 10Mb once installed on some of my other devices). I have experienced this with some other devices (like my MR6400). However, the ER605 has 100Mb storage (currently reporting 99Mb free), so I don't think the package would be missing due to this constraint.
I can of course try to install it directly via other means, but I also wanted to understand why tailscale was not in the package list and also why it will differ between routers? (My AC88U has tailscale in its package list is also 23.05.3 and has 100M storage)
Are there any other factors which would prevent tailscale from showing in the package list on this device?

did you update the packages first?

opkg update
opkg install tailscale
1 Like

Yes, I had updated the package list first with the opkg update. I had also tried it via luci. All the packages update, but it is simply not in the package list. Looking from luci, I see (after update) there are 7181 packages available on my ER605. Doing the same on my AC88U also running 23.05.3 I see 7200 packages available. Clearly some are missing (including tailscale) and I'd like to understand why there is a difference between models with identical versions.

let's start with this... show us the output of:

ubus call system board
cat /etc/opkg/distfeeds.conf
opkg update
opkg list | grep tailscale

Sure:

root@ER605-OpenWRT:~# ubus call system board
{
        "kernel": "5.15.150",
        "hostname": "ER605-OpenWRT",
        "system": "MediaTek MT7621 ver:1 eco:4",
        "model": "TP-Link ER605 v2",
        "board_name": "tplink,er605-v2",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "ramips/mt7621",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}
root@ER605-OpenWRT:~# cat /etc/opkg/distfeeds.conf
src/gz openwrt_core https://downloads.openwrt.org/releases/23.05.3/targets/ramips/mt7621/packages
src/gz openwrt_base https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/base
src/gz openwrt_luci https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/luci
src/gz openwrt_packages https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/packages
src/gz openwrt_routing https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/routing
src/gz openwrt_telephony https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/telephony
root@ER605-OpenWRT:~# opkg update
Downloading https://downloads.openwrt.org/releases/23.05.3/targets/ramips/mt7621/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_core
Downloading https://downloads.openwrt.org/releases/23.05.3/targets/ramips/mt7621/packages/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/base/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/base/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/luci/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/packages/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/routing/Packages.sig
Signature check passed.
Downloading https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading https://downloads.openwrt.org/releases/23.05.3/packages/mipsel_24kc/telephony/Packages.sig
Signature check passed.
root@ER605-OpenWRT:~# opkg list | grep tailscale
root@ER605-OpenWRT:~#

(no result)

It is in the repo....

https://downloads.openwrt.org/releases/23.05.3/packages/mips_24kc/packages/tailscale_1.58.2-1_mips_24kc.ipk

what do you get when you run:

opkg list | wc
root@ER605-OpenWRT:~# opkg list | wc
     9810    184623   1386381

That seems fine, from what I can tell. My Pi4 has a value of 9954 -- that probably has to do with the difference in platform.

what happens if you try to install via the direct link I provided above and/or downloading that first with wget?

From luci, I paste in "https://downloads.openwrt.org/releases/23.05.3/packages/mips_24kc/packages/tailscale_1.58.2-1_mips_24kc.ipk" into the "Download and install package" box. It says: " Manually install package

Installing packages from untrusted sources is a potential security risk! Really attempt to install *https://downloads.openwrt.org/releases/23.05.3/packages/mips_24kc/packages/tailscale_1.58.2-1_mips_24kc.ipk*?" and I click "install".
Almost immediately it comes back with " Unable to execute opkg install command: PermissionError: Exec permission denied".

I will also try with wget via ssh. What's the syntax needed to install the package after download that way?

cd /tmp
wget https://downloads.openwrt.org/releases/23.05.3/packages/mips_24kc/packages/tailscale_1.58.2-1_mips_24kc.ipk
opkg install /tmp/tailscale_1.58.2-1_mips_24kc.ipk
1 Like
root@ER605-OpenWRT:~# cd /tmp
root@ER605-OpenWRT:/tmp# wget https://downloads.openwrt.org/releases/23.05.3/pac
kages/mips_24kc/packages/tailscale_1.58.2-1_mips_24kc.ipk
Downloading 'https://downloads.openwrt.org/releases/23.05.3/packages/mips_24kc/packages/tailscale_1.58.2-1_mips_24kc.ipk'
Connecting to 151.101.2.132:443
Writing to 'tailscale_1.58.2-1_mips_24kc.ipk'
tailscale_1.58.2-1_m 100% |*******************************|  8062k  0:00:00 ETA
Download completed (8256272 bytes)
root@ER605-OpenWRT:/tmp# opkg install /tmp/tailscale_1.58.2-1_mips_24kc.ipk
Unknown package 'tailscale'.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for tailscale found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package tailscale.

ah, had missed putting it in /tmp - thanks.
Seems it doesn't like the architecture - had not expected that.

oh... my bad... I did give you the wrong architecture....
one moment please...

Ok... so I must eat my words...
It's not in the repo for some reason. I'm not seeing it for that architecture at all for anything 23.05. It is there in 22.03 (but package that won't work with a 23.05 installation).

So, you're right... it's missing. I don't know why.

Thanks for your assist on this so far. I wonder why its missing too.

This would also explain why it's missing for my TP-Link MR6400, as this is also of the same ramips architecture. If it worked on 22.03, it must be possible to work on ramips, I guess it may be that it's just not been updated for this version. Any ideas where I could start enquiries on this?

It is available on other platforms (like the two devices I checked - pi4 and routerstation pro) for 23.05. This suggests that maybe there was a build failure for the package on the platform in question.

It's also not available for mvebu/cortexa9 (vfpv3-d16) . =(
But the weird thing is -- it was available before.
I installed it normally via opkg a few weeks ago in my mom's router; I havent updated anything on that OpenWrt, and yesterday I messed up some tailscale configs and thought it was best to reinstall & start clean again, but now I can't install anymore.

Do you know if there's someplace we should, idk, 'report' this?

I'll move this to the developers section.... maybe one of the devs has some info.

2 Likes

@r5e, @ViniciusMR

seems the package is available again.

Edit:

Issues with packages are usually reported here:
https://github.com/openwrt/packages/issues/

2 Likes