Unable to access via external despite port forwards

I've been having a heck of a time trying to figure this out with OpenWRT and port forwards. Basing on a couple hours of searching, it appeared to be straight forward just like most other things, but boy was I proven wrong on that.

I've known about OpenWRT for a long while now, and I would have used it before had my router (an ASUS RT-87U) been supported for wireless capabilities. However, that was not the case, so I had to pass on it for now due to ASUS (and consequently Merlin) dropping full support of my router. Then it recently decided to want to reboot 2-3 times a day on its own and well, had to get a new router sent to me. Enter the Linksys EA7300 v1 that I'm using now that a friend of mine sent me. (installing OpenWRT on it was quite the chore...)

Alright, so I did all my configurations for getting network set, get some static DHCP going to make it easy to port forward, and get all that configured. I'll post a couple images of my current configs:

Where I'm stuck is the fact that right now, the two I'm most concerned about are Plex and my VNC ports for the desktop specifically. (in this case, the IP is, the laptop I'll worry about later) I've also been through this topic: Port Forwarding and Plex - am I missing something? - to see if there was anything I missed. I tried some stuff in this topic but to no avail, I can not access Plex externally at all. (same goes for VNC) Currently, the way I'm checking is simply to use my external IP I've set with a DNS A Record through my domain, and I've already double-checked those settings and my public IP is correct to the DNS records.

I've read some other things about using I think it's tcpdump or something, not sure. I have not used it yet, and while I'm not a stranger to Linux and CLI stuff, I do sometimes need a guiding hand on those at times.

About the only thing I didn't try in the topic previously mentioned was adding the plex.direct domain to a whitelist, but I couldn't find that in the settings on the interface. Considering the topic was originally from 2019, I guess the LuCI UI may have changed slightly since then. My current version of the firmware is as follows:

Right now I'm at a loss, and I do somewhat frequently remote into my system when I'm not at home. And then I have a friend or two that has access to my Plex that worked fine previously on the ASUS router, but it seems on OpenWRT with the Linksys, I can't seem to figure out the port forwarding.


maybe your WAN IP is not a public IP ?
maybe it is CGNAT or some other ISP "magic" to provide you internet access

best way to check is to open this site

and then look at LuCI status for WAN interface

two address need to be same

If I'm understanding right, I went into Network > Interfaces to double check and the IPv4 is most certainly not the public IP. I have an AT&T provided gateway for fiber internet, and I've set the settings on the gateway to a Passthrough mode so that the router can handle the majority of my traffic. Beyond that, I'm not sure what to do right now.

After spending some time away, watch a bit of anime, I decided to dig some more into some settings. I went into the AT&T Fiber Gateway and looked more into the IP Passthrough options, and as it turns out, I guess I didn't set the DHCP-fixed to the right device or something, so I set it to DHCP-Dynamic instead so it picks up the first client to ask for a DHCP lease.

I figured I'd update on that at least. I checked the network interface and it was indeed showing the correct IP this time around.

so, your WAN address in Luci is same as address from


It wasn't before, it was showing as I showed in the image previously. After I changed the setting in the AT&T Gateway, rebooted the router, now it shows my external IP. (and yes, I have rebooted the router a couple times before to no avail)

My port forwards are working as intended now.


if your problem is solved
please mark the answer as solution, and topic as [solved]

1 Like