Port Forwarding and Plex - am I missing something?

Here's my port forwarding screen on my OpenWRT router (BT Homehub 5):

image

Plex is set to : Private 192.168.1.2 : 32400 > Public (myIP address) : 50500 Internet

Despite this canyouseeme.org says port 50500 is not open (connection refused). What am I missing? Thanks for your help :slight_smile:

Is the Plex configured to accept connections, from a device outside the LAN, on that port?

Plex recommends using a port between 20000-50000, so you might try one in that range (along with @eduperez suggestion ) .

https://support.plex.tv/articles/200931138-troubleshooting-remote-access/
Plex suggests UPNP / NAT-PMP

I use manual port forwarding for my Plex server so it should work. Also, you might need to add plex.direct to Domain whitelist in Luci>Network>DHCP and DNS>General Settings.

UPNP installed, plex.direct added to domain whitelist in DHCP and DNS general settings, and I've changed the manually specified port to 40,000. Still canyouseeme.org thinks port 40,000 is open, and UPNP doesn't appear to be pickup up plex either.

So far as "Is the Plex configured to accept connections, from a device outside the LAN, on that port" is concerned, I've checked windows firewall and it has been added as an exception.

Any other ideas? Thanks.

EDIT: Rebooted the router, it briefly decided the port was open, and then it changed its mind again. My head hurts, off to bed, night.

If upnp is installed you don't need to manually specify a port, you can just let Plex choose.

Just wanted to chime in that I'm running plex on a server on my LAN and have remote access working fine with nothing but UPNP in place on my openwrt box

One thing to note: I had to ensure that my DNS returned the LAN address for my server to internal clients, rather than the internet IP of the router, otherwise data tromboned through the router for those local clients. The joys of NAT, eh?

%E6%93%B7%E5%8F%96

quite a big range but it works for me, but in Plex app, it still shows no connection to internet but I can watch movie on my phone with 4G connection.

You only need to forward port 32400 from your WAN interface to your Plex. Manually adding the port forward is much better than using UPnP as there's a bug in the current version of Plex Media Server that causes 100% CPU utilisation if minupnpd is running on the LAN.

besides everything said in this topic I needed additionally to allow "dns reverse lookup to be forwarded" just like in the picture! Otherwise plex would show green and accessible for like 10 seconds then turns red and inaccessible.

so summing up, you need to:

Disable DNS rebind protection;
Disable DNS Filter Private (allow dns reverse lookup to be forwarded);
Either manually open port 32400 to your device or install and activate UPNP on your router.