Ubnt-erx Error Updating from 19.07.7 to 21.02.1


I got the following message when updating, via lucy, from 19.07.7 to 21.02.1

Device ubnt-erx not supported by this image Supported devices: ubnt,edgerouter-x ubnt-erx ubiquiti,edgerouterx - Image version mismatch: image 1.1, device 1.0. Please wipe config during upgrade (force required) or reinstall. Reason: Config cannot be migrated from swconfig to DSA Image check failed.

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

What should I do?

Thank you

Force install without keeping settings and reconfigure from scratch.

And if ER-X did not come back up after flashing, hold down the reset button for 30 seconds.

See my own thread on this. Hopefully, this was just a 21.02.0 thing.

Should we be using the 'initramfs-factory > sysupgrade' method instead of upgrading with just sysupgrade for the 19-to-21 jump on this router?

Another one. You might want to hold off the upgrade.

1 Like

I think I Will wait.
I do not want to lost my settings. Many time spent there.

With this guide, you can make a backup archive of your router. You can then either restore the backup archive back to the router or open up the backup archive tar file and read the configuration files in there. Note that, by default, it will not back up your additional packages you added either via Luci or opkg in ssh. You must follow step #1 in the guide for that.

That 'another one' link in my previous reply has marked his topic as solved. It seems he has answered my 'initramfs-factory > sysupgrade' method question.

Restoring a 19.07 network configuration on an 21.02 installation will most likely lead to a soft brick, due to the DSA conversion.


About Backup and Restore link, I think all my setups are included in the backup, because the list under configuration menu charges all the submenus of lucy.
I restored some backups in the past and they always loaded the custom setup.
Isn´t it?
@jow , Is it possible that the problem would be solved soon?

I don’t think so. You need to manually redo your network configuration eventually.

1 Like

ok, I will do so.
@jow ,Where you say "Force install without keeping settings" you mean using terminal with "sysupgrade -F" comand?
Thank you

sysupgrade -F -n file

Do not keep config.

But if the issue is only the DSA conversion you may be able to just set aside the network config and proceed. Whether on the device itself, or in a backup / restore.