Trouble installing on MikroTik hAP AC (RB962UiGS-5HacT2HnT)


I've been trying to get OpenWrt on hAP AC. I followed the instructions outlined here. I am using a device running pfSense as my gateway. All the necessary services are running and configured (dhcpd and tftpd). I have added LAN firewall rules to allow port 69 (TFTP) traffic to be safe.

When I try to boot from TFTP using the rb-nor-flash-16M-ac-initramfs-kernel.bin file, the device appears to be "stuck" for a few minutes, then reboots into RouterOS. During the time that it is "stuck", it has successfully acquired a DHCP lease from the server (I assigned it a static lease since I noticed before that it was requesting repeatedly).

I'm not sure what else to try at this point, there is very little documentation on how to get OpenWrt on this device. I should note that I am using the US version of this device. Could it be that OpenWrt cannot be installed on the US version?


RouterBoards can boot OpenWrt .elf images with initramfs via TFTP. This is first used to validate that the desired version of OpenWrt works and then to install OpenWrt onto NAND Flash from the shell of the running initramfs OpenWrt.

why are you trying to tftp the .bin image when the page you link to states .elf image via tftp?

To be fair, I missed that detail. However, I made the decision to use the .bin based on others' experiences described in this post and this one. It seems both of these users were able to use the .bin file, and in fact needed to in order to get proper 5 GHz functionality.

Perhaps I should try booting from the .elf and then flashing the .bin?

Please try elf and then bin, that's how I flashed my hap lite, rb951ui, rb951g, map lite, hap ac2, rb750up and cap2n.


1 Like

I have tried doing this with no success. I also added LAN outbound NAT rules to be extra safe. Also tried using BOOTP protocol instead of DHCP.

The hAP AC is unresponsive for about 5 minutes before automatically rebooting into RouterOS. During this time it is assigned according to my static DHCP rule, but no device on the network can ping it. I noticed in pfSense's state tables, it shows entries from the pfSense device to the hAP AC, with each state labeled as SINGLE:NO_TRAFFIC. There is one state from the hAP AC to pfSense on port 69 labeled NO_TRAFFIC:SINGLE.

Not sure what else I can try here :confused:

I'll take that back - I was able to boot and flash OpenWrt. The problem apparently was pfSense wasn't properly serving the file when the router tried to network boot. I set up a TFTP server on another device in the network and the router successfully booted from that, and I was able to flash afterwards.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.