Tracking down regression - LED CF-E538AC

I have created a set of patches against 19.07.4 to add support for a Comfast CF-E538AC.
When testing I could not see any issues, all functions are available.

I then ported the patches to master and cannot find out why the LED (and reset button) do not work.

The DTS file is an exact copy, but in master I get this error that does not pop up in 19.07.4

[    4.602000] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.968530] rt2880-pinmux pinctrl: pin 13 is not set to gpio mux
[    4.974747] rt2880-pinmux pinctrl: request() failed for pin 13
[    4.980723] rt2880-pinmux pinctrl: pin-13 (pio:13) status -22
[    4.986605] gpio-keys-polled keys: unable to claim gpio 13, err=-22
[    4.993029] gpio-keys-polled: probe of keys failed with error -22
[    5.001651] rt2880-pinmux pinctrl: pin 72 is not set to gpio mux
[    5.007880] rt2880-pinmux pinctrl: request() failed for pin 72
[    5.013849] rt2880-pinmux pinctrl: pin-72 (pio:72) status -22
[    5.019746] leds-gpio: probe of leds failed with error -22

Also the LED device is not being created

19.7.04:
/sys/class/leds
cf-e538ac:white:wifi
mt76-phy0                rt2800soc-phy1::quality
rt2800soc-phy1::assoc    rt2800soc-phy1::radio
Master:
/sys/class/leds
mt76-phy0                rt2800soc-phy1::quality
rt2800soc-phy1::assoc    rt2800soc-phy1::radio

Please pay attention that pinctrl syntax was changed.
So this code in openwrt 19.07

&pinctrl {
	state_default: pinctrl0 {
		gpio {
			ralink,group = "uartf", "nd_sd", "wled";
			ralink,function = "gpio";
		};
	};
};

need to be changed to

&state_default {
	gpio {
		groups = "uartf", "nd_sd", "wled";
		function = "gpio";
	};
};

for current master branch.

2 Likes

@123serge123 Thank you so very much! I compared the dts file with others from master but never noticed that mine still was using ralink, group.
All good - now I just have to confirm that I didn't mess up anything else while testing and can submit the patches to hopefully add that device to openWRT

1 Like

Hello,

I'm interested in support this device too (I saw your patch just before the device arrived to me). Let me know if I can help you with something.

BR,
ValentĂ­n

@vk496 - If you feel adventurous, you can try the firmware, BUT please ensure that you have serial access to recover the firmware via u-boot.

I selected a random sharing platform to upload test.bin (link expires in 30 days - around 20/12/2020):

Stock firmware available here:


Direct download link (it was only single digits kb/s coming from china):
http://dl.comfast.cn/firmware/CF-E538AC-V3.0.rar

Hello,

Thank you. I could flash the firmware trough OEM webinterface without problems (rebooted to OpenWrt with LUCI).

Here are all the things I could test:

  • LED works correctly. However, there are multiple options (mt76-phy0, rt2800soc-phy1::asoc, rt2800soc-phy1::quality, rt2800soc-phy1::radio, white:wifi). The last one is associated to the whit LED

  • Not all space is used (should be 8MB, no?). Problem with the mtd layout definition?

Filesystem                Size      Used Available Use% Mounted on
/dev/root                 3.0M      3.0M         0 100% /rom
tmpfs                    28.7M    236.0K     28.5M   1% /tmp
tmpfs                    28.7M     56.0K     28.7M   0% /tmp/root
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock6            2.9M    176.0K      2.7M   6% /overlay
overlayfs:/overlay        2.9M    176.0K      2.7M   6% /

And half of the RAM is used for /tmp. I supose is the default behaviour

  • The default VLAN config is in the reverse order. Port 2 should be untagged for WAN instead for LAN

And LAN interface is bridged with eth0. I think it should be with eth0.1

  • Wifi works corretly. 2ghz and 5ghz seems to be stable.

  • A dmesg during all the tests. For the case

[    0.000000] Linux version 5.4.75 (user@OpenWRT-build) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r14926-41b867165d)) #0 Thu Nov 12 17:21:55 2020
[    0.000000] Board has DDR2
[    0.000000] Analog PMU set to hw control
[    0.000000] Digital PMU set to hw control
[    0.000000] SoC Type: MediaTek MT7620A ver:2 eco:6
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019650 (MIPS 24KEc)
[    0.000000] MIPS: machine is Comfast CF-E538AC
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000]   Normal zone: 144 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16384 pages, LIFO batch:3
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 16240
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes, linear)
[    0.000000] Writing ErrCtl register=00035990
[    0.000000] Readback ErrCtl register=00035990
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 57568K/65536K available (4581K kernel code, 204K rwdata, 1020K rodata, 1228K init, 205K bss, 7968K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 256
[    0.000000] random: get_random_bytes called from start_kernel+0x32c/0x518 with crng_init=0
[    0.000000] CPU Clock: 580MHz
[    0.000000] clocksource: systick: mask: 0xffff max_cycles: 0xffff, max_idle_ns: 583261500 ns
[    0.000000] systick: enable autosleep mode
[    0.000000] systick: running - mult: 214748, shift: 32
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
[    0.000010] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
[    0.007591] Calibrating delay loop... 385.02 BogoMIPS (lpj=770048)
[    0.045490] pid_max: default: 32768 minimum: 301
[    0.050173] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.057232] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.071385] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[    0.080866] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
[    0.087562] pinctrl core: initialized pinctrl subsystem
[    0.093233] NET: Registered protocol family 16
[    0.359737] PCI host bridge /pcie@10140000 ranges:
[    0.364353]  MEM 0x0000000020000000..0x000000002fffffff
[    0.369412]   IO 0x0000000010160000..0x000000001016ffff
[    0.397960] rt2880_gpio 10000600.gpio: registering 24 gpios
[    0.403439] rt2880_gpio 10000600.gpio: registering 24 irq handlers
[    0.409774] rt2880_gpio 10000660.gpio: registering 32 gpios
[    0.415202] rt2880_gpio 10000660.gpio: registering 32 irq handlers
[    0.421540] rt2880_gpio 10000688.gpio: registering 1 gpios
[    0.426888] rt2880_gpio 10000688.gpio: registering 1 irq handlers
[    0.433621] PCI host bridge to bus 0000:00
[    0.437604] pci_bus 0000:00: root bus resource [mem 0x20000000-0x2fffffff]
[    0.444227] pci_bus 0000:00: root bus resource [io  0xffffffff]
[    0.449975] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.456566] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.464305] pci 0000:00:00.0: [1814:0801] type 01 class 0x060400
[    0.470125] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    0.476185] pci 0000:00:00.0: reg 0x14: [mem 0x20200000-0x2020ffff]
[    0.482346] pci 0000:00:00.0: supports D1
[    0.486169] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    0.493846] pci 0000:01:00.0: [14c3:7662] type 00 class 0x028000
[    0.499730] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit]
[    0.506314] pci 0000:01:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[    0.512897] pci 0000:01:00.0: PME# supported from D0 D3hot D3cold
[    0.520638] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    0.527043] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 01
[    0.533469] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    0.539865] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    0.546627] pci 0000:00:00.0: BAR 8: assigned [mem 0x20000000-0x200fffff]
[    0.553227] pci 0000:00:00.0: BAR 9: assigned [mem 0x20100000-0x201fffff pref]
[    0.560239] pci 0000:00:00.0: BAR 1: assigned [mem 0x20200000-0x2020ffff]
[    0.566841] pci 0000:01:00.0: BAR 0: assigned [mem 0x20000000-0x200fffff 64bit]
[    0.573952] pci 0000:01:00.0: BAR 6: assigned [mem 0x20100000-0x2010ffff pref]
[    0.580946] pci 0000:00:00.0: PCI bridge to [bus 01]
[    0.585764] pci 0000:00:00.0:   bridge window [mem 0x20000000-0x200fffff]
[    0.592352] pci 0000:00:00.0:   bridge window [mem 0x20100000-0x201fffff pref]
[    0.599472] workqueue: max_active 576 requested for napi_workq is out of range, clamping between 1 and 512
[    0.614739] clocksource: Switched to clocksource systick
[    0.621325] NET: Registered protocol family 2
[    0.626467] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
[    0.634618] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.642026] TCP bind hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.648869] TCP: Hash tables configured (established 1024 bind 1024)
[    0.655185] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.661540] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.668593] NET: Registered protocol family 1
[    0.672874] PCI: CLS 80 bytes, default 32
[    0.679859] rt-timer 10000100.timer: maximum frequency is 1220Hz
[    0.688084] workingset: timestamp_bits=14 max_order=14 bucket_order=0
[    0.702791] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.708404] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.736350] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
[    0.743763] printk: console [ttyS0] disabled
[    0.747976] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 20, base_baud = 2500000) is a Palmchip BK-3103
[    0.757592] printk: console [ttyS0] enabled
[    0.766062] printk: bootconsole [early0] disabled
[    0.781899] spi spi0.0: force spi mode3
[    0.796313] spi-nor spi0.0: s25fl064k (8192 Kbytes)
[    0.801363] 4 fixed-partitions partitions found on MTD device spi0.0
[    0.807857] Creating 4 MTD partitions on "spi0.0":
[    0.812765] 0x000000000000-0x000000030000 : "u-boot"
[    0.818955] 0x000000030000-0x000000040000 : "u-boot-env"
[    0.825424] 0x000000040000-0x000000050000 : "factory"
[    0.831729] 0x000000050000-0x000000800000 : "firmware"
[    0.841555] 2 uimage-fw partitions found on MTD device firmware
[    0.847683] Creating 2 MTD partitions on "firmware":
[    0.852771] 0x000000000000-0x0000001d98b5 : "kernel"
[    0.858998] 0x0000001d98b5-0x0000007b0000 : "rootfs"
[    0.865029] mtd: device 5 (rootfs) set to be root filesystem
[    0.872736] 1 squashfs-split partitions found on MTD device rootfs
[    0.879143] 0x0000004c9000-0x0000007b0000 : "rootfs_data"
[    0.886618] libphy: Fixed MDIO Bus: probed
[    0.900630] gsw: setting port4 to gmac mode
[    0.905442] libphy: mdio: probed
[    0.910825] mtk_soc_eth 10100000.ethernet: connected port 4 to PHY at mdio-bus:04 [uid=001cc916, driver=Generic PHY]
[    0.921867] mtk_soc_eth 10100000.ethernet: connected port 5 to PHY at mdio-bus:05 [uid=001cc916, driver=Generic PHY]
[    0.932858] mtk_soc_eth 10100000.ethernet: loaded mt7620 driver
[    0.939639] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
[    0.948661] rt2880_wdt 10000120.watchdog: Initialized
[    0.955398] NET: Registered protocol family 10
[    0.965310] Segment Routing with IPv6
[    0.969293] NET: Registered protocol family 17
[    0.973924] 8021q: 802.1Q VLAN Support v1.8
[    0.995932] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[    1.010094] Freeing unused kernel memory: 1228K
[    1.014747] This architecture does not have kernel memory protection.
[    1.021321] Run /sbin/init as init process
[    1.206697] random: fast init done
[    2.681975] init: Console is alive
[    2.685878] init: - watchdog -
[    4.602439] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.972419] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    4.982209] init: - preinit -
[    6.882806] random: jshn: uninitialized urandom read (4 bytes read)
[    6.975969] random: jshn: uninitialized urandom read (4 bytes read)
[    7.134376] random: jshn: uninitialized urandom read (4 bytes read)
[    8.038950] 8021q: adding VLAN 0 to HW filter on device eth0
[    8.111864] urandom_read: 4 callbacks suppressed
[    8.111873] random: procd: uninitialized urandom read (4 bytes read)
[    8.767713] mount_root: jffs2 not ready yet, using temporary tmpfs overlay
[    8.779661] urandom-seed: Seed file not found (/etc/urandom.seed)
[    8.897456] procd: - early -
[    8.900712] procd: - watchdog -
[    9.097014] procd: - watchdog -
[    9.100603] procd: - ubus -
[    9.291343] random: ubusd: uninitialized urandom read (4 bytes read)
[    9.299729] random: ubusd: uninitialized urandom read (4 bytes read)
[    9.314921] procd: - init -
[   10.522115] kmodloader: loading kernel modules from /etc/modules.d/*
[   10.791205] Loading modules backported from Linux version v5.8-0-gbcf876870b95
[   10.798665] Backport generated by backports.git v5.8-1-0-g79400d9e
[   10.868393] xt_time: kernel timezone is -0000
[   10.901361] urngd: jent-rng init failed, err: 2
[   11.047700] mt76x2e 0000:01:00.0: card - bus=0x1, slot = 0x0 irq=4
[   11.054384] mt76x2e 0000:01:00.0: ASIC revision: 76120044
[   11.131691] mt76x2e 0000:01:00.0: ROM patch build: 20141115060606a
[   11.143912] mt76x2e 0000:01:00.0: Firmware Version: 0.0.00
[   11.149591] mt76x2e 0000:01:00.0: Build: 1
[   11.153797] mt76x2e 0000:01:00.0: Build Time: 201507311614____
[   11.165098] mt76x2e 0000:01:00.0: Firmware running!
[   11.172790] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   11.262571] PPP generic driver version 2.4.2
[   11.270856] NET: Registered protocol family 24
[   11.337183] rt2800_wmac 10180000.wmac: loaded eeprom from mtd device "factory"
[   11.344595] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 6352, rev 0500 detected
[   11.352543] ieee80211 phy1: rt2x00_set_rf: Info - RF chipset 7620 detected
[   11.359724] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[   11.452633] kmodloader: done loading kernel modules from /etc/modules.d/*
[   20.329524] random: crng init done
[   41.717536] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[   41.733688] jffs2_build_filesystem(): unlocking the mtd device... 
[   41.733771] done.
[   41.742094] jffs2_build_filesystem(): erasing all blocks after the end marker... 
[   42.412046] 8021q: adding VLAN 0 to HW filter on device eth0
[   42.471567] br-lan: port 1(eth0.2) entered blocking state
[   42.477169] br-lan: port 1(eth0.2) entered disabled state
[   42.483101] device eth0.2 entered promiscuous mode
[   42.488049] device eth0 entered promiscuous mode
[   47.192119] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   47.208585] br-lan: port 1(eth0.2) entered blocking state
[   47.214155] br-lan: port 1(eth0.2) entered forwarding state
[   47.233129] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   47.545687] mtk_soc_eth 10100000.ethernet eth0: port 4 link up (1000Mbps/Full duplex)
[   76.381041] done.
[   76.383083] jffs2: notice: (1805) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   76.629322] overlayfs: upper fs does not support tmpfile.
[   85.636090] mtk_soc_eth 10100000.ethernet eth0: port 5 link up (100Mbps/Full duplex)
[  131.160005] ieee80211 phy1: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration start
[  131.168726] ieee80211 phy1: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration end
[  133.618533] ieee80211 phy1: rt2800_loft_iq_calibration: Info - LOFT Calibration Done!
[  134.131704] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Start!
[  134.153015] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Done! CH = 0, (gain= 1, phase=3e)
[  134.163258] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Start!
[  134.184555] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Done! CH = 1, (gain= f, phase=3f)
[  134.193914] ieee80211 phy1: rt2800_loft_iq_calibration: Info - TX IQ Calibration Done!
[  134.703445] ieee80211 phy1: rt2800_rxiq_calibration: Warning - Wait MAC Status to MAX !!!
[  135.210482] ieee80211 phy1: rt2800_rxiq_calibration: Info - RXIQ G_imb=2, Ph_rx=-2
[  135.230924] ieee80211 phy1: rt2800_rxiq_calibration: Info - RXIQ G_imb=-1, Ph_rx=3
[  135.289319] br-lan: port 2(wlan1) entered blocking state
[  135.294836] br-lan: port 2(wlan1) entered disabled state
[  135.300705] device wlan1 entered promiscuous mode
[  135.839825] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[  135.846596] br-lan: port 2(wlan1) entered blocking state
[  135.852082] br-lan: port 2(wlan1) entered forwarding state
[  190.745263] br-lan: port 3(wlan0) entered blocking state
[  190.750780] br-lan: port 3(wlan0) entered disabled state
[  190.756646] device wlan0 entered promiscuous mode
[  192.556703] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  192.563538] br-lan: port 3(wlan0) entered blocking state
[  192.569022] br-lan: port 3(wlan0) entered forwarding state
[  387.387434] br-lan: port 4(eth0) entered blocking state
[  387.392855] br-lan: port 4(eth0) entered disabled state
[  387.398741] br-lan: port 4(eth0) entered blocking state
[  387.404144] br-lan: port 4(eth0) entered forwarding state
[  387.411134] device eth0.2 left promiscuous mode
[  387.416041] br-lan: port 1(eth0.2) entered disabled state
[  422.896245] br-lan: port 1(eth0.1) entered blocking state
[  422.901862] br-lan: port 1(eth0.1) entered disabled state
[  422.907911] device eth0.1 entered promiscuous mode
[  422.913188] br-lan: port 1(eth0.1) entered blocking state
[  422.918774] br-lan: port 1(eth0.1) entered forwarding state
[  422.954518] br-lan: port 4(eth0) entered disabled state
[  422.980260] device eth0.1 left promiscuous mode
[  422.984975] device eth0 left promiscuous mode
[  422.989680] br-lan: port 1(eth0.1) entered disabled state
[  423.129471] br-lan: port 1(eth0.1) entered blocking state
[  423.135063] br-lan: port 1(eth0.1) entered disabled state
[  423.141074] device eth0.1 entered promiscuous mode
[  423.146016] device eth0 entered promiscuous mode
[  423.151160] br-lan: port 1(eth0.1) entered blocking state
[  423.156749] br-lan: port 1(eth0.1) entered forwarding state
[  490.826025] device wlan0 left promiscuous mode
[  490.830820] br-lan: port 3(wlan0) entered disabled state
[  491.294031] device wlan1 left promiscuous mode
[  491.298931] br-lan: port 2(wlan1) entered disabled state
[  493.912748] ieee80211 phy1: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration start
[  493.921459] ieee80211 phy1: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration end
[  495.664361] ieee80211 phy1: rt2800_loft_iq_calibration: Info - LOFT Calibration Done!
[  495.676224] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Start!
[  495.697572] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Done! CH = 0, (gain= 0, phase=3e)
[  495.707807] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Start!
[  495.729114] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Done! CH = 1, (gain= 1, phase= 0)
[  495.738471] ieee80211 phy1: rt2800_loft_iq_calibration: Info - TX IQ Calibration Done!
[  495.759972] ieee80211 phy1: rt2800_rxiq_calibration: Info - RXIQ G_imb=2, Ph_rx=-1
[  495.777967] ieee80211 phy1: rt2800_rxiq_calibration: Warning - RXIQ calibration FAIL
[  495.802001] br-lan: port 2(wlan1) entered blocking state
[  495.807504] br-lan: port 2(wlan1) entered disabled state
[  495.813411] device wlan1 entered promiscuous mode
[  495.928380] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[  495.935188] br-lan: port 2(wlan1) entered blocking state
[  495.940652] br-lan: port 2(wlan1) entered forwarding state
[  496.004801] br-lan: port 3(wlan0) entered blocking state
[  496.010326] br-lan: port 3(wlan0) entered disabled state
[  496.016403] device wlan0 entered promiscuous mode
[  496.021482] br-lan: port 3(wlan0) entered blocking state
[  496.026949] br-lan: port 3(wlan0) entered forwarding state
[  496.267030] br-lan: port 3(wlan0) entered disabled state
[  524.661326] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  524.668149] br-lan: port 3(wlan0) entered blocking state
[  524.673636] br-lan: port 3(wlan0) entered forwarding state
[  544.384902] device wlan1 left promiscuous mode
[  544.389686] br-lan: port 2(wlan1) entered disabled state
[  544.497281] device wlan0 left promiscuous mode
[  544.502059] br-lan: port 3(wlan0) entered disabled state
[  547.665924] br-lan: port 2(wlan0) entered blocking state
[  547.671442] br-lan: port 2(wlan0) entered disabled state
[  547.677335] device wlan0 entered promiscuous mode
[  547.732743] ieee80211 phy1: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration start
[  547.741463] ieee80211 phy1: rt2800_rf_self_txdc_cal: Info - RF Tx self calibration end
[  549.575666] ieee80211 phy1: rt2800_loft_iq_calibration: Info - LOFT Calibration Done!
[  549.587571] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Start!
[  549.608902] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Done! CH = 0, (gain= f, phase=3e)
[  549.619145] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Start!
[  549.640457] ieee80211 phy1: rt2800_iq_search: Info - IQCalibration Done! CH = 1, (gain= f, phase=3f)
[  549.649821] ieee80211 phy1: rt2800_loft_iq_calibration: Info - TX IQ Calibration Done!
[  549.671827] ieee80211 phy1: rt2800_rxiq_calibration: Info - RXIQ G_imb=2, Ph_rx=-1
[  549.689822] ieee80211 phy1: rt2800_rxiq_calibration: Warning - RXIQ calibration FAIL
[  549.721469] br-lan: port 3(wlan1) entered blocking state
[  549.726979] br-lan: port 3(wlan1) entered disabled state
[  549.732861] device wlan1 entered promiscuous mode
[  550.454805] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[  550.461683] br-lan: port 3(wlan1) entered blocking state
[  550.467179] br-lan: port 3(wlan1) entered forwarding state
[  556.242877] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  556.249700] br-lan: port 2(wlan0) entered blocking state
[  556.255184] br-lan: port 2(wlan0) entered forwarding state

Things I couldn't test:

  • Gigabit speeds. I only could try with Fast Ethernet.
  • The button

Br,
ValentĂ­n :slight_smile:

@vk496
Thank you for testing this. Could you please check if the MAC address matches the sticker on your box/the stickers that were provided with the device?

I think I found out why the overlay system is only has 2.9MB free space. Looking at this ( https://openwrt.org/docs/techref/flash.layout ) the 8MB are split as:
Root filesystem (3MB)
Kernel (5.2MB[firmware size] - 3MB[root] =~ 2.2MB) - not shown in df command
Overlay 2.9MB

LED - I have not found a way to disable the automatic creation of the LEDs by the module/driver [mt76 + rt2800]

I have now swapped wan/lan in the file "/etc/board.b/02_network" to make the PoE port LAN. I will upload that firmware soon, I just want to make sure that I haven't missed anything.

PS: I also only have a Fast Ethernet PoE switch.

I selected a random sharing platform to upload "test.bin" (default filename for u-boot recovery) (link expires in 30 days - around 23/12/2020):

Only change was to make back port (PoE port) LAN and front port as WAN

Hello,

Ok, make sense for the storage. The snapshots/official builds should be less heavy.

I confirm MAC address corresponds to the device label & box (Wifi mac differs in last digit). Also, RJ45 front port is gigabit capable, as expected to be.

2 days in production and no strange logs or wifi issues. Hope it could be merged in master soon :slight_smile:

Br,
ValentĂ­n :slight_smile:

Thanks for sharing the build!

Why are you interested in using the back port as LAN and the front one as WAN?

The device will only work while powered via PoE and I have now changed it so the configuration is possible with only one Ethernet cable connected.

So in that case, I can still use the WAN port (front port) to connect to my network, right? I am planning to use it as an AP, just like I have it now, but I would like the front port to be available.

Have you already tried Gigabit Ethernet?

I will probably flash your firmware this weekend.

Maybe we should avoid setting WAN at all?

I read suggestions from a OpenWrt Telegram Group (some maintainers there) that for a specific case like this device (mainly for AP repetear/extender), using LAN for both ports would be fine.

Maybe just using a non default IP range (like 192.168.255.0/24) to avoid IP overlapping when it's connected to a OpenWrt with default LAN config...

Br,
ValentĂ­n :slight_smile: