Cannot get more than Fast Ethernet in a Gigabit port

Hello everyone, yesterday I flashed OpenWRT for the first time on my Comfast CF-E538AC, with a community firmware that I found in this forum.

When I flashed it, everything seemed to work fine. I can connect through the WiFi networks and I was able to configure the front port. However, I found out that the "input" port is limited to 100Mbps (as shown in the picture below). ¿Any ideas on how to allow Gigabit connections?

PD: I already checked that my connection is Gigabit and in fact this same setup achieved Gigabit speeds with the stock firmware.

Well they are "allowed" always. But there might be a negotiation issue. Install ethtool and check the supported/advertised values.

opkg update
opkg install ethtool

Thanks for replying! This is what I get when running the tool with my main interface (the one connected to the router). It seems that both the supported and advertised modes support Gigabit.


try disabling auto-neg, and setting it hard to 1gbit.

Something like this

ethtool –s [device_name] speed [10/100/1000] duplex [half/full] autoneg [on/off]

And if that doesn't work - check your cable. Good ones can go bad once moved.
Check it has all 8 coloured wires in the plugs - some cheap cables just use 4.

Obviously, if you have not replaced the cable since it did work on gigabit speeds, maybe it has moved and a wire has broken - check with a good spare.

Because once you've forced it to 1GBit and disabled autoneg, there's a lot more you can do than try a new cable if it still isn't working - unless someone has any other ideas?

edit: whoops sorry frollic - I replied to you instead of OP.
This forum UI is laid out almost the same as one I use for work, so I make that same mistake far too often :frowning:

Thanks for your advices @momo54 @frollic , I will try a different cable today, although it would be very rare that it was the cause, as I did not move any cable recently.

I tried to use the ethtool command with no luck, and I also found that the swconfig utility could also be useful, but it seems that my chip does not allow changing the link speed using that software.

¿Any other suggestion?

ethtool runs on the CPU port driver. The connection from the CPU to the switch is always 1000 Mb. These are on the same chip but logically separate. The switch physical cable ports from the switch side of the chip should run at up to 1000 Mb. swconfig can poll the switch to report the negotiated speed but not change it.

There is some suggestion in the development thread that the "back" Ethernet port hardware is limited to 100Mb-- probably by the way the PoE hardware is wired. Of course if you're using a PoE injector it needs to be gigabit capable.

The back port worked at 1000Mbps with the stock firmware, and the PoE injector that I am using is Gigabit capable because it worked before.

So I should just wait until the support for Gigabit on OpenWRT is implemented for the back port of my switch, right?

Even though it's old, you could always try mii-tool instead

I finally switched cables and it is working fine now. I really do not know how this could happen, I did not move the AP after flashing OpenWRT. Anyway thanks for helping me!

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.