[Solved] PoE WAN on eth1 looses IP when disconnecting eth0 - IXP425


I have a Titan Wireless TW-533-4 (Intel IPX425) running 17.04.1 (https://openwrt.org/toh/zinwell/zw4400). It has two Fast Ethernet ports: eth0 (LAN) and eth1 (WAN).

I have an odd issue that if I unplug the LAN, my WAN no longer possesses an IP Address, and therefore my wireless LAN cannot reach the Internet.

I'm not sure if this is some protection for the Power-over-Ethernet, as I can't connect eth1 directly to an Atheros switch port in another device, without the 'circuit breaker' cutting the board off...perhaps 0 must always be connected before 1???

The log states when unplugging eth0 (relevant entries):

  • Network device 'eth1' link is down
  • connectivity loss on interface wan
  • eth1 link down
  • lastly: eth0 link down
  • then: DHCP packet received on eth1 which has no address

Any ideas?

EDIT: I also notice that, if I use eth1 for the PoE and I disconnect the Ethernet side of the jack, eth1 remains up and frozen in OpenWRT (Tx with no Rx). I believe this might be a circuit breaker issue. I discovered this because I had to use the PoE adapter in order to connect to an upstream Atheros switch.

Update: It seems it is a ciruit breaker.

Port 0 must always be connected and up (both power and Ethernet) for port 1 to work, so I made WAN eth0 for the needed scenario.

Also, I tried to move them by tagging the WAN as VLAN eth0.5 (random) and making eth1 the LAN port bridged to eth0; but then eth1 was still off (could not yet plug in the Atheros to eth0's PoE port), and hence no bridge, and no LAN WiFi...so then I could only access the board by the LAN's Link Local IPv6 address on eth0 (IPv6 saved me using the serial cable or accessing its bootloader). I did not get IPv4 on eth0. I did see DHCP requests for the VLAN, though. I should have edited the changes in LuCI, reviewed them, then hit 'Save and Apply'.