TP-Link TL-WR841N(D), WA701N(D), WR740N(D), WR741N(D), WR743N(D), WR940N, WR941N(D) - LADUS / JULIA / Ultra Lite / VPN builds


#143

Update:
After that one time where my router's CPU usage spiked and it hanged after 12hours of uptime it has yet to happen again i did restart the router a couple of times after that (Not because of the firmware but because I was, in general, having issues with my internet found out it was an issue on the ISP's side) and now it has been up for ~3 hours.

Edit:
Would help if someone else with an 841n V8,9 could use ultralite V2 and report back on this issue. it could have been just a one-time thing this time around or I don't know maybe it's because this is an old router.


#144

Hello @hmd61551.

Are you planning update JULIA or LADDUS build?

Thanks.
Juliano


#145

I've had this problem with my TP-Link TL-WR841N v7 on other build of LEDE. I'm now running ultralite V2 and it seems way better, but sometimes the WIFI drops across my devices and it seems cpu usage jumps a bit. Maybe it's something with LEDE itself, since I've had this problem with other build. (Build for TP-Link TL-WR841N(D) [all versions])
Edit:
In the other build it was terribly worse, I could see ssl service use a lot of cpu and LuCI would timeout a lot, but in ultralite v2 I can't tell if something is out of order besides what I said.


#146

Well, things seem to be getting worse... right now I was about to play a match of CSGO where when I got into a match I experienced 20-60% packet loss, unplayable. then after checking the router page CPU usage seemed fine too. but when I disabled SQM Packet loss went to 0-3% but now ping was ~300ms instead of the usual 140ms that I get. had to leave the game mid match to check up on my router, this was just 15 minutes ago. currently trying to figure out what is the issue.

P.S
Also tried rebooting my modem, router,pc multiple times issue still persists.

P.P.S
My ISP also seems to be having issues and I suspect my ISP could be the cause of my ping spikes as for the packet loss I think it might be SQM, No matter how low I set the bandwidth too they still happen. Come to think of it I've had 0-3% packet loss for the past week.


#147

I tried it on the WR841 V10 and it is much more responsive now(UI)!!, I didnt experience the total hangs I would get with the other builds. However under extreme load (1 device doing speedtest another downloading torrent and another watching youtube 4k ) with SQM enabled the router would hang and will not access the UI for a while I guess High CPU usage again. But overall much better.
Soon I will try it on the WR841V4 but as of now the LADDUS build (with everything disabled only SQM enabled) is quite stable and not experiencing this CPU spike issues.
Again thanks for your awesome work!!


#148

Today I flashed the Ultra Lite V2 on my WR841N V8 and it has been running smoothly. I haven't enabled SQM and I didn't notice any high CPU usage yet. It has been 8 hours and everything seems to be running fine.


#149

So update...
Looks like the so called SQM issue that I thought was actually an issue with my ISP (still is) as I went back to OpenWRT BB to check if it was LEDE but no still same results at night time. Decided to try gargoyle too as for why not and pretty much the same story would still get packet loss. however, it's down to 1-20 packet loss in spikes instead of 40-60 packet loss constant.

This leaves me to believe it was indeed an issue on the ISP's end will flash back to LEDE tomorrow as I finally got a bit free time as for SQM can't really say anything on that until my ISP fixes my connection had to drop my package down to 4mbit instead of 8mbit just so that my line wouldn't disconnect anymore (ADSL Line).

I'll report on the CPU usage If it happens again once I flash back to Ultralite v2 build tomorrow

@agusalex:
What is your internet speed? are you using the UltraLiteV2?


#150

Bad news guys, my router is bricked. The power went out while I was flashing it.
I will try to unbrick it when CP2102 module I ordered arrives from China.

If someone is willing to test the builds until I fix my router, let me know here or in the Telegram group.


#151

I flashed the UltraLiteV2 build back again, it's been running fine for the past hour... I will report back if anything comes up this time (Fingers Crossed)

@hmd61551:
Which router was it? did you make new builds apart from the ones in the original post up top?


#152

Ultra Lite V2 has been running more than 1 day on my WR841N V8 and I must say this is the best performance I have seen from this device for a very long time.

Thanks hmd61551 for taking the time to build and share these router images with us. I really appreciate it. Sorry to hear that you bricked your router, which model was it?


#153

Well, It's been 20 hours since my router has been up and CPU spiked only once and that was when my internet was disconnecting a lot and when I went to check the router's page CPU was ~4.0, Instead of rebooting or checking the CPU usage this time after a minute I just let it be and after 15 minutes when my line got stable and internet started to work I decided to go check the router and hey back to <1.00 CPU usage I guess my CPU usage only spiked because I opened the router GUI when it was constantly trying to connect the PPPoE interface to get an IP.

All in all everything else seems to work nicely no issues there yet.

Do have a question though not related to this build but ima ask it here anyway. Since I have a PPPoE connection do I need to manually change my MTU size to 1492 anywhere in the router? If yes then which interfaces MTU size do I change?

Edit:
If I leave the routers status page open after the CPU spike happens and goes back to normal CPU will instantly rise back up to ~3.00 usage. if I leave the router for 20 minutes and then open the GUI interface again CPU usage will be 0.02 something initially but will quickly rise.

Edit 2:
Rebooted the router and CPU usage is back to normal doesn't rise even if I leave the status page open.


#154

@greyfreak19 @rubab
It was 841nd v7 .


#155

I've installed lite version on wr841nd-v9. It works fine. But my ISP is using l2tp based billing. So I can't install required packages (ip, resolveip, kmod-l2tp, kmod-pppol2tp, ppp-mod-pppol2tp, xl2tpd) without opkg. I guess it possible to make by hand, but I don't know how. I was trying to compile binary image by myself, but got fail. I used ubuntu on the virtual machine. When image was compiling my macbook has restarted unexpectedly in reason of some error. I had the issue like this at a first time. May I ask some of you guys to compile bin image with required packages? Or 2nd way for me is soldering the ROM chip. I have one 16 MB flash chip. Are Winbond w25q128fv and tl-wr841nd-v9 compaitable? I'm sorry for my bad english, it's not my native language. Hope for your assistance


#156

Have a look here:


https://openwrt.org/docs/guide-developer/build-system/install-buildsystem
https://openwrt.org/docs/guide-developer/build-system/use-buildsystem

I'd recommend reading this too:
https://openwrt.org/supported_devices/432_warning
https://openwrt.org/docs/guide-user/additional-software/saving_space

Thanks again @hmd61551
ultralite v2 on 841 v8/9/11 work smoothly!**


#157

@hmd61551, thanks for bulids ! :slight_smile:


#158

OpenVPN build is updated.


#159

First of all, apologize for my bad English.

Total thanks to @hmd61551 for bulids, runs wonderfully, the router is TP-Link TL-WR740N v4

Sorry for my dare but it would not be possible to build ultralite v2 with sqm and adblock only or update the bulid of LADDUS

I appreciate the response, and thank this great community and their collaborators for the hard work that has involved in this build


#160

@hmd61551

Hi, I think that this could be interesting add to your builds: How to read TP-Link factory wireless pin from flash - art

It set factory SSID and KEY, the ones from bottom-label.


#161

thanks alot for these builds
i have WR940N V4 and am using ladus build and it is working great
am asking if there is a way to set daily download / upload quota as is gargoyle as i have limited data plan

thanks in advance


#162

I know it might be too much to ask. But I'm wondering if it's possible to have fast path included into ultra lite firmware (4MB flash)?