TP-Link TL-WR841N(D), WA701N(D), WR740N(D), WR741N(D), WR743N(D), WR940N, WR941N(D) - LADUS / JULIA / Ultra Lite / VPN builds


#121

Hello I just registered to thank you for the work you are doing! my V8 is flying with your LADUS build, thank you!!!


#123

Great work here. I have it on my 740n and it works great!


#125

Is there any chance to include WOL client?. Cheers.


#126

Will there be a new release Ultra Lite?


#127

DNScrypt by default and drop ipv6 for now imo.
BTW, how can I change the resolver im using to, lets say, Cisco/OpenDNS?

EDIT: Answering my own question, use WinSCP, go to /etc/config/dnscrypt-proxy and put "Cisco" on the resoler field: # option resolver 'cisco'
While I was there I decided to disable IPv6 support since I read there were some issues with OpenDNS and IPv6 (I read this on another thread tho).
Thanks.


#128

Can you create a new ultra lite version? please.


#129

Could you make a version with OpenVPN for v12?

As basic as possible, I just want to use the router as a VPN AP


#130

Hi.

I was looking to flash my router (841n v9) with LEDE for a while now but since it has 4mb flash I couldn't get SQM with Cake installed with the stable release (Main purpose of installing a custom firmware like this as my only goal is to get low latencies while the internet is being used) and as I couldn't really make my own build with the stuff I need I started searching and found this, perfect.

However...
after flashing the Julia build for the first time everything worked but after a few hours I started noticing really bad ping spikes and network slow down when I opened the router page which took a longer to load up I noticed that my CPU usage was really high exceeding the 1.00 mark going up as high to 4.00.I then flashed the ladus build (Flashed to the factory firmware first from the Julia build then flashed the ladus build) again the same thing happened after a while high CPU usage.

I then decided to go back to OpenWRT BB which has just enough space for me to install SQM but I really want to get UPNP and SQM with Cake on my router.


#131

Same issue here with 841n v10, high CPU usage making UI not respond and lag spikes.
Im working really hard on a openwrt CC 15 build with cake to solve this and if I get it to work I will post a link here.
It would be nice if OP could make a build (ULTRA LITE+SQM UPNP) as I think is what a lot of users are here for. Its really sad that these builds are unstable (at least for 841 v9 and v10).


#132

Sorry guys for not updating these builds.

@kunkun3012 @greyfreak19 @agusalex
Ultra Lite build will be updated tomorrow.
There will also be a new UltraLiteV2 build which will include upnp and sqm. It would be much appreciated if you guys could test it and give feedback.

Rest of the builds will be updated by the end of the week.


#133

thanks a lot you are the best! I just tried LADDUS on a 941-v4 and it worked flawlessly!! , so the problem seems to be with 841. Sure will try it!!
As a side note I failed miserably on the openwrt + cake build, the image builder and source code seems to be buggy with Cake I dont know whats the issue since I had succeded before without it.


#134

Ultra Lite build is updated.
UltraLiteV2 build with UPnP and SQM is uploaded.

Also, there is a Telegram Group link in first post, feel free to join if you want to chat.


#135

@hmd61551 I'm really glad to hear that will definitely give the new ultra lite build a go.
How ever I have an ADSL connection and will use PPPoE on the LEDE router will it still work properly with Ultra Lite v2?

P.S
Thank you so much dude for making a new build, You are the best. love you <3


#136

@greyfreak19 PPPoE is enabled in both UltraLite builds so there should not be any problems.


#137

Great :smile: I'm gonna flash the build right now then.

Update:
Flashed the build and set everything up wifi, sqm e.t.c. now I'll just use it normally for a few days and see if it all works fine :slight_smile: thanks again for all the work.


#138

If everything works fine, kindly post it here so that me and everyone else can use this version on our only router.


#139

Update:
Everything ran fine for the most part but the CPU usage spiked high again. This happened when my DSL modem resynced and then the LEDE router had to reconnect the PPPoE interface to get an IP address. when this happened the CPU spiked up refusing to come back down until I rebooted the router.


#140

I also use PPPoE(Wired) to connect to my ISP. But I am using WR841N v8 and using Gargoyle 1.8.1. My CPU usage from Gargoyle is showing this:
Memory Usage:14.8MB / 28.2MB (52.3%)
Connections:587/4096
CPU Load Averages:0.11 / 0.12 / 0.13 (1/5/15 minutes)

I am planning on moving from Gargoyle to LEDE but I am unsure if it will solve the random Wifi dropping issue I am getting with Gargoyle.


#141

Well, I did not occur any issues with gargoyle when using it. my one and only reason for switching to OpenWRT/LEDE Were the QOS while worked didn't cope well with my line and it used SFQ (From what I found out by scrolling the forums) instead of fq_codel/cake and also still gave me ping spikes upon launching an HD youtube video in the background.

Did not have any issues with the wifi though, Cpu usage was perfectly fine too apart from when browsing the router's GUI interface where I switched from one page to another too quickly.

LEDE wifi is working fine for me.

As for CPU spikes on LEDE whenever the wan interface syncs and gets any ip the CPU usage jumps from say 0.10 to 1.50> it does come back though but in some cases, it spikes too high and if I leave the status page open it seems to affect the CPU spike as well.


#142

Ultra Light V2 has given a new life to my TP-Link TL-WR841N v7, thanks a ton!