TP-Link TL-WR841N(D), WA701N(D), WR740N(D), WR741N(D), WR743N(D), WR940N, WR941N(D) - LADUS / JULIA / Ultra Lite / VPN builds


#101

Thank you sir @hmd61551!
Your SSH commands were precious for someone like me...
I will test it soon as I get home!


#102

Hello @hmd61551.

Thanks for OpenVPN build.
Flashed this morning, no problems in my network until now.

About OpenVPN, I have to learn first how to configure on LEDE. When I've done this, i will give feedback to you.

Regards.


#103

@hmd61551, welcome.

Another trick I find it useful , after finalized the build and confirmed the firmware is build successfully.

Try reduce the squashfs block size to 512 and rebuild. From what read from internet, it seems to reduce a bit of RAM usage of our precious 32MB

It didn't work for me cause I literally maximized the allowable size for my build
Hope it works for you

Thanks


#104

Hello @hmd61551! Your trick worked successfully! Thank you!
However I tried to go a little further and enter 20000 entries.
The router ran out of memory, and I had to reset...
I can see that the list from /tmp/dnsmasq.d/adb_list.hphost has nearly 50000. And i can edit him throught the vi as you teached me.
So my question is: where can I disable the lists from being updated?


#105

@cozinheiro Lists are updated only when you restart the router or your connection restarts.
You can also disable all the lists you do not want and use only blacklist you edited.


#106

Ultra Lite version should show more memory free than other versions. As it has less modules compared to others.


#107

14 hours uptime in TP-Link TL-WR941N/ND v2 with 23/03/17 OpenVPN build. Looking good!!! Is there any chance to include WOL? Cheers!


#108

Hello @hmd61551.

How are you?
Today i noticed something strange in my routers.
Just to remember, my config is: Main Router (server) ---- wds link ---- (client 1) ---- wds link ---- (client 2), etc.
The main router provides DHCP server and IPv6 address to all clients, that have a static IPv4 and DHCP server disabled.

Today, while checking the log of the routers, i noticed that all my client routers are loosing time sync (the main router is ok). I check the configuration, NTP Client checkbox is marked and servers are ok.
Do you have an idea what could be the problem? Or how to fix this?

Thanks.


#109

Hi everyone...

I followed this tutorial and solved my problem.
The link is below if someone has the same problem.

https://www.leowkahman.com/2016/01/06/openwrt-redirect-all-ntp-queries-to-specific-servers/

Juliano


#110

@hmd61551

A feedback about VPN build...
Looks like that router doesn't have enough CPU to run OpenVPN and SQM, so i flashed back JULIA build.

Juliano


#111

If OpenVPN & SQM is a must. Try these:

  • try to disable download SQM and only enable upload SQM
  • If ISP bandwidth is not a concern, perhaps you can use lz4 or disable compression on OpenVPN

It will lower the CPU pressure

Hope it helps


#112

Hello @lithoc .

Wich VPN server are you using?
Can you send to me your configuration files?
Maybe i was made something wrong when I test.

Thanks.


#113

I didn't use VPN . Sorry


#114

I would like to ask if support for TL-WR810N is possible? Thx in advance.


#115

Hello, I recently bought TL-WR841N v12 and i want to flash it with custom firmware but in every site i looked there is firmware only till version 11. And here i found that there is v12 but still no info and how to flash it. So can someone guide which version should i download and how to flash it? Also is it reversible ?


#116

v12 is the same as v11 and yes, it's reversible


#117

I have a TP_Link wr741nd HW 4.25 currently running openwrt-15.05.1-ar71xx-generic-tl-wr741nd and I have modded the AR9331 Chip to get the USB wires out.
Unfortunately there are kernel issues with the USB support in OpenWRT and I was wondering if these were fixed in LEDE.
I'd like to try LEDE and your custom build UltraLite looks interesting. I'm wondering however how much free space would I be able to use after flashing it. On OpenWRT to get 3G Dongle USB support I needed around 246KB for the following packages:
kmod-usb-core_3.18.23-1_ar71xx.ipk
kmod-nls-base_3.18.23-1_ar71xx.ipk
kmod-usb2_3.18.23-1_ar71xx.ipk
kmod-usb-serial_3.18.23-1_ar71xx.ipk
kmod-usb-serial-option_3.18.23-1_ar71xx.ipk
kmod-usb-serial-wwan_3.18.23-1_ar71xx.ipk
usb-modeswitch_2014-08-26-993a9a542791953c4804f7ddbb3a07756738e37a_ar71xx.ipk
libusb-1.0_1.0.19-1_ar71xx.ipk
libpthread_0.9.33.2-1_ar71xx.ipk
librt_0.9.33.2-1_ar71xx.ipk
luci-proto-3g_git-16.018.33482-3201903-1_all.ipk
comgt_0.32-25_ar71xx.ipk
chat_2.4.7-6_ar71xx.ipk

I guess you should add this information for your custom builds, if possible.

Thanks in advance!


#118

Hello @hmd61551.

There is a long time that can´t see you in the forum.
Is everything fine with you?

Juliano


#119

Hello @julianocs,

I got a new job and did not have much free time but I am gonna get back on updating these builds.

Updated builds are gonna be up on Thursday or Friday and I will probably get back on the promissed update schedule at the end of this month.


#120

LADUS build is updated.
WR841ND v12 was added.

There might be a problem with starting adblock service.
If that happens, ssh to your router and: /etc/init.d/adblock restart

You can now control the adblock service manually with /etc/init.d/adblock start/stop/restart/reload/suspend/resume/status or use the LuCI frontend.