TP-Link RE200 V3 refuses to install OpenWrt

Hi, I'm trying to install OpenWrt ona TP-Link repeater RE200 v3 using the repeater web ui, but is not working, the UI directly refuses to upload the image. A second after click the upgrade button the UI shows the error "Unable to upgrade."

Regarding the RE200:

**Firmware Version**: 1.1.3 Build 20210128 Rel. 60944(6582)
**Hardware Version**:  RE200 v3.0

An i'm taking the OpenWrt version from:
Factory version from https://firmware-selector.openwrt.org/?version=21.02.0&target=ramips%2Fmt76x8&id=tplink_re200-v3

Also, looking a bit under the hood, when i press the Upgrade button I see the UI is doing a POST to:

http://192.168.10.245/cgi-bin/luci/;stok=d70afc039e6ddeb7498704b8b8ec51a7/admin/firmware?form=upgrade

And the response from the repeater is a json:

{"errorcode":"err_failed","success":false}

with no other relevant information on the response headers.

So, i have no clue about why this is happening. looks like the repeater is refusing to upload a "non official firmware", which is weird when the're using opwnwrt and their UI is even using luci...

I also tried with a couple of versions of openwrt, and also upgraded the stock firmware to the same version (the only one available on tp-link website) with a different zone, but after try the install again the result was the same.

Do anyone saw something similar or have any recommendation?

Thanks in advance!!

This also makes the following impossible:

flash OpenWrt
revert to stock
flash OpenWrt again (fails because the firmware already has the version used by this image)

Hi @ulmwind , thanks for answer!
In my case I couldn't flash it with OpenWrt neither once, but i upgraded the stock image. So you think that upgrade is now stopping me of flash it with openwrt?

No, I do not know. There are differences between hardware versions, so please, make sure, you have correct version of hardware, and firmware.

Warning: 5Ghz radio on RE200 is broken (at least
In v2, probably also in v3 and v4).

More details at TP-Link RE200 Wi-Fi Broken

Thanks dsouza! :point_up_2:

I think this device needs a hardware improvement. IMHO It's a pity, as it's cheap, small, compact and in general looks good to be used at auxiliary tasks avoiding external power supplies, cables, etc. On my case i was only trying to using it to connect an eth device to my 5Ghz network.

Just bought TP-Link RE200 v3 (RU) and flashed w/ OpenWRT
Steps to reproduce:

  1. Install OEM firmware v1.1.0 (v1.1.2 out-of-box which refused to upload -factory.bin)
  2. Install -factory.bin via Web interface
  3. Wait

Note: wireless interfaces were disabled by default so I used network cable after flashing to access LuCI

@fabay Can you downgrade from v 1.1.3 to v1.1.0 and then try again to install OpenWrt?

1 Like

Hi, ok i'll try that tomorrow and let you know. Thanks!

In my case, that worked. Thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.