Tp-Link Archer c6 v3 not booting after install and LAN ports not working for TFTP recovery

Hi everyone!

I has install the OpenWrt in Tp-Link C6 v3 AC1200 following this page https://openwrt.org/toh/hwdata/tp-link/tp-link_archer_c6_v3 using the firmware upgrade webpage (GUI). the router has accepted and installed the firmware but after reload apparently they not boot.

The real problem is with recovery/debrick using TFTP, i trying recovery the original firmware using the 192.168.0.66 address and pressing reset + power button, but the router LAN ports not working, all led blinks, the power led lights on but nothing more works.

Inspecting the ethernet interface with wireshark noone package has sent from router when reset+power is tried.

:cry:

Known issue...

1 Like

Recover using the TFTP server method. Written for Windows users...but the concepts are the same for other OS.

Download the stock firmware...you may need to try more than one version.

The OpenWRT "factory" firmware can also be used if you don't want to go back to stock.

Download TFTP64.

Rename the downloaded firmware file to ArcherC6v3_tp_recovery.bin, and place it in the same folder as TFTPD64.

Open your network settings in Windows, and select the wired adapter (don't try this on a wireless connection).

Right-click and select Properties.

Select Internet Protocol Version 4 (TCP/IPv4) and click on the Properties button.

In the General tab, select the radio button for Use the Following IP Address.

Enter 192.168.0.66 for the IP address.

Should default to 255.255.255.0 for the Subnet Mask.

Turn the router off.

Make sure nothing else is connected to the router, it should be just the router and your computer.

Open TFTPD64. You may be asked to allow it through the firewall. Select Public.

Note: Some people turn off the firewall. However, giving the TFTP server permissions temporarily, and later removing them is a little safer, IMO.

Go to Settings > Global, and uncheck everything except TFTP Server.

Go to Settings > TFTP. Select None for TFTP security. Uncheck Option negotiation, and enter 192.168.0.66 in the Bind to this IP address drop down.

Go back to the main window, and make sure the Current Directory dropdown is showing the path to the TFTPD64 folder, which should also contain your recovery firmware file ArcherC6v3_tp_recovery.bin

The IP address 192.168.0.66 should be displayed in the Server Interface dropdown. If not, select it.

Go to the router and press the power button and the reset button at the same time.

Release the power button...but continue to hold the reset button for about 4 or 5 seconds, then release.

You should see a progress bar going across the TFTPD64 screen (although it should only take a very short time).

View the log. It should show 100% transferred.

Go back to your wired network adapter, and change the radio button back to Obtain an IP Address Automatically.

Try to access the router GUI. The stock firmware IP address is 192.168.0.1 and admin/admin for the User Id and Password.

If you can see that you have Internet access in the Network icon, but can't access the GUI, open a Command prompt and run ipconfig /release and then ipconfig /renew.

Try to access the GUI again.

1 Like

The same happened with my A6v3 (same hardware as c6 v3) 2 days ago. I flashed the latest firmware via sysupgrade and my router is dead. Only the power light turns on + no lan port is detected.

You now need to connect via UART to unbrick it.

1 Like

I tried UART without solder here, no success. My Macbook dit not open connection with router, no serial was detect. I will try again after with solder.

I already tried this method, unfortunately it doesn't work because no LAN ports work. I think my router is dead until i fixs this via UART/Serial :frowning_face:

TFTP will not work in this situation. UBOOT detects a valid kernel and is trying to load it. Since the kernel is valid it will not activate the web recovery.

Therefore a UART connection is required to manually activate the web recovery via serial console.

I successfully unbricked an Archer C6 v3.x this way (using UART console to activate the web recovery). More details below and let's continue the unbricking discussion there:

3 Likes

Hi guys, i fixed using UART today and all run fine now :slightly_smiling_face:

I bought other router of same model and now i have two and i will use this (un)bricked for test compilations.

Thanks all.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.